Subject: [Geopriv] WG Please READ! (was RE: HELD: range for frequency of location Requests forMobileDevices

From: "Mary Barnes" <[email-masked]>
Date: Fri, 12 Dec 2008 13:50:03 -0500

Hi all,

I'm finally back on task updating the document and in working through detailed changes, I realize there is still some confusion. Yes, Cullen did bring up the fact that the "several minutes" in section 6.5.2 should be better scoped to a specific recommendation, so I will change that to the "at least 30 minutes". 

I think the confusion arose because I believe this concern also relates back to section 6.2 which describes the locationType in the case of a location URI.  In general, I think the text in 6.2 is too specific on the mobile devices and we should remove that sentence altogether, since the normative information for a "locationURI" really should be in section 6.5.2.  Note, this was one of the suggestions I made in my response to Cullen, to which no one replied ;)
http://www.ietf.org/mail-archive/web/geopriv/current/msg06433.html

Also, note that the text in 6.2 was added as a result of WG feedback from Brian Rosen (in the -06) during the 1st WGLC:
http://www.ietf.org/mail-archive/web/geopriv/current/msg05491.html
Noting, that it was originally under the description of "any" and moved out of there in the -08.

To summarize, I will make the following changes to the HELD doc based on the above discussion:
1) Remove this sentence wrt mobile devices in section 6.2
   "If the LIS believes that the Device is
   mobile, that is, its location may change over relatively short
   periods of time (i.e., several minutes), it SHOULD return a location
   URI." 

2) Change the following sentence in section 6.5.2 as follows:
OLD:
   The "expires" attribute is RECOMMENDED not to exceed
   24 hours and SHOULD be a minimum of several minutes.

NEW: 
   The "expires" attribute is RECOMMENDED not to exceed
   24 hours and SHOULD be a minimum of 30 minutes.

Other than the following, the other changes discussed at IETF-73 are straightforward.

With regards to qualifying the scope of the URI from LIS discovery, I propose to make changes something like the following in section 4:
OLD:
   As described in the L7 LCP problem statement and requirements
   [I-D.ietf-geopriv-l7-lcp-ps], the Device must first discover the URI
   for the LIS for sending the HELD protocol requests.  The discovery
   methods are specified in [I-D.ietf-geopriv-lis-discovery].

NEW: 
   As described in the L7 LCP problem statement and requirements
   [I-D.ietf-geopriv-l7-lcp-ps], the Device MUST first discover the URI
   for the LIS for sending the HELD protocol requests.  The URI for the 
   LIS SHOULD be obtained from an authorized and authenticated entity. 
   The details for ensuring that an appropriate LIS is contacted are provided 
   in section 9 and in particular section 9.1.
   The LIS discovery protocol details are out of scope of this document and 
   are specified in [I-D.ietf-geopriv-lis-discovery]. The type of URI provided
   by LIS discovery is RECOMMENDED not be a general HTTP URI. 

Please provide any feedback or raise any concerns on these proposed changes ASAP. 

Thanks, 
Mary. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomson, Martin
Sent: Thursday, November 20, 2008 5:14 PM
To: [email-masked]; [email-masked]
Subject: Re: [Geopriv] HELD: range for frequency of location Requests forMobileDevices

Hi Gabor,

There was confusion in the meeting over what this number referred to.  I'd like to clear that up.  The original issue, which came from a review from Cullen, was that there was no guidance on how long a _location URI_ was to be good for.

The outcome of this discussion was that the recommendation would be "at least 30 minutes".  Which ensures that a location URI doesn't become unusable sooner. 

There are no suggestions on request intervals for mobile devices.  I'll strongly argue that that cannot and should not be a suggestion for location by value.  Polling might be convenient in some cases, but the appropriate rate will largely depend on the application.  No sensible suggestion can be made.

Cheers,
Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Thursday, 20 November 2008 2:15 PM
> To: [email-masked]
> Subject: [Geopriv] HELD: range for frequency of location Requests for 
> MobileDevices
> 
> During the HELD update presentation, the following question was raised:
> 
> 3. Specific range for frequency of location Requests for mobile 
> devices:
> § Currently = several minutes
> § Propose: change to >2 minutes and <10 minutes?
> 
> And there was a proposal to make that time interval 30min.
> 
> While 30min sounds more reasonable than ">2 minutes and <10 minutes", 
> I would note that a mobile device should not be required to make 
> location updates using HELD, unless the device will rely on HELD to 
> get its location for emergency call purposes.
> Currently mobile devices rely on L2 location information for that 
> purpose. And any unnecessary message exchanges consume battery life, 
> and that should be avoided.
> 
> Therefore, I would request to make this clarification when specifying 
> the time interval.
> 
> - Gabor
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender immediately and delete the original.  Any unauthorized use of this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 15 Dec 2008 16:14:46 -0600

Hi Mary,

I have no problem with the changes.

> Behalf Of Mary Barnes
> Sent: Saturday, 13 December 2008 5:50 AM
> To: Thomson, Martin; [email-masked]; [email-masked]
> Cc: Rosen, Brian
> Subject: [Geopriv] WG Please READ! (was RE: HELD: range for frequency
> oflocation Requests forMobileDevices
> 
> Hi all,
> 
> I'm finally back on task updating the document and in working through
> detailed changes, I realize there is still some confusion. Yes, Cullen
> did bring up the fact that the "several minutes" in section 6.5.2
> should be better scoped to a specific recommendation, so I will change
> that to the "at least 30 minutes".
> 
> I think the confusion arose because I believe this concern also relates
> back to section 6.2 which describes the locationType in the case of a
> location URI.  In general, I think the text in 6.2 is too specific on
> the mobile devices and we should remove that sentence altogether, since
> the normative information for a "locationURI" really should be in
> section 6.5.2.  Note, this was one of the suggestions I made in my
> response to Cullen, to which no one replied ;)
> Also, note that the text in 6.2 was added as a result of WG feedback
> from Brian Rosen (in the -06) during the 1st WGLC:
> With regards to qualifying the scope of the URI from LIS discovery, I
> propose to make changes something like the following in section 4:
> OLD:
> Behalf Of Thomson, Martin
> There was confusion in the meeting over what this number referred to.
> I'd like to clear that up.  The original issue, which came from a
> review from Cullen, was that there was no guidance on how long a
> _location URI_ was to be good for.
> 
> The outcome of this discussion was that the recommendation would be "at
> least 30 minutes".  Which ensures that a location URI doesn't become
> unusable sooner.
> 
> There are no suggestions on request intervals for mobile devices.  I'll
> strongly argue that that cannot and should not be a suggestion for
> location by value.  Polling might be convenient in some cases, but the
> appropriate rate will largely depend on the application.  No sensible
> suggestion can be made.
> 
> Cheers,
> Martin
> 
> This message is for the designated recipient only and may contain
> privileged, proprietary, or otherwise private information.
> If you have received it in error, please notify the sender immediately
> and delete the original.  Any unauthorized use of this email is
> prohibited.

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv