Subject: [Geopriv] Further uncertainty draft

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 3 Dec 2008 23:33:13 -0600

I've submitted a change to draft-thomson-geopriv-uncertainty.

Changes in -02:

 - The proposed confidence element for PIDF-LO has been removed.  It's not that I've decided that this is a bad idea, but I think that it distracts from the main purpose of the document.  The document now aims for Informational status.

 - A major mathematical error in the arc-band uncertainty calculation and a smaller error (21km or so) that occurs near the poles in the ecef-lla conversion have both been corrected.

 - A description on how to calculate polygon overlap, which is better in some cases than having to resort to circles.

 - A more thorough description of how to obscure a location estimate based on the (fairly loose) description in geopriv-policy (the previous version referred to a very old version of the policy document).

 - Based on the above change, is a discussion on using repeated requests to discover the "random" offset used to obscure a location estimate.  This proposes an augmentation to the algorithm proposed in geopriv-policy.

 - Matching updates to the examples.

 - A lot of editorial changes.

---

This is also a good point to publish the HELD client that I have implemented in Javascript.  It suffers badly from the same source restriction on XMLHttpRequest, but it serves quite well as a visualization tool for PIDF-LO.

  <http://held-location.sourceforge.net/held_js/pidflo.html>

The page is able to display all the shapes from PIDF-LO profile and applies the algorithms from the uncertainty draft to simplify the complex shapes.  Both the base shape and the simplified circular area (with centroid) are displayed.

[Apologies to those who don't have Firefox.  My testing budget doesn't extend to hair replacement, so there's a good chance that other browsers will die a messy death on this page.]

Cheers,
Martin
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: <[email-masked]>
Date: Tue, 9 Dec 2008 00:17:04 +0200

I have a question to section '1.2. Major Changes from RFC 3825' of the
draft:

  'The way in which uncertainty is described is changed from the
   previous version.'

I assume from the section heading that by previous version the authors
mean the encoding used in RFC 3825 and not any previous version of this
draft. But RFC 3825 does not use the term 'uncertaincy'. Could the
statement be clarified?

  'There was some confusion with the way that the
   word "resolution" was used in the previous version.'

I again assume that the text refers to the encoding used in RFC3825. Is
there any document available which describes the 'confusion' around the
usage of resolution in RFC3825? If yes, it would be very helpful if that
was added as a reference to the draft.

I personally would find very useful to have an example which compares
the RFC3825 encoding with the herein proposed new encoding and explains
why the resulting difference is significant enough to change the
encoding. If this is considered to be too trivial to be added to the
draft, an explanation posted to the mailing list would also be enough.

Thanks,
- Gabor

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 8 Dec 2008 16:28:29 -0600

Gabor,

I'd suggest that you do a little searching through the mailing list archives if you want to know a more about this topic.  It still hasn't been resolved.

Cheers,
Martin