Subject: [Geopriv] RFC 4776 Encoder/Decoder?

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 26 Dec 2008 14:50:09 +0200

Hi all, 

Some time ago Klaus published the RFC 3825 encoder/decoder, see 
http://www.enum.at/rfc3825encoder.529.0.html
Karl Heinz recently added the code to Wireshark. 

I wonder whether someone has written a similar encoder/decoder (something
like a reference code) for http://www.ietf.org/rfc/rfc4776.txt? 

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Sun, 28 Dec 2008 15:14:30 +0100

Hi Hannes!

I implemented a basic RFC 4776 encoder some time ago, it is available at:

http://ecrit.labs.nic.at/rfc4776.php

Wireshark 1.0 already includes my patch for decoding RFC 4776 location
information in DHCPv4.

So, encoding and decoding according to RFC 4776 is possible with these
two tools.

Cheers,
Karl Heinz