Subject: Re: [Geopriv] [Ecrit] draft-george-ecrit-lamp-post-00]

From: Robins George <[email-masked]>
Date: Thu, 26 Feb 2009 08:40:30 +0800

I 'd prefer using the PIDF-LO IANA procedure for adding a new element 
for lamp posts.
I think that re-using the address code is probably not a particularly 
good idea.

-robins

Karl Heinz Wolf wrote:
> Wouldn't the ADDCODE (Additional Code) element be a good place for the
> lamp number code?
>
> karl heinz
>
> On Tue, Feb 24, 2009 at 10:56 PM, Winterbottom, James
> <[email-masked]> wrote:
>   
>> A couple of things.
>>
>> First this should be posted to geopriv and ecrit.
>>
>> Secondly, could these not be covered by the LOC and landmark fields?
>>
>> Cheers
>> James
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of Robins George
>> Sent: Wednesday, 25 February 2009 2:24 PM
>> To: ECRIT IETF
>> Subject: [Ecrit] draft-george-ecrit-lamp-post-00]
>>
>> Hi All,
>>
>> I have submitted a draft which describes an extension to civic location
>> format and
>> adds new element PN (pole number). PN carries utility and lamp post
>> number
>> information which can identify a civic location.
>>
>> http://tools.ietf.org/html/draft-george-ecrit-lamp-post-00
>>
>> Comments are appreciated.
>>
>> Regards,
>> Robins.
>>
>>
>>
>>
>>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 25 Feb 2009 20:01:58 -0500

Robins,

Given that your use case may be of a more local than global nature, I 
wonder if it would be appropriate to instead set a local standard that 
maps to the global (RFC 5139) standard.  We've been working on a 
document that has recommendations for how to do that:
<http://tools.ietf.org/html/draft-ietf-geopriv-civic-address-recommendations>

--Richard

Robins George wrote:
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 25 Feb 2009 20:05:40 -0500

Sorry, didn't mean to cross-post.  Please keep this discussion on 
GEOPRIV from now on.
--Richard

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 25 Feb 2009 18:50:58 -0600

Moving to GEOPRIV...

Personal preference usually has little bearing on finding the correct solution.  If ADDCODE fits, then you should consider it.  Extensions to the civic address format need to provide information that cannot be provided by existing elements.

If you are aware that ADDCODE could be used in the same context as a lamp/pole number, then a new code might be appropriate.  ADDCODE was created for a purpose very similar to what you describe - a locally significant number.  Alternatively, if you believe that there are usability concerns arising from use of ADDCODE, then that might also be a basis for a new element.

As background, I've heard a range of suggestions for new elements, but each in turn has been amply accommodated by existing elements.  This approach has been taken in draft-ietf-geopriv-civic-address-recommendations - Austrian civic addresses contain far more discrete elements than the civic address format provides, but the local policy for mapping to the civic address form manages with the existing elements.

Regards,
Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Robins George
> Sent: Thursday, 26 February 2009 11:41 AM
> To: Karl Heinz Wolf
> Cc: GEOPRIV; ECRIT IETF
> Subject: Re: [Geopriv] [Ecrit] draft-george-ecrit-lamp-post-00]
> 
> 
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 26 Feb 2009 07:35:33 -0500

Richard,

pole numbers are actually fairly common and don't seem to be  
restricted to a particular country. For example, in New Jersey (where  
I live), towns are so close together that it is often difficult to  
tell which one you are in at the moment. The "insider" recommendation  
is to look at the nearest utility pole; the first two letters  
correspond to the town name (followed by a unique numeric identifier).

Henning

On Feb 25, 2009, at 8:01 PM, Richard Barnes wrote:

> Robins,
>
> Given that your use case may be of a more local than global nature,  
> I wonder if it would be appropriate to instead set a local standard  
> that maps to the global (RFC 5139) standard.  We've been working on  
> a document that has recommendations for how to do that:
> <http://tools.ietf.org/html/draft-ietf-geopriv-civic-address-recommendations 
> >
>
> --Richard
>
>
> Robins George wrote:
>> I 'd prefer using the PIDF-LO IANA procedure for adding a new  
>> element for lamp posts.
>> I think that re-using the address code is probably not a  
>> particularly good idea.
>> -robins
>> Karl Heinz Wolf wrote: