Subject: [Geopriv] Scope of 3825 fixes

From: Richard Barnes <[email-masked]>
Date: Sun, 29 Mar 2009 22:09:39 -0400

Hi all,

Assuming the consensus expressed in the GEOPRIV meeting (to fix, not
replace 3825) is confirmed by the list, I would like to get a feeling
for what scope should be allowed for these fixes.

There are 4 modifications that have been proposed across the 3 drafts:
1. Addition of a switch that changes the meaning of the "*res" fields
2. Deprecation of the "floor" altitude type
3. Addition of an uncertainty radius (i.e., a GML circle)
4. Switch to a TLV-based geo-element format

Number (1) seems clearly in scope, since this is the fix that was agreed
to at IETF 71 (Philadelphia).

Number (4) seems clearly out of scope, since it breaks backward
compatibility and substantially replaces RFC 3825.

What do people think about (2) and (3)?

--Richard

---

From: "Winterbottom, James" <[email-masked]>
Date: Sun, 29 Mar 2009 21:14:28 -0500

Hi Richard,

I think that 3 is as out of scope as 4 and can't really be done without
replacing 3825.

I don't mind about 2 so much.

Cheers
James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Richard Barnes
Sent: Monday, 30 March 2009 1:10 PM
To: 'GEOPRIV'
Subject: [Geopriv] Scope of 3825 fixes

Hi all,

--Richard

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 29 Mar 2009 23:27:34 -0400

I'm in favor of (2). Since this won't break old implementations (if  
there are any...), this satisfies backward-compatibility.

(4) is indeed well out of scope.

---

From: <[email-masked]>
Date: Mon, 30 Mar 2009 18:46:36 +0200

I am in favor of (1) and against (2),(3),(4).

- gabor

  >Behalf Of ext Henning Schulzrinne
  >Sent: Sunday, March 29, 2009 8:28 PM
  >To: Richard Barnes
  >Cc: 'GEOPRIV'
  >Subject: Re: [Geopriv] Scope of 3825 fixes
  >

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 30 Mar 2009 17:51:38 -0500

1 we should do - yes.
2 I don't care about.
3 we don't need to do - no.
4 definitely not - no.

> Sent: Sunday, 29 March 2009 7:10 PM
> To: 'GEOPRIV'