Subject: [Geopriv] draft-barnes-geopriv-lo-sec-05 - Positioning Protocol

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 15 Mar 2009 11:26:03 +0200

A few comments on the Positioning section in
http://tools.ietf.org/html/draft-barnes-geopriv-lo-sec-05

As shown in Figure 3 the positioning protocol runs between the Target and
the Location Generator. 

So far, the LG (with the previously used terminolog) didn't really play an
important role in our architecture (as we didn't work on protocols between
the LG and Target / LG and the LIS). FLAP, in my view, would have been such
a protocol that runs between the LG and the LS. 

When reading through Section 3.1.1 one could get the impression that HELD
(and the other LCPs) would be such positioning protocols (and the LG could
be labeled LIS) but the documents states that LCPs are now conveyance
protocols. 

The privacy section (Section 3.1.2) is quite confusing as it mixes LG and LS
and sometimes speaks of the LG as the initial LS.
Statements are made that the Target should send privacy rules to the LG. 

Overall I have to say, I am not sure there is a lot of value in introducing
this entity. What are examples of positioning protocols?

---

From: "Winterbottom, James" <[email-masked]>
Date: Sun, 15 Mar 2009 04:52:39 -0500

Hi Hannes,

FLAP is a protocol for providing measurements about network attachment from an entity in the network to the LIS. The LIS is still the entity, at least n most cases, that provides the context needed for the provided measurements to be turned into a location.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Hannes Tschofenig
Sent: Sun 3/15/2009 4:26 AM
To: 'GEOPRIV'
Subject: [Geopriv] draft-barnes-geopriv-lo-sec-05 - Positioning Protocol
 
A few comments on the Positioning section in http://tools.ietf.org/html/draft-barnes-geopriv-lo-sec-05 <http://tools.ietf.org/html/draft-barnes-geopriv-lo-sec-05>  

As shown in Figure 3 the positioning protocol runs between the Target and the Location Generator. 

So far, the LG (with the previously used terminolog) didn't really play an important role in our architecture (as we didn't work on protocols between the LG and Target / LG and the LIS). FLAP, in my view, would have been such a protocol that runs between the LG and the LS. 

When reading through Section 3.1.1 one could get the impression that HELD (and the other LCPs) would be such positioning protocols (and the LG could be labeled LIS) but the documents states that LCPs are now conveyance protocols. 

The privacy section (Section 3.1.2) is quite confusing as it mixes LG and LS and sometimes speaks of the LG as the initial LS.

Overall I have to say, I am not sure there is a lot of value in introducing this entity. What are examples of positioning protocols? 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 15 Mar 2009 11:00:13 -0400

We've had a history, in my opinion, of trying to label all kinds of  
protocols ("using protocol" being an infamous example). These efforts  
seem to mainly yield philosophical discussions of interest to a  
handful of GEOPRIV veterans, with no adoption anywhere else. Instead  
of trying to categorize various protocols, typically with a set size  
of one or two, we can try to identify the differences we care about.  
It is also clear by now that some protocols can deliver location both  
to the target, the owner of the target and to third parties.

Thus, overall, I'm not sure I see the point of having fine-grained  
terminology. Rather, it might be more productive to say "if a protocol  
does X, it needs to take these security precautions." What matters is  
whether the information has PII (personally-identifiable information)  
characteristics and what the relationship is between the target/owner  
and the recipient of the data.

Henning

On Mar 15, 2009, at 5:26 AM, Hannes Tschofenig wrote:

> A few comments on the Positioning section in http://tools.ietf.org/html/draft-barnes-geopriv-lo-sec-05
>
> So far, the LG (with the previously used terminolog) didn't really  
> play an important role in our architecture (as we didn't work on  
> protocols between the LG and Target / LG and the LIS). FLAP, in my  
> view, would have been such a protocol that runs between the LG and  
> the LS.
>
> When reading through Section 3.1.1 one could get the impression that  
> HELD (and the other LCPs) would be such positioning protocols (and  
> the LG could be labeled LIS) but the documents states that LCPs are  
> now conveyance protocols.
>
> The privacy section (Section 3.1.2) is quite confusing as it mixes  
> LG and LS and sometimes speaks of the LG as the initial LS.
>
> Overall I have to say, I am not sure there is a lot of value in  
> introducing this entity. What are examples of positioning protocols?
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 15 Mar 2009 20:37:40 +0200

Right.

A protocol between the LG and the LIS is IMHO a mechanism to collect
measurements. 

So, the positioning terminology is confusing for me 

>From: Winterbottom, James [mailto:[email-masked]] 
>Sent: 15 March, 2009 11:53
>To: Hannes Tschofenig; GEOPRIV
>Subject: RE: [Geopriv] draft-barnes-geopriv-lo-sec-05 - 
>Positioning Protocol
>
>Hi Hannes,
>
>FLAP is a protocol for providing measurements about network 
>attachment from an entity in the network to the LIS. The LIS 
>is still the entity, at least n most cases, that provides the 
>context needed for the provided measurements to be turned into 
>a location.
>
>
>Cheers
>James
>
><http://tools.ietf.org/html/draft-barnes-geopriv-lo-sec-05>  
>
>So far, the LG (with the previously used terminolog) didn't 
>really play an important role in our architecture (as we 
>didn't work on protocols between the LG and Target / LG and 
>the LIS). FLAP, in my view, would have been such a protocol 
>that runs between the LG and the LS. 
>
>When reading through Section 3.1.1 one could get the 
>impression that HELD (and the other LCPs) would be such 
>positioning protocols (and the LG could be labeled LIS) but 
>the documents states that LCPs are now conveyance protocols. 
>
>The privacy section (Section 3.1.2) is quite confusing as it 
>mixes LG and LS and sometimes speaks of the LG as the initial LS.
>
>Overall I have to say, I am not sure there is a lot of value 
>in introducing this entity. What are examples of positioning 
>protocols? 
>
>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 15 Mar 2009 20:39:54 +0200

I fully agree. Even we have a hard time figuring out what the differences
are with a lot of the terms. 

In my other mail I suggested some dramatically simplified terminology.  

>From: Henning Schulzrinne [mailto:[email-masked]] 
>Sent: 15 March, 2009 17:00
>To: Hannes Tschofenig
>Cc: 'GEOPRIV'
>Subject: Re: [Geopriv] draft-barnes-geopriv-lo-sec-05 - 
>Positioning Protocol
>
>We've had a history, in my opinion, of trying to label all 
>kinds of protocols ("using protocol" being an infamous 
>example). These efforts seem to mainly yield philosophical 
>discussions of interest to a handful of GEOPRIV veterans, with 
>no adoption anywhere else. Instead of trying to categorize 
>various protocols, typically with a set size of one or two, we 
>can try to identify the differences we care about.  
>It is also clear by now that some protocols can deliver 
>location both to the target, the owner of the target and to 
>third parties.
>
>Thus, overall, I'm not sure I see the point of having 
>fine-grained terminology. Rather, it might be more productive 
>to say "if a protocol does X, it needs to take these security 
>precautions." What matters is whether the information has PII 
>(personally-identifiable information) characteristics and what 
>the relationship is between the target/owner and the recipient 
>of the data.
>
>Henning
>
>> As shown in Figure 3 the positioning protocol runs between 
>the Target 
>> and the Location Generator.
>>
>> view, would have been such a protocol that runs between the 
>LG and the 
>> LS.
>>
>> HELD (and the other LCPs) would be such positioning 
>protocols (and the 
>> LG could be labeled LIS) but the documents states that LCPs are now 
>> conveyance protocols.
>>
>mixes LG 
>> and LS and sometimes speaks of the LG as the initial LS.
>>

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 15 Mar 2009 21:37:34 -0500

One problem with these discussions is that they ascend into the abstract quite a ways before we can agree.  That might be symptomatic of other problems, but it's not really something I'm overly concerned with as long as the abstraction only affects us, and not the ultimate product of our work.

As I commented in my review, there is no need for an LG-LS "protocol".  The LS role is assumed by the entity that had the LG role.  A label for such an interface isn't really that helpful either.

However, I'm not entirely against the idea of a positioning protocol, not as a label for a particular thing, but more for what it does to label the function.  The lo-sec draft talks about the function and suggests the existence of a protocol where a network entity (my label: a LIS) cooperates with a device to determine the location of the device.  That's a function that is embodied in held-measurements and a number of the other drafts that I've proposed.  I am strongly supportive of any efforts to standardize on these interfaces, in the hopes that some semblance of sense comes out of the proprietary muck that is status quo.

My thought is that this is a good catalyst for some discussions.  Someone noted in Dublin that this was something we'd have to deal with one way or other at some point.  I'm glad that the authors of this document are willing to at least open discussions.

Cheers,
Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Hannes Tschofenig
> Sent: Monday, 16 March 2009 5:38 AM
> To: Winterbottom, James; 'GEOPRIV'
> Subject: Re: [Geopriv] draft-barnes-geopriv-lo-sec-05 - Positioning
> Protocol
> 
> Right.
>