Subject: [Geopriv] I-D Action:draft-ietf-geopriv-dhcp-lbyr-uri-option-04.txt

From: [email-masked]
Date: Mon, 9 Mar 2009 16:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Geographic Location/Privacy Working Group of the IETF.

	Title           : Dynamic Host Configuration Protocol (DHCP) IPv4 and IPv6 Option for a Location Uniform Resource Identifier (URI)
	Author(s)       : J. Polk
	Filename        : draft-ietf-geopriv-dhcp-lbyr-uri-option-04.txt
	Pages           : 13
	Date            : 2009-03-09

This document creates a Dynamic Host Configuration Protocol (DHCP) 
Option for the downloading of a Uniform Resource Identifier (URI) 
pointing to the geolocation record of an endpoint.  This URI, called
a Location-by-Reference (LbyR), points to a record on a location 
server which tracks the geolocation of the endpoint.  Once 
downloaded by an endpoint, this LbyR can be forwarded to another 
entity, to be dereferenced if this entity wants to learn the 
geolocation of the sender endpoint.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-dhcp-lbyr-uri-option-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 10 Mar 2009 15:33:13 -0500

Geopriv

I have revved the DHCP LbyR Option WG draft (to -04).

Here's what's changed in this version:

- I have added the IPv6 Option format, which was not present before

- I have completely redone the format to follow the 
'type/length/value' format introduced in RFC 4776 (civic location).

- I have changed the 'valid-for' header field into a LbyrElement, 
thus implying this is optional to have present in Option. This is the 
equivalent to the previous 'valid-for' header field having all zeros, 
so this isn't much of a change other than where it is in the Option.

- I have added a 4-bit version header field, and added a 4-bit 
reserved field (for future).

I hope this format change is acceptable to the WG, as this should 
make implementations easier - given the common 'type/length/value' 
format introduced in RFC 4776 is now in this Option as well.

comments are welcome

James

At 06:00 PM 3/9/2009, [email-masked] wrote:
>         Title           : Dynamic Host Configuration Protocol 
> (DHCP) IPv4 and IPv6 Option for a Location Uniform Resource Identifier (URI)