Subject: [Geopriv] WG Review: Recharter of Geographic Location/Privacy (geopriv)

From: IESG Secretary <[email-masked]>
Date: Tue, 9 Jun 2009 09:00:01 -0700 (PDT)

A modified charter has been submitted for the Geographic Location/Privacy
(geopriv) working group in the Real-time Applications and Infrastructure
Area of the IETF.  The IESG has not made any determination as yet.  The
modified charter is provided below for informational purposes only. 
Please send your comments to the IESG mailing list ([email-masked]) by
Tuesday, June 16, 2009.

Geographic Location/Privacy (geopriv)
--------------------------------------
Last Modified: 2009-05-29

Chair(s):
- Richard Barnes <[email-masked]>
- Alissa Cooper <[email-masked]>

Real-time Applications and Infrastructure Area Director(s):
- Robert Sparks <[email-masked]>
- Cullen Jennings <[email-masked]>

Real-time Applications and Infrastructure Area Advisor:
- Cullen Jennings <[email-masked]>

Technical Advisor(s):
- Lisa Dusseault <[email-masked]>

Mailing Lists:
General Discussion: [email-masked]
To Subscribe: [email-masked]
In Body: subscribe
Archive: http://www.ietf.org/mail-archive/web/geopriv/index.html

Description of Working Group:

The IETF has recognized that many applications are emerging that
require geographic and civic location information about resources and
entities, and that the representation and transmission of that
information has significant privacy and security implications. We have
created a suite of protocols that allow such applications to represent
and transmit such location objects and to allow users to express
policies on how these representations are exposed and used. The IETF
has also begun working on creating applications that use these
capabilities, for emergency services, general real-time communication,
and other usages.

The GEOPRIV working group is chartered to continue to develop and
refine representations of location in Internet protocols, and to
analyze the authorization, integrity, and privacy requirements that
must be met when these representations of location are created,
stored, and used. The group will create and refine mechanisms for the
transmission of these representations that address the requirements
that have been identified.

The working group will work with other IETF working groups and other
standards development organizations that are building applications
that use location information to ensure that the requirements are well
understood and met, and that no additional security or privacy issues
related to location are left unaddressed as these location information
is incorporated into other protocols.

It remains a goal of the GEOPRIV working group to deliver
specifications of broad applicability that will become mandatory to
implement for IETF protocols that are location aware.

This working group will not develop location-determining technology.
However, the IETF acknowledges that information used in the location-
determination process will in some cases need to be carried over the
Internet. Where necessary, this working group will develop protocols
or protocol extensions to encode location-determination data
structures defined elsewhere. This working group will not develop
technologies to directly address any particular regulatory
requirements (e.g. 9-1-1). The group will continue to coordinate with
any other IETF entities that are working on those problems to ensure
the technologies created here meet the needs of those entities, and
that the authorization, integrity, and privacy requirements on the
mechanisms provided by these technologies continue to be met.

Goals and Milestones:

Done Discuss initial geopriv scenarios and application requirements 
     i-d's
Done Discuss initial geographic location privacy and security
     requirements i-d.
Done Initial i-d on geographic information protocol design, including
     privacy and security techniques.
Done Review charter and initial i-ds with AD, and have IESG consider
     rechartering if necessary.
Done Submit geopriv scenarios and application requirements to IESG for
     publication as Informational RFCs
Done Submit security/privacy requirements I-D to IESG for publication 
     As Informational RFC.
Done Submit PIDF-LO basic geopriv object draft as a PS
Done Initial Common Rules base object draft
Done Initial Common Rules GEOPRIV object draft
Done Submit DHCP Civil draft as a PS
Done Resubmit Conveying Location Objects in RADIUS and Diameter to
     the IESG for publication as PS
Done Submit Additional Civic PIDF-LO types (updating 4119) to the
     IESG for publication as PS
Done Submit minimal HTTP based protocol satisfying baseline
     requirements specified in the Layer 7 Location Conveyance Protocol 
     Problem Statement and Requirements to the IESG for publication as 
     PS
Done Submit PIDF-LO Usage Clarifications and Recommendations
     (updating 4119) to the IESG for publication as PS
Done Submit Layer 7 Location Conveyance Protocol Problem Statement
     and Requirements to the IESG for publication as Informational
Done Submit recommendations for representing civic addresses in
     PIDF-LO to the IESG for publication as BCP
Done Submit Recommendations for Retransmission in SIP Location
     Conveyance to the IESG for publication as Informational
Done Submit Requirements for Location by Reference Protocols to
     the IESG for publication as Informational
Done Submit a LIS Discovery Mechanism to the IESG for publication as a
     PS
Jun 2009 Resubmit Geolocation Policy to the IESG for publication as PS
Sep 2009 Submit an draft for DHCP geodetic location to the IESG for
     publication as PS to obsolete 3825
Sep 2009 Submit an Architecture for Location and Location Privacy
     to the IESG for publication as Informational
Dec 2009 Submit a URI scheme for directly expressing geodetic location
     to the IESG for publication as PS
Dec 2009 Submit a DHCP Option for a Location Uniform Resource
     Identifier (URI) to the IESG for publication as PS
Dec 2009 Submit a Document Format for Filtering and Reporting PIDF-LO
     Location Notifications to the IESG for publication as PS

---

From: <[email-masked]>
Date: Tue, 16 Jun 2009 10:33:02 -0400

Hi,

I kindly ask that draft-winterbottom-geopriv-held-identity-extensions be considered for inclusion in the rechartered geopriv Goals and Milestones. As discussed at the June 2008 geopriv interim meeting, this extension to the basic HELD protocol is required for some deployments.

Thanks,

Guy

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de IESG Secretary
Envoyé : 9 juin 2009 12:00
À : [email-masked]
Cc : [email-masked]
Objet : [Geopriv] WG Review: Recharter of Geographic Location/Privacy (geopriv)

Chair(s):

Technical Advisor(s):

Mailing Lists:

Goals and Milestones:

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: [email-masked]
Date: Tue, 16 Jun 2009 16:03:59 +0100

> I kindly ask that draft-winterbottom-geopriv-held-identity-
> extensions be considered for inclusion in the rechartered geopriv 
> Goals and Milestones. As discussed at the June 2008 geopriv interim 
> meeting, this extension to the basic HELD protocol is required for 
> some deployments.

me too!

The document is required for the UK emergency services architecture work.

Ray

-- 
Ray Bellis, MA(Oxon) MIET
Senior Researcher in Advanced Projects, Nominet
e: [email-masked], t: +44 1865 332211

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 16 Jun 2009 19:29:59 +0300

Thanks for raising this issue, Guy. 

I agree with you. 

Ciao
Hannes

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext [email-masked]
	Sent: 16 June, 2009 18:04
	To: [email-masked]
	Cc: [email-masked]; [email-masked]; [email-masked]
	Subject: Re: [Geopriv] WG Review: Recharter ofGeographic
Location/Privacy (geopriv)

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 16 Jun 2009 12:19:59 -0500

I would like to see a milestone for this also.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Wednesday, 17 June 2009 2:30 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [Geopriv] WG Review: RecharterofGeographic
Location/Privacy
> (geopriv)

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 16 Jun 2009 11:13:59 -0700

+1

> From: [email-masked]
> To: [email-masked]
> Date: Tue, 16 Jun 2009 10:33:02 -0400
> CC: [email-masked]
> Subject: Re: [Geopriv] WG Review: Recharter of Geographic Location/Privacy (geopriv)
> 
> Hi,
>

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 16 Jun 2009 15:26:55 -0700

Would people advise that we remove any of the currently proposed  
milestones until after the identity and work it depends on got  
completed?

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 16 Jun 2009 20:31:31 -0500

The work on filters is far less mature than the identity work.  Unless Brian has hidden wonders in store, I'd suggest that that work can wait.

--Martin

> Behalf Of Cullen Jennings
> Sent: Wednesday, 17 June 2009 8:27 AM
> To: <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Geopriv] WG Review: Recharter of
> GeographicLocation/Privacy (geopriv)
> 
>

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 17 Jun 2009 19:05:44 -0400

Although the XML is undergoing substantial change, the basic filter mechanisms have, I believe, stabilized.  In conjunction with the throttle and basic 4661 filter, when we get the XML right (meaning, in alignment with 4661), then I think we're done.

So, I don't think it's far less mature.

Brian

> Behalf Of Thomson, Martin
> Sent: Tuesday, June 16, 2009 9:32 PM
> To: Cullen Jennings; [email-masked]
> The work on filters is far less mature than the identity work.  Unless
> Brian has hidden wonders in store, I'd suggest that that work can wait.
> 
> --Martin
> 
> > > Done Submit a LIS Discovery Mechanism to the IESG for publication
> as
> > a
> > >     PS

---

From: "Dawson, Martin" <[email-masked]>
Date: Wed, 17 Jun 2009 23:36:52 -0500

While that matter of degree is open to interpretation, we've heard from a number of stakeholders who actually need to implement the identity extension work. Can the same be said for filters?

Cheers,
Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Thursday, 18 June 2009 9:06 AM
To: Thomson, Martin; 'Cullen Jennings'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Geopriv] WG Review: Recharterof GeographicLocation/Privacy (geopriv)

Brian

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 18 Jun 2009 01:04:59 -0500

Martin

Thinking out loud - what's preventing those 
stakeholders from implementing what's in the 
identity ext work? Surely it's not because it's not an RFC..?

James

At 11:36 PM 6/17/2009, Dawson, Martin wrote:
>While that matter of degree is open to 
>interpretation, we've heard from a number of 
>stakeholders who actually need to implement the 
>identity extension work. Can the same be said for filters?
>
>Cheers,
>Martin
>
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Brian Rosen
>Although the XML is undergoing substantial 
>change, the basic filter mechanisms have, I 
>believe, stabilized.  In conjunction with the 
>throttle and basic 4661 filter, when we get the 
>XML right (meaning, in alignment with 4661), then I think we're done.
>

---

From: "Dawson, Martin" <[email-masked]>
Date: Thu, 18 Jun 2009 01:36:06 -0500

It's always better to have proper referenceable specification. Drafts expire. An RFC provides some assurance that things won't change radically and, in any case, the specific RFC is at least permanently referenceable. The stakeholders are going to need to ask vendors for interoperable implementations.

Otherwise, I guess we wouldn't care about anything becoming an RFC.

Cheers,
Martin

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Thursday, 18 June 2009 4:05 PM
To: Dawson, Martin; Brian Rosen; Thomson, Martin; Cullen Jennings; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Geopriv] WG Review: Recharterof GeographicLocation/Privacy (geopriv)

Martin

James

---

From: [email-masked]
Date: Thu, 18 Jun 2009 08:37:50 +0100

> identity ext work? Surely it's not because it's not an RFC..?

Some of the stakeholders are other SDOs, who like the IETF have rules 
against normative references to incomplete standards.

Ray

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 18 Jun 2009 09:02:42 -0400

Yes, we have

> From: Dawson, Martin [mailto:[email-masked]]
> Sent: Thursday, June 18, 2009 12:37 AM
> To: Brian Rosen; Thomson, Martin; Cullen Jennings; [email-masked]
> Subject: RE: [Geopriv] WG Review: Recharterof
> While that matter of degree is open to interpretation, we've heard from
> a number of stakeholders who actually need to implement the identity
> extension work. Can the same be said for filters?
> 
> Cheers,
> Martin
> 
> Behalf Of Brian Rosen
> Although the XML is undergoing substantial change, the basic filter
> mechanisms have, I believe, stabilized.  In conjunction with the
> throttle and basic 4661 filter, when we get the XML right (meaning, in
> alignment with 4661), then I think we're done.
> 
> > > > De : [email-masked] [mailto:[email-masked]]
> De
> > > > la part de IESG Secretary
> > > > A modified charter has been submitted for the Geographic
> Location/
> > > > Privacy
> > > > Area of the IETF.  The IESG has not made any determination as
> yet.
> > > > The
> > > > Please send your comments to the IESG mailing list
> ([email-masked])
> > by
> > > > Tuesday, June 16, 2009.
> > > >
> > > >
> > > > Done Submit geopriv scenarios and application requirements to
> IESG
> > > for
> > > >     Problem Statement and Requirements to the IESG for
> publication
> > as
> > > >     PS
> > > > Jun 2009 Resubmit Geolocation Policy to the IESG for publication
> as
> > > PS
> > > > Dec 2009 Submit a Document Format for Filtering and Reporting
> PIDF-
> > LO
> > ---------------------------------------------------------------------
> --
> > -------------------------
> > ---------------------------------------------------------------------
> --
> > -------------------------
> > [mf2]

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 18 Jun 2009 16:14:38 -0700

Folks,

The discussion around the milestone is separate from the charter text.  
There seemed to be no problem with the charter text so the IESG  
approved the new charter today. It webpage will be update with the the  
milestones that were attached to charter but theses can be changed as  
appropriate. The important part about this update is now we can add  
milestones related to transport of measurement data. Lets continue the  
discussion around how to sequence this work and then Robert and I can  
update the milestones.

Cullen <RAI AD>

On Jun 17, 2009, at 23:36 , Dawson, Martin wrote:

> It's always better to have proper referenceable specification.  
> Drafts expire. An RFC provides some assurance that things won't  
> change radically and, in any case, the specific RFC is at least  
> permanently referenceable. The stakeholders are going to need to ask  
> vendors for interoperable implementations.
>
> On
> > > > > De : [email-masked] [mailto:geopriv- 
> [email-masked]] De
> > > > > Area of the IETF.  The IESG has not made any determination  
> as yet.
> > > > > The
> > > > > Please send your comments to the IESG mailing list ([email-masked] 
> )
> > > by
> > > > > Tuesday, June 16, 2009.
> > > > >
> > > > >
> > > > > require geographic and civic location information about  
> resources
> > > and
> > > > > information has significant privacy and security  
> implications. We
> > > > have
> > > > > policies on how these representations are exposed and used.  
> The
> > > IETF
> > > > > stored, and used. The group will create and refine  
> mechanisms for
> > > the
> > > > > that use location information to ensure that the  
> requirements are
> > > > well
> > > > > determination process will in some cases need to be carried  
> over
> > > the
> > > > > requirements (e.g. 9-1-1). The group will continue to  
> coordinate
> > > with
> > > > > Done Submit geopriv scenarios and application requirements  
> to IESG
> > > > for
> > > > > Jun 2009 Resubmit Geolocation Policy to the IESG for  
> publication as
> > > > PS
> > > > > Dec 2009 Submit a Document Format for Filtering and  
> Reporting PIDF-
> > > LO

---

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 18 Jun 2009 21:34:17 -0500

Thanks Cullen.

I am definitely happy with the charter text, as you point out it is the milestones that some of us are less thrilled about.
I will post a proposal tomorrow.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Cullen Jennings
Sent: Thu 6/18/2009 6:14 PM
To: GEOPRIV
Subject: Re: [Geopriv] WGReview:Recharterof	GeographicLocation/Privacy	(geopriv)

Folks,

Cullen <RAI AD>