Subject: [Geopriv] Plan for 3825bis

From: Richard Barnes <[email-masked]>
Date: Tue, 02 Jun 2009 21:04:28 -0400

Hi all,

Wanted to send an update outlining a little bit of process for how we're
going to manage the production of a 3825bis document.  Because there is
a desire in the group to manage carefully the differences between this
update and RFC 3825, we'll use the following process:

1. The -00 draft will just be RFC 3825 with updated boilerplate.

2. Issues and proposed resolutions will be proposed to the list and
entered as tickets for the milestone draft-ietf-geopriv-3825bis on the
geopriv trac page:
<http://trac.tools.ietf.org/wg/geopriv/trac/report/1>
(Note: you will need an account on the tools page to do this.  Let me
know if this is an issue for you.)

3. Based on discussion on the list, changes will either be added to the
document or dropped, with the corresponding result noted in trac.
Issues with widespread agreement will be added as the editor sees fit;
issues that are more contentious may require a consensus call.

I have seeded the tracker with a set of changes that were agreed to at
the virtual interim and in subsequent consensus calls.

Bernard Aboba has graciously agreed to serve as editor for this
document, and should have an initial version out soon.

Thanks,
--Richard

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 4 Jun 2009 22:06:16 -0700

Starting from the text of RFC 3825, I have produced a strawman -00 draft of RFC 3825bis:
http://www.drizzle.com/~aboba/GEOPRIV/draft-ietf-geopriv-rfc3825bis-00.txt

Comments welcome. 

Other than the editorial changes outlined in Appendix B, the basis of the -00 strawman is RFC 3825, so that no technical differences should have been introduced.   Just to make sure, I have compared the text to RFC 3825 line by line. 

The -00 strawman  generates no errors or warings when reviewed by the ID-NITS tool (see below).  

On checking the URLs provided in the Reference section, two questions arose: 

a. EPSG.  One of the URLs given for the EPSG now resolves to the IHS site map:
http://www.ihsenergy.com/epsg/geodetic2.html

Does this URL need to be updated, removed or left as is?

b. WGS 84.  There is no longer a web site configured at the cited URL:
http://www.wgs84.com/ 

Is there an updated URL available? 

===========================================
ID-NITS output

idnits 2.11.11 

tmp/draft-ietf-geopriv-rfc3825bis-00.txt:

  Checking boilerplate required by RFC 5378 and the IETF Trust (see
  http://trustee.ietf.org/license-info):
  ----------------------------------------------------------------------------

     No issues found here.

  Checking nits according to http://www.ietf.org/ietf/1id-guidelines.txt:
  ----------------------------------------------------------------------------

     No issues found here.

  Checking nits according to http://www.ietf.org/ID-Checklist.html:
  ----------------------------------------------------------------------------

     No issues found here.

  Miscellaneous warnings:
  ----------------------------------------------------------------------------

  -- The document has a disclaimer for pre-RFC5378 work, but was first
     submitted on or after 10 November 2008.  Does it really need the
     disclaimer?

  Checking references for intended status: Proposed Standard
  ----------------------------------------------------------------------------

     (See RFCs 3967 and 4897 for information about using normative references
     to lower-maturity documents in RFCs)

  -- Possible downref: Non-RFC (?) normative reference: ref. 'EPSG'

  -- Possible downref: Non-RFC (?) normative reference: ref. 'WGS84'

     Summary: 0 errors (**), 0 warnings (==), 3 comments (--).

---

From: "Thomson, Martin" <[email-masked]>
Date: Fri, 5 Jun 2009 01:50:24 -0500

Hi Bernard,

a.       It might be OK to use <http://info.ogp.org.uk/geodesy/CurrentDB.html> but OGP seem to shift occasionally.

b.      I use the following reference:

   [WGS84]    US National Imagery and Mapping Agency, "Department of

              Defense (DoD) World Geodetic System 1984 (WGS 84), Third

              Edition", NIMA TR8350.2, January 2000.

      <reference anchor="WGS84" target="">

        <front>

          <title>

            Department of Defense (DoD) World Geodetic System 1984 (WGS 84), Third Edition

          </title>

          <author fullname="">

            <organization>US National Imagery and Mapping Agency</organization>

          </author>

          <date day="3" month="January" year="2000"/>

        </front>

        <seriesInfo name="NIMA" value="TR8350.2"/>

      </reference>

I’ll provide some input once I have time to read through.

--Martin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernard Aboba
Sent: Friday, 5 June 2009 3:06 PM
To: [email-masked]
Subject: [Geopriv] -00 Strawman of RFC 3825bis for Review

Comments welcome. 

http://www.wgs84.com/ 

ID-NITS output

idnits 2.11.11 

     No issues found here.

     No issues found here.

     No issues found here.

  Miscellaneous warnings:

     disclaimer?

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 5 Jun 2009 10:54:40 +0300

Hi Bernard, 
 
the only a few comments at this point in time. 

I cannot find the person(s) that have brought up the issue, tried to
convince the working group that there is a problem for years and have
submitted documents to explain the issue anywhere in the document (neither
as author(s), contributor(s) nor anything else). 

That cannot be right.

I don't see the guys who implemented this specification (based on Martin's
clarifications) listed in the document either. We should acknowledge their
work a bit more ("Remember: Rough consensus and RUNNING CODE") given that
they are the poor folks who had to decipher our mysterious specifications
and very likely spent a lot of time doing so. 

Ciao
Hannes

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bernard Aboba
	Sent: 05 June, 2009 08:06
	To: [email-masked]
	Subject: [Geopriv] -00 Strawman of RFC 3825bis for Review

	Starting from the text of RFC 3825, I have produced a strawman -00
draft of RFC 3825bis:

	Comments welcome. 
	
	Other than the editorial changes outlined in Appendix B, the basis
of the -00 strawman is RFC 3825, so that no technical differences should
have been introduced.   Just to make sure, I have compared the text to RFC
3825 line by line. 
	
	The -00 strawman  generates no errors or warings when reviewed by
the ID-NITS tool (see below).  
	
	On checking the URLs provided in the Reference section, two
questions arose: 
	
	a. EPSG.  One of the URLs given for the EPSG now resolves to the IHS
site map:

	
	b. WGS 84.  There is no longer a web site configured at the cited
URL:
	http://www.wgs84.com/ 

	
	idnits 2.11.11 

	
	
	     No issues found here.
	
	  Checking nits according to
http://www.ietf.org/ietf/1id-guidelines.txt:

	     No issues found here.

	
	     No issues found here.
	
	  Miscellaneous warnings:

	  -- The document has a disclaimer for pre-RFC5378 work, but was
first
	     submitted on or after 10 November 2008.  Does it really need
the
	     disclaimer?

	
	     (See RFCs 3967 and 4897 for information about using normative
references
	     to lower-maturity documents in RFCs)

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 5 Jun 2009 01:19:13 -0700

The -00 strawman is just the first step: RFC 3825 with some minor editorial fixes.  RFC 3825 doesn't appear to have any errata filed against it (see http://www.rfc-editor.org/errata_search.php?rfc=3825&rec_status=15&presentation=table), so in -00, the acknowledgment section is identical to that of RFC 3825. 

After we submit -00, we will start to discuss changes, and as those are incorporated, this will be reflected in the acknowledgments and author list. 

------------------------------------------------------------------------
> From: [email-masked]
> To: [email-masked]; [email-masked]
> Subject: RE: [Geopriv] -00 Strawman of RFC 3825bis for Review
> Date: Fri, 5 Jun 2009 10:54:40 +0300
> 
> Hi Bernard, 
>

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 05 Jun 2009 03:52:10 -0500

Hannes

Please re-read what Richard said about this -- (paraphrasing)

         "the -00 version of this doc will be the text from RFC 3825
         *with* the new boilerplate, and that's all."

-01 and beyond will have changed text, based on WG consensus of what 
needs to be changed (i.e., Alissa's 6 items, at least).

James

At 02:54 AM 6/5/2009, Hannes Tschofenig wrote:
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 5 Jun 2009 12:04:25 +0300

I am looking forward to the next version.  

>-----Original Message-----
>From: James M. Polk [mailto:[email-masked]] 
>Sent: 05 June, 2009 11:52
>To: Hannes Tschofenig; 'Bernard Aboba'; [email-masked]
>Subject: Re: [Geopriv] -00 Strawman of RFC 3825bis for Review
>
>Hannes
>
>-01 and beyond will have changed text, based on WG consensus 
>of what needs to be changed (i.e., Alissa's 6 items, at least).
>
>James
>
>>submitted documents to explain the issue anywhere in the document 
>>(neither as author(s), contributor(s) nor anything else).
>>
>>That cannot be right.
>>
>>clarifications) listed in the document either. We should acknowledge 
>>their work a bit more ("Remember: Rough consensus and RUNNING CODE") 
>>given that they are the poor folks who had to decipher our mysterious 
>>specifications and very likely spent a lot of time doing so.
>>
>>Ciao
>>Hannes
>>
>>         From: [email-masked] 
>>[mailto:[email-masked]] On Behalf Of Bernard Aboba
>>         Starting from the text of RFC 3825, I have produced 
>a strawman 
>>-00 draft of RFC 3825bis:
>>
>>http://www.drizzle.com/~aboba/GEOPRIV/draft-ietf-geopriv-rfc38
>25bis-00.
>>txt
>>
>>         Comments welcome.
>>
>>         Other than the editorial changes outlined in Appendix B, the 
>>basis of the -00 strawman is RFC 3825, so that no technical 
>differences should
>>         The -00 strawman  generates no errors or warings 
>when reviewed 
>>by the ID-NITS tool (see below).
>>
>>--------------------------------------------------------------
>---------
>>-----
>>
>>              No issues found here.
>>
>>--------------------------------------------------------------
>---------
>>-----
>>
>>              No issues found here.
>>
>http://www.ietf.org/ID-Checklist.html:
>>
>>--------------------------------------------------------------
>---------
>>-----
>>
>>              No issues found here.
>>
>>           Miscellaneous warnings:
>>
>>--------------------------------------------------------------
>---------
>>-----
>>
>>--------------------------------------------------------------
>---------
>>-----
>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 5 Jun 2009 12:37:50 +0200

You get the next version by proposing precise text against the listed open issues, or by opening another issue.

Keith

> [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
> Sent: Friday, June 05, 2009 10:04 AM
> To: 'James M. Polk'; 'Bernard Aboba'; [email-masked]
> >>         a. EPSG.  One of the URLs given for the EPSG now 
> resolves to 
> >>the IHS site map:
> >>
> >>         b. WGS 84.  There is no longer a web site 
> configured at the 
> >>cited
> >>URL:
> >>         http://www.wgs84.com/
> >>
> >>           -- The document has a disclaimer for pre-RFC5378 
> work, but 
> >>was first
> >>              submitted on or after 10 November 2008.  Does 
> it really 
> >>need the
> >>              disclaimer?
> >>
> >>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 5 Jun 2009 14:16:31 +0300

It is the responsibility of the working group chairs to select the authors
of a document.

>From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
>Sent: 05 June, 2009 13:38
>To: Hannes Tschofenig; 'James M. Polk'; 'Bernard Aboba'; 
>[email-masked]
>You get the next version by proposing precise text against the 
>listed open issues, or by opening another issue.
>
>Keith
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 5 Jun 2009 14:01:25 +0200

I saying nothing more than is in the following message.

So somehow consensus calls will be made on issues accompanied by text proposals in the tracker.

Keith

From:	[email-masked] on behalf of Richard Barnes [[email-masked]]
Sent:	03 June 2009 02:04
To:	'GEOPRIV'
Subject:	[Geopriv] Plan for 3825bis

Hi all,

Thanks,
--Richard

> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Friday, June 05, 2009 12:17 PM
> To: DRAGE, Keith (Keith); 'James M. Polk'; 'Bernard Aboba'; 
> [email-masked]
> It is the responsibility of the working group chairs to 
> select the authors of a document.
> 
> >You get the next version by proposing precise text against 
> the listed 
> >open issues, or by opening another issue.
> >
> >Keith
> >
> >> >>I don't see the guys who implemented this specification 
> (based on 
> >> >>Martin's
> >> >>              (See RFCs 3967 and 4897 for information 
> about using 
> >> >>normative references

---

From: "Carl Reed" <[email-masked]>
Date: Fri, 5 Jun 2009 08:55:01 -0600

Bernard -

I will check the URL. The OGP is now using an EPSG CRS registry so I suspect that the URL has changed. I will also provide the correct URL for  WGS 84 documentation (NGA url)

Cheers

Carl

  ----- Original Message ----- 
  From: Bernard Aboba 
  To: [email-masked] 
  Sent: Thursday, June 04, 2009 11:06 PM
  Subject: [Geopriv] -00 Strawman of RFC 3825bis for Review

  Comments welcome. 

http://www.ihsenergy.com/epsg/geodetic2.htmlDoes this URL need to be updated, removed or left as is?b. WGS 84.  There is no longer a web site configured at the cited URL:http://www.wgs84.com/ Is there an updated URL available? ===========================================ID-NITS outputidnits 2.11.11 tmp/draft-ietf-geopriv-rfc3825bis-00.txt:  Checking boilerplate required by RFC 5378 and the IETF Trust (see  http://trustee.ietf.org/license-info):  ----------------------------------------------------------------------------     No issues found here.  Checking nits according to http://www.ietf.org/ietf/1id-guidelines.txt:  ----------------------------------------------------------------------------     No issues found here.  Checking nits according to http://www.ietf.org/ID-Checklist.html:  ----------------------------------------------------------------------------     No issues found here.  Miscellaneous warnings:  ----------------------------------------------------------------------------  -- The document has a disclaimer for pre-RFC5378 work, but was first     submitted on or after 10 November 2008.  Does it really need the     disclaimer?  Checking references for intended status: Proposed Standard  ----------------------------------------------------------------------------     (See RFCs 3967 and 4897 for information about using normative references     to lower-maturity documents in RFCs)  -- Possible downref: Non-RFC (?) normative reference: ref. 'EPSG'  -- Possible downref: Non-RFC (?) normative reference: ref. 'WGS84'     Summary: 0 errors (**), 0 warnings (==), 3 comments (--).

------------------------------------------------------------------------------

---

From: "Carl Reed" <[email-masked]>
Date: Fri, 5 Jun 2009 09:10:41 -0600

All -

The EPSG information page is now here: http://info.ogp.org.uk/geodesy/

and the EPSG registry is here: http://www.epsg-registry.org/

The WGS 84 document is here:
 https://www1.nga.mil/PRODUCTSSERVICES/GEODESYGEOPHYSICS/WORLDGEODETICSYSTEM/Pages/default.aspx

Cheers

Carl

  ----- Original Message ----- 
  From: Bernard Aboba 
  To: [email-masked] 
  Sent: Thursday, June 04, 2009 11:06 PM
  Subject: [Geopriv] -00 Strawman of RFC 3825bis for Review

  Comments welcome.