Subject: Re: [Geopriv] The "geo" URI draft

From: "Marc Berryman" <[email-masked]>
Date: Tue, 2 Jun 2009 19:41:50 -0500

Thanks Thomas,
Perhaps people on the list can begin the see the absurdity of this thread. Simple elegant cost effective efficient WGS84 which can be easily converted into any other coordinate system used on this planet by GPS receivers and GPS transmitters and a large installed base of systems and applications.
When WGS20xx comes out we can adopt it. If we go to Mars then we can use the Mars Geodetic Standard of the day. The WGS84 has been vetted for over 20 years, I think it is safe to use it then encode, transform, conflate, or reproject into any other reference system you wish, but we need to standardize and adopt the WGS84 and move on.

Just my opinion,
Marc B

----- Original Message -----
From: [email-masked] <[email-masked]>
To: GEOPRIV <[email-masked]>
Sent: Tue Jun 02 19:27:37 2009
Subject: Re: [Geopriv] The "geo" URI draft

Gee I like design-by-committee.

This thread seems to have lost sight of the original design goals of this work: cheap and simple.

Now we could worry about the impact of a new coordinate reference systems, but whatever we choose, two things happen: we start paying a price now; we probably get it wrong.

The only think that I am certain we can get right now is a version tag (which it seems that we've started to use datum/CRS tags for recently).  So maybe that's the way to go--an optional version tag that forces the receiver to drop the whole payload if it isn't the expected value.  There's a little cost involved, but at least we know how to do that part right.  

Even then, I'm not convinced that we need to do this given the relative ease with which we are able to convert between different systems.  Of course, to do that with the utmost precision, we'd need to include a time parameter to allow for continental drift adjustments...  And then we can add location type parameters, maybe mood.

As for extraplanetary locations, these aren't really compatible with the idea of "simple".  If we want to go off planet, maybe we wont be able to take our geo: URIs with us.  I can live with that.

Furthermore, <http://microformats.org/wiki/index.php?title=mars-examples&oldid=32233> was used to support an argument for the addition of extraterrestrial positions.  Strange, because it uses a completely different tag to identify the microformat describing a position on Mars; 'mars' instead of 'geo'.  That suggests that if I wanted to identify the Spirit landing site I would use 'mars:-14.5718,175.4785'.  All in all, an elegant solution (thanks Peter :).

--Martin
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 02 Jun 2009 19:08:34 -0600

On 6/2/09 6:41 PM, Marc Berryman wrote:
> Thanks Thomas, Perhaps people on the list can begin the see the
> absurdity of this thread. Simple elegant cost effective efficient
> WGS84 which can be easily converted into any other coordinate system
> used on this planet by GPS receivers and GPS transmitters and a large
> installed base of systems and applications. When WGS20xx comes out we
> can adopt it. If we go to Mars then we can use the Mars Geodetic
> Standard of the day. The WGS84 has been vetted for over 20 years, I
> think it is safe to use it then encode, transform, conflate, or
> reproject into any other reference system you wish, but we need to
> standardize and adopt the WGS84 and move on.

+1 already. :)

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Andy Mabbett <[email-masked]>
Date: Tue, 9 Jun 2009 13:14:39 +0100

In message <[email-masked]>, 
Marc Berryman <[email-masked]> writes

>Perhaps people on the list can begin the see the absurdity of this 
>thread.

How does a pejorative and subjective label as "absurdity" help us to 
take this discussion forward?

>Simple elegant cost effective efficient WGS84 which can be easily 
>converted into any other coordinate system used on this planet by GPS 
>receivers and GPS transmitters and a large installed base of systems 
>and applications.

Assuming that your meaning is obscured by a rogue "which", you're right, 
but that fact does not support your claim of absurdity, nor negate my 
points.

>If we go to Mars then we can use the Mars Geodetic Standard of the day.

We already go to Mars - we have vehicles there already, and more on the 
way - and are already mapping other non-terrestrial bodies and assigning 
coordinates to their features. I have already posted the URL of evidence 
to support this. Do you wish to challenge that?

>The WGS84 has been vetted for over 20 years, I think it is safe to use 
>it then encode, transform, conflate, or reproject into any other 
>reference system you wish, but we need to standardize and adopt the 
>WGS84 and move on.

Again, please explain how you would convert Martin coordinates to WGS84.

-- 
Andy Mabbett