Subject: [Geopriv] "DHC" options

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 7 Oct 2009 23:59:56 -0500

Why do rfc3825bis and dhcp-lbyr-uri-option both use the acronym "DHC" (without the usual "P")?

When I see "DHC Option" I wonder whether this option is a protocol parameter or if it belongs to the DHC WG.

--Martin

p.s. Can we at least "expand on first use" here?

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 7 Oct 2009 22:37:05 -0700

Good question.  I went over all the usages of "DHC" in rfc3825bis and "DHCP" appears more appropriate in all cases.  I'll fix this in the next revision. 

> Date: Wed, 7 Oct 2009 23:59:56 -0500
> From: [email-masked]
> To: [email-masked]
> Subject: [Geopriv] "DHC" options
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 08 Oct 2009 01:50:46 -0500

The WG isn't called the "DHCP WG", it's called the DHC WG. Way back 
in 2004 - when I was writing the original ID that became RFC 3825, I 
was asked to refer to anything DHC without the P by the DHC WG 
(within the original draft).  I didn't question that, given they know 
more about their protocol than I do, and I suspect more than anyone 
within Geopriv does...  but I could be wrong.  I carried that 
philosophy forward in the dhcp-lbyr-uri-option ID.

James

At 12:37 AM 10/8/2009, Bernard Aboba wrote:
>Good question.  I went over all the usages of "DHC" in rfc3825bis 
>and "DHCP" appears more appropriate in all cases.  I'll fix this in 
>the next revision.
>
> > When I see "DHC Option" I wonder whether this option is a 
> protocol parameter or if it belongs to the DHC WG.
> >
> > --Martin
> >

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 8 Oct 2009 16:37:11 -0500

We aren't talking about the WG, but the specific protocol (or protocols) they produce.

> -----Original Message-----
> From: James M. Polk [mailto:[email-masked]]
> Sent: Thursday, 8 October 2009 5:51 PM
> To: Bernard Aboba; Thomson, Martin; [email-masked]
> Subject: Re: [Geopriv] "DHC" options
>