Subject: [Geopriv] FW: New Version Notification for draft-garcia-geopriv-indirect-publish-01

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 26 Oct 2009 14:17:41 +0800

Hannes asked me to update this last week, so this hasn't had the full attention it deserves.  It's still a fairly major update to this document.

I'll point out that there is some contention between the authors over the exact mechanisms used (which was precisely what I was looking for), and I didn't have enough time to fill in all the details.

This is, however, a much more complete version that what was provided previously.

--Martin

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Monday, 26 October 2009 5:09 PM
To: Thomson, Martin
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: New Version Notification for draft-garcia-geopriv-indirect-publish-01 

A new version of I-D, draft-garcia-geopriv-indirect-publish-01.txt has been successfuly submitted by Martin Thomson and posted to the IETF repository.

Filename:	 draft-garcia-geopriv-indirect-publish
Revision:	 01
Title:		 Indirect Presence Publication with the Session Initiation Protocol(SIP)
Creation_date:	 2009-10-26
WG ID:		 Independent Submission
Number_of_pages: 17

Abstract:
A method for indirectly publishing presence information is described.
This allows a presentity user agent to publish a URI that can be used
by the presence agent to retrieve presence information.  A presence
agent is then better able to acquire dynamic presence information
without relying on the presentity user agent.  This also allows a
presentity user agent to delegate responsibility for managing
changing presence data to the source of that information.

The IETF Secretariat.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 26 Oct 2009 14:21:43 +0000

Martin,

One quick comment: You should probably say something about how  
authorization works in these scenarios.  Namely, the PUA will need to  
tell the PS that the PA is authorized to have his stuff, unless the  
reference that the PUA gets is open access.

--Richard

On Oct 26, 2009, at 6:17 AM, Thomson, Martin wrote:

> Hannes asked me to update this last week, so this hasn't had the  
> full attention it deserves.  It's still a fairly major update to  
> this document.
>
> I'll point out that there is some contention between the authors  
> over the exact mechanisms used (which was precisely what I was  
> looking for), and I didn't have enough time to fill in all the  
> details.
>
> A new version of I-D, draft-garcia-geopriv-indirect-publish-01.txt  
> has been successfuly submitted by Martin Thomson and posted to the  
> IETF repository.
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 27 Oct 2009 05:48:04 +0800

Thanks Richard,

The thought had occurred, but I had less than 4 hours in total to do this update, so there are lots of omissions of that sort.  Miguel and I continue to debate whether or not this was even a good idea.

> From: Richard Barnes [mailto:[email-masked]]
> Sent: Tuesday, 27 October 2009 1:22 AM
> To: Thomson, Martin
> Cc: GEOPRIV
> Subject: Re: [Geopriv] FW: New Version Notification for draft-garcia-
> geopriv-indirect-publish-01
> 
> Martin,
> 
> > Title:		 Indirect Presence Publication with the Session
> Initiation
> > Protocol(SIP)