Subject: [Geopriv] [geopriv] #25: Address feedback from AD Evaluation

From: "geopriv issue tracker" <[email-masked]>
Date: Thu, 01 Oct 2009 07:40:38 -0000

#25: Address feedback from AD Evaluation
----------------------------------------+-----------------------------------
 Reporter:  [email-masked]  |       Owner:  [email-masked]
     Type:  task                        |      Status:  new                       
 Priority:  major                       |   Milestone:                            
Component:  geo-uri                     |     Version:                            
 Severity:  -                           |    Keywords:                            
----------------------------------------+-----------------------------------
 Cullen has reviewed the draft as part of the IESG evaluation, and has
 provided feedback about

 - Example to be provided in section 1
 - Discussion of vertical vs. horizontal uncertainty
 - crs Parameter registry & interopability issues

 TODO: Discuss those issues, provide feedback, create updated versions on
 agreed topics

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/geopriv/trac/ticket/25>
geopriv <http://tools.ietf.org/geopriv/>

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 1 Oct 2009 18:56:18 -0500

On face value these comments are reasonable.

Since I'm somewhat responsible on the uncertainty aspect, here's what I propose we do on that front:

OLD:
   The single uncertainty value is applied to all dimensions given in
   the URI.
NEW:
   The single uncertainty value is applied to all dimensions given in
   the URI.  

   How uncertainty applies depends on the selected CRS.  For a WGS-84
   location that contains altitue, uncertainty applies both horizontally
   and vertically; if altitude is absent, uncertainty only applies
   horizontally.

As for CRS registry, I don't want to re-open discussions on this issue.  Thus, we need to be very clear on what the problem is, did Cullen provide more specific comments on the issue?

If I were to guess at the concern here, it relates to what Henning has said on the topic.  It's not possible to achieve universal communication (i.e. interoperability) if everyone is allowed to speak different languages.  Perhaps a statement to this effect in Section 3.4.1 (before the last paragraph):

   This interpretation of the 'crs' parameter ensures that the included
   information cannot be misinterpreted by a recipient that doesn't
   support the CRS. However, it equally prevents 'geo' URI recipients
   from using the included data.  To ensure interoperability, authors
   of 'geo' URIs MUST use WGS-84 unless they have prior knowledge
   indicating that recipients support an alternative 'crs' parameter.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of geopriv issue tracker
> Sent: Thursday, 1 October 2009 5:41 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Geopriv] [geopriv] #25: Address feedback from AD Evaluation
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: [email-masked]
Date: Fri, 2 Oct 2009 05:18:49 -0400 (EDT)

Actually, we3 should be even more specific in terms of WGS-84. Need to
specify 2d or 3d and perhaps the EPSG code so that developers can
references the exact definition of what is meant by WGS-84 in the uri
document.

Just a thought.

Carl

> As for CRS registry, I don't want to re-open discussions on this issue.
> Thus, we need to be very clear on what the problem is, did Cullen provide
> more specific comments on the issue?
>
> If I were to guess at the concern here, it relates to what Henning has
> said on the topic.  It's not possible to achieve universal communication
> (i.e. interoperability) if everyone is allowed to speak different
> languages.  Perhaps a statement to this effect in Section 3.4.1 (before
> the last paragraph):
>

---

From: Richard Barnes <[email-masked]>
Date: Fri, 02 Oct 2009 11:26:27 +0200

I think the current document is pretty clear on these issues: If the URI 
has an altitude, it's WGS-84 3D, and if not, it's 2D.  The GML mappings 
have EPSG numbers that look right to me.

--Richard