Subject: [Geopriv] Interior Location in the Presence Information Data Format - Location

From: "Carl Reed" <[email-masked]>
Date: Fri, 5 Mar 2010 12:08:52 -0700

Brian et. all. -

Just did a quick read of the document which triggered a question/thought.

Is anyone in this group away of a standards project titled Open Floor Plan? The initial work was the result of Carnegie Mellon Silicon Valley collaborating with the Golden Gate Safety Network to develop a format for displaying floor plans related building data for First Responders. In the last year, this activity has increased in collaboration scope to include the Open Geospatial Consortium, the buildingSMARTalliance, OASIS, the International Justice and Public Safety Network, and the Virginia EM. The idea is to define a relatively simple content model for indoor floor plans that can then be encoded in some grammar, such as GML. A key aspect of this work is the agreement that the vocabulary for indoor assets (such as a door/window etc) shall be based on the taxonomy and defined semantics as used in the international Building Information Model (BIM).

Would be nice if the indoor location work and be consistent with or based on the same model as what is developed for the OFP. 

Let me know if there are any questions.

Regards

Carl Reed, PhD
CTO and Executive Director Specification Program
OGC

The OGC: Helping the World to Communicate Geographically

---------------------

This communication, including attachments, is for the exclusive use of addressee and may contain proprietary, confidential or privileged information. If you are not the intended recipient, any use, copying, disclosure, dissemination or distribution is strictly prohibited. If you are not the intended recipient, please notify the sender  immediately by return email and delete this communication and destroy all copies.

"The important thing is not to stop questioning." -- Albert Einstein 
"Security is mostly a superstition. It does not exist in nature. Life is either a daring adventure or nothing." -- Helen Keller

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 5 Mar 2010 14:35:50 -0500

There is nothing that is incompatible AFAIK.  We would register the BIM
taxonomy as types in the registry and just plug those types, with the right
values, into INT.  

INT is defined as order dependent.  I¹m not all that up on how BIM works,
but I think it¹s a strict hierarchy of models, which encodes fine in order
dependent tag lists.

It would be nice for some BIM expert to look at this and concur.

Brian

On 3/5/10 2:08 PM, "Carl Reed" <[email-masked]> wrote:

> Is anyone in this group away of a standards project titled Open Floor Plan?
> The initial work was the result of Carnegie Mellon Silicon Valley
> collaborating with the Golden Gate Safety Network to develop a format for
> displaying floor plans related building data for First Responders. In the last
> year, this activity has increased in collaboration scope to include the Open
> Geospatial Consortium, the buildingSMARTalliance, OASIS, the International
> Justice and Public Safety Network, and the Virginia EM. The idea is to define
> a relatively simple content model for indoor floor plans that can then be
> encoded in some grammar, such as GML. A key aspect of this work is the
> agreement that the vocabulary for indoor assets (such as a door/window etc)
> shall be based on the taxonomy and defined semantics as used in the
> international Building Information Model (BIM).
>  
> Would be nice if the indoor location work and be consistent with or based on
> the same model as what is developed for the OFP.
>  
> This communication, including attachments, is for the exclusive use of
> addressee and may contain proprietary, confidential or privileged information.
> If you are not the intended recipient, any use, copying, disclosure,
> dissemination or distribution is strictly prohibited. If you are not the
> intended recipient, please notify the sender  immediately by return email and
> delete this communication and destroy all copies.
>  
> "Security is mostly a superstition. It does not exist in nature. Life is
> either a daring adventure or nothing." -- Helen Keller
>