Subject: [Geopriv] Location Coherence (LoCo) Bar BoF

From: Richard Barnes <[email-masked]>
Date: Wed, 17 Mar 2010 19:05:58 -0400

Hey all,

This email is announcing a Bar BoF at the upcoming IETF meeting on the  
topic of "location coherence", to be held somewhere in the vicinity of  
the GEOPRIV meeting, probably during the lunch break on Wednesday, 24  
March.  Since the topic is a little peripheral to GEOPRIV,  I've also  
set up a Google Group for discussions here:
<http://groups.google.com/group/geo-loco>

What I mean by "coherence" is this:

In order for location-based Internet applications to work, there are  
several pieces that need to work together, including
-- Positioning sevices
-- Location protocols
-- Location APIs-- Application protocols that use location
Right now, there are many different implementations out there for each  
layer in this stack, each with its own set of semantics for location  
related concepts -- not just the location that can be expressed (e.g.,  
lat/long/accuracy vs. polygons), but also ancillary ideas like types  
of location (civic vs geodetic) and supporting information like signal  
measurements.

In the spirit of allowing different organizations to add value at  
different levels of this stack, while still maintaining  
interoperability, it would seem like a good idea to have a coherent  
set of semantics for location concepts -- a common data model, if not  
common protocols and APIs.

Topics for discussion could include:
-- How can we map out the space of things that exist today?
-- What sorts of location systems would this effort try to encompass?  
Protocols and/or APIs?  Positioning and/or conveyance?
-- What's the proper venue for this work?  GEOPRIV?  A new IETF WG?  
Somewhere else?

As an example of the sort of thing that might come out of this work, a  
colleague and I put together a partial draft looking at mappings  
between different location protocols:
<http://tools.ietf.org/html/draft-doran-geopriv-proto-map-01>

Thanks for taking the time to read through this, and I look forward to  
some useful discussions next week.

Best,
--Richard

---

From: Brian Rosen <[email-masked]>
Date: Wed, 17 Mar 2010 19:11:53 -0500

Great idea

For some time now, I've been frustrated with our inability to get on the
same page on these issues.

I also wanted to get some kind of effort started on cross OS APIs to the
LCPs.

Brian

On 3/17/10 6:05 PM, "Richard Barnes" <[email-masked]> wrote:

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 17 Mar 2010 19:14:35 -0500

>Great idea

great idea -- bad timing

That's when the WG chairs lunch is that both Brian and Richard usually attend.

Can this be some other lunch time than Wed?

James

---

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 18 Mar 2010 08:16:21 +0800

Can people stay Friday afternoon?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of James M. Polk
> Sent: Thursday, 18 March 2010 11:15 AM
> To: Brian Rosen; Richard Barnes; [email-masked]
> Subject: Re: [Geopriv] Location Coherence (LoCo) Bar BoF
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 17 Mar 2010 21:39:08 -0400

I would strongly prefer to keep it some time on Wednesday, so that  
people who are mainly interested in location issues don't have to stay  
a real long time.

And anyway, the topic for the chairs lunch is just "How does legacy  
IPv4 differ from IPv6?"  Don't we all know the answer to that already  
-- bigger addresses and no NAT, right?  Duh!

--Richard

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Mar 2010 09:54:38 -0700

Wednesday lunch is looking worse and worse.  How would people feel  
about Tuesday lunch?  If I don't hear any objections by, say, early  
this afternoon, I'll go ahead and make the change.
--Richard

On Mar 17, 2010, at 4:05 PM, Richard Barnes wrote:

> Hey all,
>
> This email is announcing a Bar BoF at the upcoming IETF meeting on  
> the topic of "location coherence", to be held somewhere in the  
> vicinity of the GEOPRIV meeting, probably during the lunch break on  
> Wednesday, 24 March.  Since the topic is a little peripheral to  
> GEOPRIV,  I've also set up a Google Group for discussions here:
> Right now, there are many different implementations out there for  
> each layer in this stack, each with its own set of semantics for  
> location related concepts -- not just the location that can be  
> expressed (e.g., lat/long/accuracy vs. polygons), but also ancillary  
> ideas like types of location (civic vs geodetic) and supporting  
> information like signal measurements.
>
> set of semantics for location concepts -- a common data model, if  
> not common protocols and APIs.
>
> -- What sorts of location systems would this effort try to  
> encompass? Protocols and/or APIs?  Positioning and/or conveyance?
> As an example of the sort of thing that might come out of this work,  
> a colleague and I put together a partial draft looking at mappings  
> Thanks for taking the time to read through this, and I look forward  
> to some useful discussions next week.
>
> Best,
> --Richard

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Mar 2010 12:12:59 -0700

Someone pointed out that Tuesday lunch conflicts with the ISOC IPv6  
meeting.  Any major issues with Tuesday breakfast?

On Mar 21, 2010, at 9:54 AM, Richard Barnes wrote:

>> In order for location-based Internet applications to work, there  
>> are several pieces that need to work together, including
>> -- Positioning sevices
>> -- Location protocols
>> expressed (e.g., lat/long/accuracy vs. polygons), but also  
>> ancillary ideas like types of location (civic vs geodetic) and  
>> supporting information like signal measurements.
>>
>> As an example of the sort of thing that might come out of this  
>> work, a colleague and I put together a partial draft looking at  
>> mappings between different location protocols:

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 21 Mar 2010 12:57:55 -0700

Tuesday lunch would probably work for me. Breakfast would not

On Mar 21, 2010, at 12:12 , Richard Barnes wrote:

> Someone pointed out that Tuesday lunch conflicts with the ISOC IPv6 meeting.  Any major issues with Tuesday breakfast?
> 
> 
>> Wednesday lunch is looking worse and worse.  How would people feel about Tuesday lunch?  If I don't hear any objections by, say, early this afternoon, I'll go ahead and make the change.
>> --Richard
>> 
>> 
>>> This email is announcing a Bar BoF at the upcoming IETF meeting on the topic of "location coherence", to be held somewhere in the vicinity of the GEOPRIV meeting, probably during the lunch break on Wednesday, 24 March.  Since the topic is a little peripheral to GEOPRIV,  I've also set up a Google Group for discussions here:
>>> In order for location-based Internet applications to work, there are several pieces that need to work together, including
>>> -- Positioning sevices
>>> -- Location protocols
>>> Right now, there are many different implementations out there for each layer in this stack, each with its own set of semantics for location related concepts -- not just the location that can be expressed (e.g., lat/long/accuracy vs. polygons), but also ancillary ideas like types of location (civic vs geodetic) and supporting information like signal measurements.
>>> 
>>> In the spirit of allowing different organizations to add value at different levels of this stack, while still maintaining interoperability, it would seem like a good idea to have a coherent set of semantics for location concepts -- a common data model, if not common protocols and APIs.
>>> 
>>> -- What sorts of location systems would this effort try to encompass? Protocols and/or APIs?  Positioning and/or conveyance?
>>> -- What's the proper venue for this work?  GEOPRIV?  A new IETF WG? Somewhere else?
>>> 
>>> As an example of the sort of thing that might come out of this work, a colleague and I put together a partial draft looking at mappings between different location protocols:
>>> Thanks for taking the time to read through this, and I look forward to some useful discussions next week.
>>> 
>>> Best,
>>> --Richard

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 21 Mar 2010 22:20:42 +0100

Same here. We have an IESG meting on Tuesday morning - so you would lose
all AD's. Tuesday lunch works. 

Dan

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Cullen Jennings
> Sent: Sunday, March 21, 2010 9:58 PM
> To: Richard Barnes
> Cc: [email-masked]
> > Someone pointed out that Tuesday lunch conflicts with the 
> ISOC IPv6 meeting.  Any major issues with Tuesday breakfast?
> > 
> > 
> >> Wednesday lunch is looking worse and worse.  How would 
> people feel about Tuesday lunch?  If I don't hear any 
> objections by, say, early this afternoon, I'll go ahead and 
> make the change.
> >> --Richard
> >> 
> >> 
> >>> This email is announcing a Bar BoF at the upcoming IETF 
> meeting on the topic of "location coherence", to be held 
> somewhere in the vicinity of the GEOPRIV meeting, probably 
> during the lunch break on Wednesday, 24 March.  Since the 
> topic is a little peripheral to GEOPRIV,  I've also set up a 
> Google Group for discussions here:
> >>> -- Location APIs-- Application protocols that use location Right 
> >>> now, there are many different implementations out there 
> for each layer in this stack, each with its own set of 
> semantics for location related concepts -- not just the 
> location that can be expressed (e.g., lat/long/accuracy vs. 
> polygons), but also ancillary ideas like types of location 
> (civic vs geodetic) and supporting information like signal 
> measurements.
> >>> 
> >>> In the spirit of allowing different organizations to add 
> value at different levels of this stack, while still 
> maintaining interoperability, it would seem like a good idea 
> to have a coherent set of semantics for location concepts -- 
> a common data model, if not common protocols and APIs.
> >>> 
> >>> -- What sorts of location systems would this effort try 
> to encompass? Protocols and/or APIs?  Positioning and/or conveyance?
> >>> As an example of the sort of thing that might come out of 
> this work, a colleague and I put together a partial draft 
> looking at mappings between different location protocols:
> >>> Thanks for taking the time to read through this, and I 
> look forward to some useful discussions next week.
> >>> 
> >>> Best,
> >>> --Richard

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 22 Mar 2010 11:31:15 -0500

Richard

Do you have this figured out enough to schedule?

James

---

From: Richard Barnes <[email-masked]>
Date: Mon, 22 Mar 2010 09:36:37 -0700

Given the IESG feedback, I'll call it for Tuesday lunch.
--Richard

On Mar 22, 2010, at 9:31 AM, James M. Polk wrote:

>> Right

---

From: Richard Barnes <[email-masked]>
Date: Tue, 23 Mar 2010 09:46:51 -0700

Still working on reserving a room for this.  If all else fails, let's  
meet at the registration desk at 11:45 and find a spot.  Either way,  
once a place is established (via either method), it will be announced  
on this list.

--Richard

---

From: Richard Barnes <[email-masked]>
Date: Tue, 23 Mar 2010 09:53:22 -0700

The room for LoCo today is Carmel.  We'll start there around 11:45.
Thanks,
--Richard

On Mar 23, 2010, at 9:46 AM, Richard Barnes wrote:

> Still working on reserving a room for this.  If all else fails,  
> let's meet at the registration desk at 11:45 and find a spot.   
> Either way, once a place is established (via either method), it will  
> be announced on this list.
>
> --Richard
>
>
>