Subject: [Geopriv] Call for consensus: WG item adoption

From: Alissa Cooper <[email-masked]>
Date: Tue, 22 Jun 2010 12:46:44 +0100

Since we've progressed a number of WG items recently, we have space in  
our queue for some new ones. I'd like to make a call for consensus  
about adopting the following three documents as GEOPRIV work items:

1) draft-thomson-geopriv-relative-location-01
2) draft-thomson-geopriv-held-measurements-06
3) draft-winterbottom-geopriv-deref-protocol-03

These were all among the documents that received expressions of  
support from the working group at IETF 77 [1]. The top two have been  
recently revised to address feedback from the meeting, the list, and  
design team work.

Please send your responses about each document to the list no later  
than Monday, June 28.

Alissa

[1] http://www.ietf.org/mail-archive/web/geopriv/current/msg08428.html

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 22 Jun 2010 19:51:41 +0800

Hi Alissa,

I believe that all three need to be adopted and progressed.

Cheers
James

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Alissa Cooper [[email-masked]]
Sent: Tuesday, June 22, 2010 6:46 AM
To: [email-masked]
Subject: [Geopriv] Call for consensus: WG item adoption

Alissa

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 27 Jun 2010 19:30:51 +0100

We've had very little response to this call for consensus. If you have  
an opinion either way about adopting these three documents as working  
group items, please send it to the list by tomorrow (Monday, June 28).

Thanks,
Alissa

Begin forwarded message:

> From: Alissa Cooper <[email-masked]>
> Date: June 22, 2010 12:46:44 PM BST
> To: [email-masked]
> Since we've progressed a number of WG items recently, we have space  
> in our queue for some new ones. I'd like to make a call for  
> consensus about adopting the following three documents as GEOPRIV  
> work items:
>

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 27 Jun 2010 11:58:01 -0700

IMHO, draft-winterbottom-geopriv-deref-protocol addresses an important need -- for a specification to define how HELD is used to de-reference a location URI.

---

From: Brian Rosen <[email-masked]>
Date: Sun, 27 Jun 2010 17:07:47 -0400

I am in favor of adopting relative location and deref protocol.

I am sanguine about -measurements.  I don't think measurements are tied to a protocol.  So, if I had my druthers, I'd define a protocol independent mechanism and then define transports of that mechanism for various protocols.  However, since I don't have cycles available to do that, and holding up the draft is not reasonable for that reason, I can't stand in the way of adopting it.

Brian

On Jun 27, 2010, at 2:30 PM, Alissa Cooper wrote:

> We've had very little response to this call for consensus. If you have an opinion either way about adopting these three documents as working group items, please send it to the list by tomorrow (Monday, June 28).
> 
> Thanks,
> Alissa
> 
> Begin forwarded message:
> 
>> Since we've progressed a number of WG items recently, we have space in our queue for some new ones. I'd like to make a call for consensus about adopting the following three documents as GEOPRIV work items:
>> 
>> These were all among the documents that received expressions of support from the working group at IETF 77 [1]. The top two have been recently revised to address feedback from the meeting, the list, and design team work.
>> 
>> Please send your responses about each document to the list no later than Monday, June 28.
>> 
>> Alissa
>>

---

From: althomso <[email-masked]>
Date: Sun, 27 Jun 2010 14:13:03 -0700

I agree with adopting relative location.

allan

On 6/27/10 2:07 PM, "Brian Rosen" <[email-masked]> wrote:

> I am sanguine about -measurements.  I don't think measurements are tied to a
> protocol.  So, if I had my druthers, I'd define a protocol independent
> mechanism and then define transports of that mechanism for various protocols.
> However, since I don't have cycles available to do that, and holding up the
> draft is not reasonable for that reason, I can't stand in the way of adopting
> it.
> 
> Brian
> 
>> We've had very little response to this call for consensus. If you have an
>> opinion either way about adopting these three documents as working group
>> items, please send it to the list by tomorrow (Monday, June 28).
>> 
>> Thanks,
>> Alissa
>> 
>> Begin forwarded message:
>> 
>>> Since we've progressed a number of WG items recently, we have space in our
>>> queue for some new ones. I'd like to make a call for consensus about
>>> adopting the following three documents as GEOPRIV work items:
>>> 
>>> These were all among the documents that received expressions of support from
>>> the working group at IETF 77 [1]. The top two have been recently revised to
>>> address feedback from the meeting, the list, and design team work.
>>>

---

From: "Dawson, Martin" <[email-masked]>
Date: Mon, 28 Jun 2010 08:37:10 +0800

Hi Alissa,

I think all of these should become WG items.

Regards,
Martin Dawson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Monday, 28 June 2010 4:31 AM
To: [email-masked]
Subject: [Geopriv] Fwd: Call for consensus: WG item adoption

Thanks,
Alissa

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 28 Jun 2010 00:52:54 -0400

<hat type="individual"/>

FWIW, what you're asking w.r.t. -measurements is basically what it  
already does.  Each measurement type is in its own namespace, as is  
the measurements container itself.  So in principle, you could re-use  
these data structure elsewhere.

Related: I think -measurements is a very high-priority item.  It is  
needed to bring HELD to feature-parity with some of the most commonly- 
used location protocols on the Internet (e.g., the Google and Skyhook  
location protocols).

On Jun 27, 2010, at 5:07 PM, Brian Rosen wrote:

> I am sanguine about -measurements.  I don't think measurements are  
> tied to a protocol.  So, if I had my druthers, I'd define a protocol  
> independent mechanism and then define transports of that mechanism  
> for various protocols.  However, since I don't have cycles available  
> to do that, and holding up the draft is not reasonable for that  
> reason, I can't stand in the way of adopting it.
>
> Brian
>
>> We've had very little response to this call for consensus. If you  
>> have an opinion either way about adopting these three documents as  
>> working group items, please send it to the list by tomorrow  
>> (Monday, June 28).
>>
>> Thanks,
>> Alissa
>>
>> Begin forwarded message:
>>
>>> Since we've progressed a number of WG items recently, we have  
>>> space in our queue for some new ones. I'd like to make a call for  
>>> support from the working group at IETF 77 [1]. The top two have  
>>> been recently revised to address feedback from the meeting, the  
>>> list, and design team work.
>>>

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 28 Jun 2010 13:35:16 +0800

As evident the author list on the drafts, I'm strongly in support of all.  I'll happily acknowledge that more work is needed, but that's certainly no barrier to adoption.

In response to Brian's reservations on -measurements: Looks like Richard beat me to it :)

If you ignore the draft name, -measurements is purposely written in a protocol-ambivalent fashion, with the only assumption being that there is some form of request-response semantics.  There are examples for HELD, that's the only protocol-specific part.

It's been like that for a while.  Marc Linsner requested that we avoid protocol-specific ages back.

--Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Richard L. Barnes
> Sent: Monday, 28 June 2010 2:53 PM
> To: Brian Rosen
> Cc: [email-masked]
> Subject: Re: [Geopriv] Fwd: Call for consensus: WG item adoption
> 
> <hat type="individual"/>
> 
> >>> [1] http://www.ietf.org/mail-
> archive/web/geopriv/current/msg08428.html
> >>>
> >>>
> >>>

---

From: <[email-masked]>
Date: Mon, 28 Jun 2010 07:39:47 +0200

I support the adoption of the first two, I don't care about the third one.

- gabor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Alissa Cooper
Sent: Sunday, June 27, 2010 11:31 AM
To: [email-masked]
Subject: [Geopriv] Fwd: Call for consensus: WG item adoption

Thanks,
Alissa

---

From: Ray Bellis <[email-masked]>
Date: Mon, 28 Jun 2010 08:24:16 +0000

> We've had very little response to this call for consensus. If you have an opinion either way about adopting these three documents as working group items, please send it to the list by tomorrow (Mon…

I support the adoption of all three.

Ray

---

From: <[email-masked]>
Date: Mon, 28 Jun 2010 15:04:55 +0100

Alissa,

I'd like to express a vote for adoption of
draft-thomson-geopriv-held-measurements-06 as a WG item.

Thanks

John 

-----Original Message-----
Behalf Of Alissa Cooper
Sent: 27 June 2010 19:31

Thanks,
Alissa

---

From: "Carl Reed" <[email-masked]>
Date: Mon, 28 Jun 2010 10:33:53 -0600

As the semantics of measurement and observation have been harmonized with OGC/ISO standards, I have no problem with HELD measurement moving forward. That siad, I should add that for future work in which observations and their related properties (such as measure) are to be modeled and encoded, I would encourage the group to consider the OGC Observations and Measurements standards. A revision of the current standard will soon be an ISO standard as an OGC standard. The standard consists of two parts: An abstract model and also the associated encoding schema (OMXML). An example is below.

Regards

Carl

The following could be made simpler but instead includes information about the temperature at the time the observation was produced, information about the processes related to the observation, and so forth.

<om:OM_Observation
 gml:id="obsTest1"
 xmlns:om="http://www.opengis.net/om/2.0"
 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xmlns:xlink="http://www.w3.org/1999/xlink"
 xmlns:gml="http://www.opengis.net/gml/3.2"
 xsi:schemaLocation="http://www.opengis.net/om/2.0 http://schemas.opengis.net/om/2.0/observation.xsd">

 <gml:description>Observation test instance: fruit mass</gml:description>
 <gml:name>Observation test 1</gml:name>
 <om:type xlink:href="http://www.opengis.net/def/observationType/OGC-OM/2.0/OM_Measurement"/>
 <om:phenomenonTime>
  <gml:TimeInstant
   gml:id="ot1t">
   <gml:timePosition>2005-01-11T16:22:25.00</gml:timePosition>
  </gml:TimeInstant>
 </om:phenomenonTime>
 <om:resultTime xlink:href="#ot1t"/>
 <!-- a notional URL identifying a  procedure ... -->
 <om:procedure
  xlink:href="http://www.example.org/register/process/scales34.xml"/>
 <!-- environmental conditions during measurement -->
 <om:parameter>
  <om:NamedValue>
   <om:name xlink:href="http://sweet.jpl.nasa.gov/ontology/property.owl#Temperature"/>
   <om:value xsi:type="gml:MeasureType" uom="Cel">22.3</om:value>
  </om:NamedValue>
 </om:parameter>
 <!-- a notional URN identifying the observed property -->
 <om:observedProperty
  xlink:href="http://sweet.jpl.nasa.gov/2.0/phys.owl#Mass"/>
 <!-- a notional WFS call identifying the object regarding which the observation was made -->
 <om:featureOfInterest
  xlink:href="http://wfs.example.org?request=getFeature&amp;featureid=fruit37f "/>

 <om:result
  xsi:type="gml:MeasureType"
  uom="kg">0.28</om:result>
 <!-- The XML Schema type of the result is indicated using the value of the xsi:type attribute -->

</om:OM_Observation>

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 28 Jun 2010 13:33:24 -0400

Geez, Carl, verbose much?

I agree with your general point that we should keep semantics aligned,  
but it might make sense to specify a more compact form of the specific  
measurements needed for positioning.  Sort of how we've now defined  
GML mappings for the DHCP and GEO URI location formats.

--Richard

On Jun 28, 2010, at 12:33 PM, Carl Reed wrote:

> As the semantics of measurement and observation have been harmonized  
> with OGC/ISO standards, I have no problem with HELD measurement  
> moving forward. That siad, I should add that for future work in  
> which observations and their related properties (such as measure)  
> are to be modeled and encoded, I would encourage the group to  
> consider the OGC Observations and Measurements standards. A revision  
> of the current standard will soon be an ISO standard as an OGC  
> standard. The standard consists of two parts: An abstract model and  
> also the associated encoding schema (OMXML). An example is below.
>
> Regards
>
> Carl
>
> The following could be made simpler but instead includes information  
> about the temperature at the time the observation was produced,  
> information about the processes related to the observation, and so  
> forth.
>
> <om:OM_Observation
>  gml:id="obsTest1"

---

From: "Carl Reed" <[email-masked]>
Date: Mon, 28 Jun 2010 12:02:55 -0600

Richard -

Yes, I guess that is what I was suggesting. OMXML does allow very lightweight and simple encodings. OMXML allows one to rigorously encode observations and measurements ranging from satellite sensors to simple in building temperature sensors - and everything in between. I am sure that Simon (O&M editor) would be happy to help define any such simple O&M schema or mappings.

Cheers

Carl

  ----- Original Message ----- 
  From: Richard L. Barnes 
  To: Carl Reed 
  Cc: Brian Rosen ; [email-masked] 
  Sent: Monday, June 28, 2010 11:33 AM
  Subject: Re: [Geopriv] Fwd: Call for consensus: WG item adoption - HELD Measurement

  I agree with your general point that we should keep semantics aligned, but it might make sense to specify a more compact form of the specific measurements needed for positioning.  Sort of how we've now defined GML mappings for the DHCP and GEO URI location formats.

  --Richard  

    Regards

    Carl

    <om:OM_Observation
     gml:id="obsTest1"

     <om:result

    </om:OM_Observation>

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 28 Jun 2010 14:30:18 -0400

Are there any public specifications for OMXML that you could point us  
to?

On Jun 28, 2010, at 2:02 PM, Carl Reed wrote:

> Richard -
>
> Yes, I guess that is what I was suggesting. OMXML does allow very  
> lightweight and simple encodings. OMXML allows one to rigorously  
> encode observations and measurements ranging from satellite sensors  
> to simple in building temperature sensors - and everything in  
> between. I am sure that Simon (O&M editor) would be happy to help  
> define any such simple O&M schema or mappings.
>
> Cheers
>
> Carl
>
> I agree with your general point that we should keep semantics  
> aligned, but it might make sense to specify a more compact form of  
> the specific measurements needed for positioning.  Sort of how we've  
> now defined GML mappings for the DHCP and GEO URI location formats.
>
> --Richard
>
>
>> As the semantics of measurement and observation have been  
>> harmonized with OGC/ISO standards, I have no problem with HELD  
>> measurement moving forward. That siad, I should add that for future  
>> work in which observations and their related properties (such as  
>> measure) are to be modeled and encoded, I would encourage the group  
>> to consider the OGC Observations and Measurements standards. A  
>> revision of the current standard will soon be an ISO standard as an  
>> OGC standard. The standard consists of two parts: An abstract model  
>> and also the associated encoding schema (OMXML). An example is below.
>>
>> Regards
>>
>> Carl
>>
>> The following could be made simpler but instead includes  
>> information about the temperature at the time the observation was  
>> produced, information about the processes related to the  
>> observation, and so forth.
>>
>> <om:OM_Observation
>>  gml:id="obsTest1"