Subject: [Geopriv] I-D Action:draft-ietf-geopriv-held-identity-extensions-04.txt

From: [email-masked]
Date: Sun, 20 Jun 2010 21:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Geographic Location/Privacy Working Group of the IETF.

	Title           : Use of Device Identity in HTTP-Enabled Location Delivery (HELD)
	Author(s)       : J. Winterbottom, et al.
	Filename        : draft-ietf-geopriv-held-identity-extensions-04.txt
	Pages           : 29
	Date            : 2010-06-20

When a Location Information Server receives a request for location
information (using the locationRequest message), described in the
base HTTP Enabled Location Delivery (HELD) specification, it uses the
source IP address of the arriving message as a pointer to the
location determination process.  This is sufficient in environments
where the location of a Device can be determined based on its IP
address.

Two additional use cases are addressed by this document.  In the
first, location configuration requires additional or alternative
identifiers from the source IP address provided in the request.  In
the second, an entity other than the Device requests the location of
the Device.

This document extends the HELD protocol to allow the location request
message to carry Device identifiers.  Privacy and security
considerations describe the conditions where requests containing
identifiers are permitted.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-held-identity-extensions-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 21 Jun 2010 13:21:09 +0800

This version clears draft nits (mostly unused references), plus the following minor updates:

- Alissa also noticed that the "v" attribute that identifies the IP version was optional.  This attribute has been made mandatory.

- The idnabis-defs reference has also been made normative.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, 21 June 2010 2:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Geopriv] I-D Action:draft-ietf-geopriv-held-identity-
> extensions-04.txt
>