Subject: [Geopriv] HELD and GET

From: "Thomson, Martin" <[email-masked]>
Date: Sat, 31 Jul 2010 08:08:06 +0800

I've had a little chat with the HTTP gurus (Thomas, Mark, Yves) and gotten the feedback that not doing GET would be...stupid.

I am sympathetic to the suggestion that one method is easier, but in this case, the delta in terms of mechanism and implementation is so trivial, it's actually hard to imagine how this would be a bad thing.

On the flip side, there are too many cases where we bastardised the use of HTTP in the past.  I would like to make some steps to rectify this.

--Martin

p.s.  I don't mind sharing this.  This is almost exactly what we do in our implementation:

handlePost(request) {
  doHELD(request, request.body);
}

handleGet(request) {
  doHELD(request, prebuiltBody);
}

---

From: "Richard L. Barnes" <[email-masked]>
Date: Sat, 31 Jul 2010 02:45:45 +0200

<hat type="individual">

This seems sensible to me.  It simplifies behavior for many clients  
and doesn't require much effort on the server.

--Richard

On Jul 31, 2010, at 2:08 AM, Thomson, Martin wrote:

> I've had a little chat with the HTTP gurus (Thomas, Mark, Yves) and  
> gotten the feedback that not doing GET would be...stupid.
>
> I am sympathetic to the suggestion that one method is easier, but in  
> this case, the delta in terms of mechanism and implementation is so  
> trivial, it's actually hard to imagine how this would be a bad thing.
>
> On the flip side, there are too many cases where we bastardised the  
> use of HTTP in the past.  I would like to make some steps to rectify  
> this.
>
> --Martin
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv