Subject: [Geopriv] FYI: OGC Seeks Comments on MovingObjectSnapshot Standard

From: "Carl Reed" <[email-masked]>
Date: Fri, 23 Jul 2010 16:35:39 -0600

Thought that this might be of interest.

Carl

----- Original Message ----- 
From: "OGC Press" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, July 23, 2010 3:01 PM
Subject: [Pc] OGC Seeks Comments on MovingObjectSnapshot Standard

> PRESS ANNOUNCEMENT FOR IMMEDIATE RELEASE
> For information about this announcement, contact:
>
> Lance McKee
> Senior Staff Writer
> Open Geospatial Consortium (OGC)
> Tel: +1-508-655-5858
> [email-masked]
>
> -----------------------------------------------------------------------
>
>
> Wayland, Mass., 23 July, 2010 - The Open Geospatial Consortium, Inc.
> (OGC®) is seeking public comment on a Geography Markup Language
> (GML) XML encoding for describing the characteristics of a moving
> object, such as a GPS enabled car. This candidate standard provides a
> way of describing in simple terms the motion of an object, such as a
> car driving through city streets or a person walking in a park.
>
> This candidate standard fills a need for "lightweight" packets of
> tracking information, such as direction and velocity that can be
> communicated between diverse platforms and applications supporting
> mobile location-aware devices. The GML encoding used in this candidate
> standard is compatible with a wide range of other standard encodings
> used in other communities, such as emergency services.
>
> The candidate standard and information on submitting comments on this
> document are available at
> http://www.opengeospatial.org/standards/requests/69.
> The public comment period closes on August 23rd, 2010.
>
> The OGC is an international consortium of more than 395 companies,
> government agencies, research organizations, and universities
> participating in a consensus process to develop publicly available
> geospatial standards. OGC Standards empower technology developers to
> make geospatial information and services accessible and useful with
> any application that needs to be geospatially enabled. Visit the
> OGC website at   http://www.opengeospatial.org/.
> _______________________________________________
> Pc mailing list
> [email-masked]
> https://lists.opengeospatial.org/mailman/listinfo/pc
>
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Jul 2010 22:45:48 +0800

Preface:

This is all written with the experience of building a (very) similar solution for the IETF:

  <http://datatracker.ietf.org/doc/draft-singh-geopriv-pidf-lo-dynamic/>

As well as involvement in W3C geolocation and their efforts in this field.

My comments are motivated by wanting to minimize the differences between solutions.

PART A

1. Evaluator: Martin Thomson <mailto:[email-masked]>
2. Submission: Moving Object Snapshot (10-034r3)

PART B

1. Requirement: n/a
2. Implementation Specification Section number: 5.2
3. Criticality: Major
4. Comments/justifications for changes:
Vertical position is not provided within the Point element, it is instead provided as a separate element.  While there is precedent for this, it is unnecessary and it actually complicates the implementation of the specification.  Using 4326 where the altitude/elevation is unknown and 4979 where the elevation is known would be both simpler and easier to implement.

1. Requirement: n/a
2. Implementation Specification Section number: 5.3
3. Criticality: Minor
4. Comments/justifications for changes:
The description of the local tangent plane could be expanded upon to include a more rigorous definition in terms of the position.  This definition could define vectors in WGS84 ECEF Cartesian space, for example.

1. Requirement: n/a
2. Implementation Specification Section number: 7
3. Criticality: Major
4. Comments/justifications for changes:
The scalarAcceleration component lacks description in the body of the document.  However, I would recommend its removal entirely.  A more complete (and therefore useful) specification for instantaneous acceleration is under discussion in the W3C in relation to their device orientation API.

1. Requirement: n/a
2. Implementation Specification Section number: 5.4
3. Criticality: Minor
4. Comments/justifications for changes:
The document only provides for a definition of velocity on the LTP.  This is likely to be constraining for many applications.

1. Requirement: n/a
2. Implementation Specification Section number: 6
3. Criticality: Editorial
4. Comments/justifications for changes:
The example does not include an srsName attribute.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Carl Reed
> Sent: Saturday, 24 July 2010 12:36 AM
> To: [email-masked]
> Subject: [Geopriv] FYI: OGC Seeks Comments on MovingObjectSnapshot
> Standard
> 
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv