Subject: [Geopriv] WGLC: draft-ietf-geopriv-dhcp-lbyr-uri-option-08

From: Alissa Cooper <[email-masked]>
Date: Mon, 23 Aug 2010 11:24:30 +0100

This is a GEOPRIV Working Group Last Call for comments on
draft-ietf-geopriv-dhcp-lbyr-uri-option-08

Please send your comments to the list by 6 September 2010.  As always,  
please remember to send a note in if you've read the document and have  
no other comments other than "its ready to go" - we need those as much  
as we need "I found a problem."

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 25 Aug 2010 17:31:26 -0400

<hat type="individual"/>

I have reviewed this document and believe that with the current  
version's new privacy text, it is ready to go.

--Richard

On Aug 23, 2010, at 6:24 AM, Alissa Cooper wrote:

> Please send your comments to the list by 6 September 2010.  As  
> always, please remember to send a note in if you've read the  
> document and have no other comments other than "its ready to go" -  
> we need those as much as we need "I found a problem."
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Fri, 27 Aug 2010 14:43:27 +0800

I too am happy that this document is ready to go.

--Martin

p.s. Don't forget to remove Resv and Ver

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Richard L. Barnes
> Sent: Thursday, 26 August 2010 7:31 AM
> To: Alissa Cooper
> Cc: [email-masked]
> Subject: Re: [Geopriv] WGLC: draft-ietf-geopriv-dhcp-lbyr-uri-option-08
> 
> <hat type="individual"/>
>

---

From: Marc Linsner <[email-masked]>
Date: Fri, 27 Aug 2010 08:32:25 -0400

Why is this a MUST?

"
3. DHC Option Operation

   The [RFC3046] RAIO MUST be utilized to provide the appropriate
   indication to the DHCP Server where this DISCOVER or REQUEST message
   came from, in order to supply the correct response.  That said, this
   Option SHOULD NOT be in a DISCOVER message, because there is zero
   knowledge by the client of which Server will answer.
"

We (Martin, Bernard, and I) just had this conversation wrt 3825bis.  I can
build a DHC server with a backend location determination mechanism that does
not require RAIO.  I'm not suggesting this document describe an alternative
mechanism, I'm suggesting that RAIO be mentioned as one way to perform
location determination, not require it with a MUST.

-Marc-

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 27 Aug 2010 08:53:33 -0400

Makes sense to me to have this be consistent with rfc3825bis.  I'm  
assuming you mean this phrase:
"
The DHCP server is assumed to have determined the location from the  
Circuit-ID Relay Agent Information Option (RAIO) defined (as SubOpt 1)  
in [2].
"

This seems to be saying "we're assuming it's done this way; if you can  
make it work otherwise, fine."  Would the corresponding change to  
James's document then be to change "MUST" to "can"?

--Richard

On Aug 27, 2010, at 8:32 AM, Marc Linsner wrote:

>> always,

---

From: Marc Linsner <[email-masked]>
Date: Fri, 27 Aug 2010 09:31:34 -0400

Yes, replace MUST with can.

But now, as I read the rest of the paragraph I¹m confused further.

³That said, this Option SHOULD NOT be in a DISCOVER message, because there
is zero knowledge by the client of which Server will answer.²

What option?  RAIO?  This URI?  Why?  (the explanation doesn¹t make sense to
me)

-Marc-

On 8/27/10 8:53 AM, "Richard L. Barnes" <[email-masked]> wrote:

> Makes sense to me to have this be consistent with rfc3825bis.  I'm assuming
> you mean this phrase:
> "
> The DHCP server is assumed to have determined the location from the Circuit-ID
> Relay Agent Information Option (RAIO) defined (as SubOpt 1) in [2].
> "
> 
> This seems to be saying "we're assuming it's done this way; if you can make it
> work otherwise, fine."  Would the corresponding change to James's document
> then be to change "MUST" to "can"?
> 
> --Richard
> 
> 
>