Subject: [Geopriv] I-D Action:draft-ietf-geopriv-deref-protocol-01.txt

From: [email-masked]
Date: Tue, 28 Sep 2010 19:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Geographic Location/Privacy Working Group of the IETF.

	Title           : A Location Dereferencing Protocol Using HELD
	Author(s)       : J. Winterbottom, et al.
	Filename        : draft-ietf-geopriv-deref-protocol-01.txt
	Pages           : 23
	Date            : 2010-09-28

This document describes how to use the Hypertext Transfer Protocol
(HTTP) over Transport Layer Security (TLS) as a dereferencing
protocol to resolve a reference to a Presence Information Data Format
Location Object (PIDF-LO).  The document assumes that a Location
Recipient possesses a secure HELD URI that can be used in conjunction
with the HELD protocol to request the location of the Target.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-deref-protocol-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 29 Sep 2010 12:28:59 +0800

I've made this update to include the changes discussed at IETF-78.

The document now describes what an HTTP GET request means. 

Diff here:
  <http://tools.ietf.org/rfcdiff?url2=draft-ietf-geopriv-deref-protocol-01.txt>

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 29 Sep 2010 00:42:13 -0400

Supporting GET is a good idea.  It makes the simple case simpler.

One minor comment: Given that one reason for supporting GET is  
generic, non-HELD/PIDF-aware clients, doesn't it seem a little odd  
that the GET example includes:
Accept: application/pidf+xml,application/held+xml;q=0.5

It might be a little more realistic to use something like a typical  
XHR Accept line:
Accept: application/xml,text/xml;q=0.5,*;q=0.1

On Sep 29, 2010, at 12:28 AM, Thomson, Martin wrote:

>  <http://tools.ietf.org/rfcdiff?url2=draft-ietf-geopriv-deref-protocol-01.txt 
> >
>
>> http://www.ietf.org/internet-drafts/draft-ietf-geopriv-deref- 
>> protocol-
>> 01.txt
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 29 Sep 2010 13:04:14 +0800

> Supporting GET is a good idea.  It makes the simple case simpler.

Very simple :)

> Accept: application/xml,text/xml;q=0.5,*;q=0.1

I do take the comment for the first example GET request - that's definitely worth updating to include a typical Accept header.

But not the second one.  If you want this sort of behaviour, you have to know what you are getting.  That means that this isn't a HELD- and PIDF-aware client.

The typical Accept here isn't much use in selecting one document type over another.  Both fall types under '*;q=0.1'.  The typical request doesn't express a useful preference.

The other thing to consider here is how this unaware client might become aware.  They do this by triggering a useful default response.  If that isn't a location response, they never get the opportunity to learn that HELD works here.

--Martin