Subject: [Geopriv] [geopriv] #39: AD review

From: "geopriv issue tracker" <[email-masked]>
Date: Wed, 29 Sep 2010 00:54:37 -0000

#39: AD review
---------------------------------------+------------------------------------
 Reporter:  bernard_aboba@…            |       Owner:  bernard_aboba@…           
     Type:  defect                     |      Status:  new                       
 Priority:  major                      |   Milestone:  draft-ietf-geopriv-3825bis
Component:  rfc3825bis                 |     Version:  1.0                       
 Severity:  Submitted WG Document      |    Keywords:                            
---------------------------------------+------------------------------------
 Comment:

 This document doesn't capture the issues with the version 0 DHCPv4 option
 that we discussed in Philadelphia.
 (See <http://www.ietf.org/proceedings/71/slides/geopriv-2/geopriv-2.htm>).
 It may not need to, since it is not trying to specify using the version 0
 DHCPv4 option to return an area covering another area. However, given the
 amount of conversation that went into understanding the limitation, some
 text explaining it seems warranted. It would also help motivate _why_
 there is now a version 1. (That said, there is text in section 1.2 that
 could be read to say a version 0 response could cover an arbitrary region
 to a desired level of precision - that text should be adjusted to make it
 clear that's not what's being claimed).

 Nits:

 Section 2.4 should call out that it is defining AType values.
 In this section (and elsewhere in the document), the older "AT"
 tag in the prose should be changed to use the "AType" tag in the new
 format layout.

 The last equation in section 2.4.5 has x on both sides. I suspect
 log2(x) should have been log2(Uncertainty)

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/geopriv/trac/ticket/39>
geopriv <http://tools.ietf.org/geopriv/>

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 29 Sep 2010 09:10:20 +0800

Maybe this could help:

This document describes conversions for the following conversions:

  version 0 to PIDF-LO
  version 1 to PIDF-LO
  PIDF-LO to version 1

Conversion to PIDF-LO does not increase uncertainty; conversion from PIDF-LO to version 1 increases uncertainty by less than a factor of 2 in each dimension.  However, it is not possible to translate an arbitrary PIDF-LO to version 0 with a bounded increase in uncertainty, thus the conversion to version 0 is not specified.

Alissa picked up the last nit a while back - but it must have been missed :)

--Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of geopriv issue tracker
Sent: Wednesday, 29 September 2010 10:55 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Geopriv] [geopriv] #39: AD review

#39: AD review

 Nits:

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv