Subject: Re: [Geopriv] WGLC: draft-ietf-geopriv-dhcp-lbyr-uri-option-08

From: "James M. Polk" <[email-masked]>
Date: Fri, 01 Oct 2010 14:40:02 -0500

I think the answer here is to change "MUST" to "can" in the first 
sentence, and just remove the second sentence of this paragraph (the 
one quoted below).

I just talked to Marc about this and he's ok with it.

James

At 08:31 AM 8/27/2010, Marc Linsner wrote:
>Yes, replace MUST with can.
>
>But now, as I read the rest of the paragraph I'm confused further.
>
>"That said, this Option SHOULD NOT be in a DISCOVER message, because 
>there is zero knowledge by the client of which Server will answer."
>
>What option?  RAIO?  This URI?  Why?  (the explanation doesn't make 
>sense to me)
>
>-Marc-
>
>
>On 8/27/10 8:53 AM, "Richard L. Barnes" 
><<[email-masked]>[email-masked]> wrote:
>
>Makes sense to me to have this be consistent with rfc3825bis.  I'm 
>assuming you mean this phrase:
>"
>The DHCP server is assumed to have determined the location from the 
>Circuit-ID Relay Agent Information Option (RAIO) defined (as SubOpt 1) in [2].
>"
>
>This seems to be saying "we're assuming it's done this way; if you 
>can make it work otherwise, fine."  Would the corresponding change 
>to James's document then be to change "MUST" to "can"?
>
>--Richard
>
>
>
>On Aug 27, 2010, at 8:32 AM, Marc Linsner wrote:
>
>Why is this a MUST?
>
>"
>3. DHC Option Operation
>
>    The [RFC3046] RAIO MUST be utilized to provide the appropriate
>    indication to the DHCP Server where this DISCOVER or REQUEST message
>    came from, in order to supply the correct response.  That said, this
>    Option SHOULD NOT be in a DISCOVER message, because there is zero
>    knowledge by the client of which Server will answer.
>"
>
>We (Martin, Bernard, and I) just had this conversation wrt 3825bis.  I can
>build a DHC server with a backend location determination mechanism that does
>not require RAIO.  I'm not suggesting this document describe an alternative
>mechanism, I'm suggesting that RAIO be mentioned as one way to perform
>location determination, not require it with a MUST.
>
>
>-Marc-
>
>
>On 8/23/10 6:24 AM, "Alissa Cooper" <<[email-masked]>[email-masked]> wrote:
>
>This is a GEOPRIV Working Group Last Call for comments on
>draft-ietf-geopriv-dhcp-lbyr-uri-option-08
>
>Please send your comments to the list by 6 September 2010.  As always,
>please remember to send a note in if you've read the document and have
>no other comments other than "its ready to go" - we need those as much
>as we need "I found a problem."
>
>
>
>
>
>
>
>
>
>
>
>
>_______________________________________________
>Geopriv mailing list
><[email-masked]>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv
>
>
>
>_______________________________________________
>Geopriv mailing list
><[email-masked]>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv
>
>
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv

---

From: Marc Linsner <[email-masked]>
Date: Fri, 01 Oct 2010 15:41:12 -0400

This works for me.

-Marc-