Subject: [Geopriv] CONSENSUS CALL: Civic address extensibility

From: "Richard L. Barnes" <[email-masked]>
Date: Tue, 30 Nov 2010 16:05:10 -0500

Hey all,

As a follow-up to our virtual interim this afternoon, the chairs would like to make a consensus call on the following questions:

A. Should this working group do something about civic address extensibility?	

B. Should we create a single extension element that can express registered, "global" elements?

C. Should we create a mechanism for private/local extensions in the DHCP civic address format, and recommendations about how to create private/local extensions in DHCP and XML?

Please send responses to the list no later than Friday, 3 December 2010.

Thanks,
--Richard

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 1 Dec 2010 05:10:50 +0800

> Hey all,
> 
> As a follow-up to our virtual interim this afternoon, the chairs would
> like to make a consensus call on the following questions:
> 

YES

> registered, "global" elements?

YES

> 
> C. Should we create a mechanism for private/local extensions in the DHCP
> civic address format, and recommendations about how to create
> private/local extensions in DHCP and XML?

YES

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: Ted Hardie <[email-masked]>
Date: Tue, 30 Nov 2010 15:02:56 -0800

> A. Should this working group do something about civic address extensibility?

Yes, provided "clarify how to do it within the existing mechanisms".

> B. Should we create a single extension element that can express registered, "global" elements?

No.

> C. Should we create a mechanism for private/local extensions in the DHCP civic address format, and recommendations about how to create private/local extensions in DHCP and XML?

I think you need to clarify whether "private" means "unknowable to
others" or something
else.  Relaxing the CAtype registry to fcfs would make it possible to
use it for local
extensions, but it would not be private.  What value of "private" is
required here?

regards,

Ted

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 1 Dec 2010 08:02:39 +0800

> extensions, but it would not be private.  What value of "private" is

I think that Richard intended "private" to be "local" or "constrained scope".  That is, interoperability is not widely sought, just within a specific community.

---

From: "Carl Reed" <[email-masked]>
Date: Tue, 30 Nov 2010 20:24:12 -0700

Yes, yes, and yes.

Carl

---

From: "Richard L. Barnes" <[email-masked]>
Date: Tue, 30 Nov 2010 23:45:59 -0500

Right, basically, "something that I don't care if anyone understands, just the people I have arranged things with".

--Richard