Subject: [Geopriv] "Do not track" header field

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 24 Jan 2011 16:41:41 -0500

This will likely come up on the WEBSEC list as well, but I thought this might be interesting to GEOPRIV folks:

Mozilla and Google Chrome are proposing to extend browsers to send a "do not track" HTTP header of the following form:
X-Tracking-Choice: do-not-track

This seems like another example of users sending along privacy preferences with their data, just like PIDF-LO privacy rules, Creative Commons licenses, etc.

References:
<http://firstpersoncookie.wordpress.com/2011/01/23/more-choice-and-control-over-online-tracking/>
<https://bugzilla.mozilla.org/show_bug.cgi?id=628197>
<https://bugzilla.mozilla.org/show_bug.cgi?id=628198>  

--Richard

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 25 Jan 2011 05:45:09 +0800

They should really drop the X-...

On 2011-01-25 at 08:41:41, Richard L. Barnes wrote:
> Mozilla and Google Chrome are proposing to extend browsers to send a
> "do not track" HTTP header of the following form:
> This seems like another example of users sending along privacy
> preferences with their data, just like PIDF-LO privacy rules, Creative
> Commons licenses, etc.
> 
> References:

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 24 Jan 2011 16:49:17 -0500

If you look at the Bugzilla link, Julian has already suggested that this go to WEBSEC for IETF approval and de-X-ification.
--Richard

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 25 Jan 2011 09:47:17 +0000

And I've been talking to Sid at Mozilla about getting a draft ready  
before IETF 80.

On Jan 24, 2011, at 9:49 PM, Richard L. Barnes wrote:

> If you look at the Bugzilla link, Julian has already suggested that  
> this go to WEBSEC for IETF approval and de-X-ification.
> --Richard
>
>
>>> This will likely come up on the WEBSEC list as well, but I thought  
>>> this
>>> might be interesting to GEOPRIV folks:
>>>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 27 Jan 2011 07:54:02 -0700

Thanks. I've forwarded this to the WEBSEC list.