Subject: [Geopriv] PIDF-LO uncertainty and confidence

From: "Winterbottom, James" <[email-masked]>
Date: Fri, 22 Mar 2013 08:30:37 +0800

Hi All,

I know that this is an old chestnut but as implementations of systems using PIDF-LO proliferate the need to express confidence at levels other than the 95% proposed in RFC5491 are needed.

Going back a few years Martin Thomson wrote  http://tools.ietf.org/html/draft-thomson-geopriv-confidence-03 which provided an acceptable means of adding confidence to the a geodetic object. This along with a good explanation of uncertainty described in http://tools.ietf.org/html/draft-thomson-geopriv-uncertainty-07 are two missing concepts form our current suite of specifications. I know that WG is kind of quiet, but completing these specifications before it finally closes would be a really good thing to accomplish.

Would it be possible to see if there is general interest within the group get something like these specifications chartered and worked on quickly?

Cheers
James

---

From: Brian Rosen <[email-masked]>
Date: Fri, 22 Mar 2013 09:13:20 -0400

I would like to see this work finish.

I will say that I've been uncomfortable with the position (snap) taken by Martin in regard to uncertainty.

Basically, the way that he proposes, and in fact the only way we currently have, to express a point with uncertainty is to express the uncertainty area.
That loses information.  You start with a  point with uncertainty, you end up with some area that may or may not have the point in it, but only reflects the uncertainty.

I think it would be better to send the original data, and also express the uncertainty.  They are related, to be sure, but a point with uncertainty and a circle is not the same thing, and if you have a more complex uncertainty area, it's definitely not the same thing.

I'll agree than in many use cases, having the uncertainty is what you want.  I'll agree that if you have a simple point with uncertainty expressed as a circle, you can guess the point pretty easily.

But I think it would be better to be able to express the original measurement, and express the uncertainty independently.

Brian

On Mar 21, 2013, at 8:30 PM, "Winterbottom, James" <[email-masked]> wrote:

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: Martin Thomson <[email-masked]>
Date: Fri, 22 Mar 2013 09:35:50 -0700

> I would like to see this work finish.

As would I.

> Martin in regard to uncertainty.

I've never had anyone try to explain this discomfort, thanks for trying.

> Basically, the way that he proposes, and in fact the only way we currently
> have, to express a point with uncertainty is to express the uncertainty
> area.
>
> That loses information.

Information loss is inevitable.  The information that the location
server has is not typically usable.  Hence the reduction to an
uncertainty region.

> You start with a  point with uncertainty,

Oh.  That's not actually true.  It's a common misconception, but I
didn't realize that this was the source of the contention.  It is true
in a subset of cases, but more often you reduce a series of
measurements to an uncertainty region without ever having any single
point.

Even if there was a way to express the location of the point that had
the highest probability of being the "correct" point, assigning
special significance to that point is actually dangerous, even if it
was the one point that a location server started with.

That said, the uncertainty draft does describe a way of picking a
point, and an explanation of the consequences of doing so.  That's
probably the most important function the draft provides: explaining
how to extract usable information from what you get.

> I think it would be better to send the original data, and also express the
> uncertainty.

I don't know if you recall Christian Hoene's draft and presentation on
providing richer location data.  It didn't get a lot of interest.  It
did exactly that:
  http://tools.ietf.org/html/draft-hoene-geopriv-bli

This describes how to describe residuals out of least-squares
estimation, or describe a probability density function numerically
(i.e., as a map of area to estimated probability).  It's complicated,
but very close to what a location (information) server actually has
when performing location determination.

The main concern with this sort of approach is not that the original
data is not present, but that there is too much of it and it's not
usable.

> But I think it would be better to be able to express the original
> measurement, and express the uncertainty independently.

That's what draft-ietf-geopriv-held-measurements does.  Unfortunately,
not everyone knows what to do with that information.  It comes back to
usability.  Now, we've made concessions to existing practice in
providing uncertainty shapes that convey more information than
point+scalar uncertainty, but that has a usability trade-off, which
this draft is intended to address.

---

From: "Winterbottom, James" <[email-masked]>
Date: Sat, 23 Mar 2013 03:43:42 +0800

Brian,

Given how most of the measurement algorithms work this just make sense because for the majority of them you never have a point. What you get is a bunch of intersecting hyperbolas that you can put an elipse over.

Cheers
James

From: Brian Rosen [mailto:[email-masked]]
Sent: Friday, March 22, 2013 09:13 PM
To: Winterbottom, James
Cc: [email-masked] WG <[email-masked]>
Subject: Re: [Geopriv] PIDF-LO uncertainty and confidence

Brian

On Mar 21, 2013, at 8:30 PM, "Winterbottom, James" <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

Cheers
James
_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Brian Rosen <[email-masked]>
Date: Fri, 22 Mar 2013 15:56:43 -0400

I don't like the notion of sending the raw data and requiring the receiver to make sense of it.
Rather, I think the sender should do it's best to determine the location.

I get the point (snap) that there is no "point", there is only the uncertainty area, but that is, like it or not, the least useful piece of information.  The senders best approximation is the actual actionable data, and the area is only marginally useful in certain unusual circumstances.

We often use emergency call, but for this discussion, let's just use "you are here" on a map, shown to your WiFi only iPad, based on info in your Android phone (so there is a geopriv protocol between them).

If I send you the circle for a 95% confidence, it's just not very helpful.  If I send you the point, and warn you that there is uncertainty, it becomes useful.
If I send you a polygon for the 95% confidence area, it's even more confusing.

Please send the point, and specify the uncertainty.

This is entirely the same as having package weight specified as 980-1100 grams.  It's true, it's precise, and it's useless.

The algorithm required to turn 980-1100 to 1000 -20, +100 is much more complex than warranted.  Just send the nominal and the variation - it's a lot more useful.

Brian

---

From: Martin Thomson <[email-masked]>
Date: Fri, 22 Mar 2013 13:21:58 -0700

A large part of the uncertainty draft describes how someone can obtain
the nominal value in a consistent fashion.

If you want to make new recommendations about what a location
information server produces, we could look at having multiple
locations in the PIDF-LO.  One for the uncertainty region, another for
the nominal point.  That would require mucking around with the RFC
5491 rules for number of locations.

If you want to ask a legacy system to provide this new information,
then you might be out of luck.  RFC 5491 defines these shapes for a
good reason.

All that is far more than what this draft is attempting to address.
It's intended to be informational.

On 22 March 2013 12:56, Brian Rosen <[email-masked]> wrote:
> I get the point (snap) that there is no "point", there is only the
> uncertainty area, but that is, like it or not, the least useful piece of
> information.  The senders best approximation is the actual actionable data,
> and the area is only marginally useful in certain unusual circumstances.
>
> We often use emergency call, but for this discussion, let's just use "you
> are here" on a map, shown to your WiFi only iPad, based on info in your
> Android phone (so there is a geopriv protocol between them).
>
> If I send you the circle for a 95% confidence, it's just not very helpful.
> If I send you the point, and warn you that there is uncertainty, it becomes
> useful.
> This is entirely the same as having package weight specified as 980-1100
> grams.  It's true, it's precise, and it's useless.
>
> The algorithm required to turn 980-1100 to 1000 -20, +100 is much more
> complex than warranted.  Just send the nominal and the variation - it's a
> lot more useful.
>
> Brian
>
> On Mar 22, 2013, at 3:43 PM, "Winterbottom, James"
> <[email-masked]> wrote:
>
> Brian,
>
> Given how most of the measurement algorithms work this just make sense
> because for the majority of them you never have a point. What you get is a
> bunch of intersecting hyperbolas that you can put an elipse over.
>
> Cheers
> James
>
> That loses information.  You start with a  point with uncertainty, you end
> up with some area that may or may not have the point in it, but only
> reflects the uncertainty.
>
> uncertainty.  They are related, to be sure, but a point with uncertainty and
> a circle is not the same thing, and if you have a more complex uncertainty
> area, it's definitely not the same thing.
>
> I'll agree than in many use cases, having the uncertainty is what you want.
> I'll agree that if you have a simple point with uncertainty expressed as a
> circle, you can guess the point pretty easily.
>
> On Mar 21, 2013, at 8:30 PM, "Winterbottom, James"
> <[email-masked]> wrote:
>
> Hi All,
>
> I know that this is an old chestnut but as implementations of systems using
> PIDF-LO proliferate the need to express confidence at levels other than the
> 95% proposed in RFC5491 are needed.
>
> Going back a few years Martin Thomson wrote
> http://tools.ietf.org/html/draft-thomson-geopriv-confidence-03 which
> provided an acceptable means of adding confidence to the a geodetic object.
> This along with a good explanation of uncertainty described in
> http://tools.ietf.org/html/draft-thomson-geopriv-uncertainty-07 are two
> missing concepts form our current suite of specifications. I know that WG is
> kind of quiet, but completing these specifications before it finally closes
> would be a really good thing to accomplish.
>
> Would it be possible to see if there is general interest within the group
> get something like these specifications chartered and worked on quickly?
>
> Cheers
> James

---

From: Brian Rosen <[email-masked]>
Date: Fri, 22 Mar 2013 16:26:55 -0400

I would muck with 4119/5491 to add a gml shape for uncertainty to the structure.  It wouldn't be two locations, I would add an explicit uncertainty region to a location.  In the same way, I would add the confidence value.

I understand what the draft does.  I'm arguing to do more, and that would include normative upgrades to PIDF-LO.

Brian

---

From: Martin Thomson <[email-masked]>
Date: Fri, 22 Mar 2013 13:34:29 -0700

I'm not sure that what you suggest could be made backward compatible,
but I'm not opposed to doing more.  I am somewhat opposed to attaching
that to the uncertainty document.  It's already big enough.

The confidence document scope could be expanded to cover what you want
to do.  James, what do you think?

---

From: Brian Rosen <[email-masked]>
Date: Fri, 22 Mar 2013 16:48:11 -0400

Re Backwards compatible

Can we not add a new namespace to be used in <geopriv> that defines confidence and uncertainty, where uncertainty is a shape from 5491?

Brian

---

From: Martin Thomson <[email-masked]>
Date: Fri, 22 Mar 2013 14:39:16 -0700

> Can we not add a new namespace to be used in <geopriv> that defines confidence and uncertainty, where uncertainty is a shape from 5491?

Sure, you can do that, but that alone doesn't guarantee backwards compatibility.

---

From: "Winterbottom, James" <[email-masked]>
Date: Sat, 23 Mar 2013 07:00:36 +0800

I am not sure that I understand what Brian means.
To me all points within the area have the same likelihood of being where the thing is.
We already have this in 5491.

The confidence is simply the measure of that likelihood and as long as we can constrain it to that area I don't really care where we put it.

I really wish that we had kept the original gel circle construct now though Martin as it would avoid the whole misconception that anyone point is more important than any other.

Cheers
James
________________________________________
From: Martin Thomson [[email-masked]]
Sent: Friday, March 22, 2013 3:34 PM
To: Brian Rosen
Cc: Winterbottom, James; [email-masked]
Subject: Re: [Geopriv] PIDF-LO uncertainty and confidence

---

From: Martin Thomson <[email-masked]>
Date: Fri, 22 Mar 2013 16:38:21 -0700

Bottom line: We're describing an approximation of what can be a very
complex 4 or 5 dimensional shape.  All variations are imperfect in
different interesting ways.  The best we can do is help people
understand a little of what lies beyond so that they don't make the
wrong sorts of assumptions.

We can also improve the abstraction to meet application needs.  I'm
not sure that we need to add a point + uncertainty representation.
It's of limited utility, especially once you have the tools provided
by the -uncertainty draft.  I'm willing to continue to discuss merits
each way though.

> We already have this in 5491.

Actually, we don't say anything about the probability distribution
within the uncertainty region.  Some technologies are exactly how you
describe, others are roughly normally distributed, but I do know of
several technologies that don't do anything approximating either.

> The confidence is simply the measure of that likelihood and as long as we can constrain it to that area I don't really care where we put it.

Yes.  When we chose uncertainty, we implied confidence.  RFC 5491
fixed the value, which turns out to be a little too inflexible.

> I really wish that we had kept the original gel circle construct now though Martin as it would avoid the whole misconception that anyone point is more important than any other.

The original GML Circle is mathematically correct, but it does have a
fairly nasty usability problem.  I'm not sure that we would want to
use it just to spite Brian :)

---

From: "Carl Reed" <[email-masked]>
Date: Sat, 23 Mar 2013 16:53:19 -0600

The following may not be germane to the discussion at hand, but those of you 
interested in uncertainty and provenance may be interested in some recently 
published OGC activities related to uncertainty and provenance. From a 
standards development process, when considering a measurement or an 
observable, provenance, uncertainty, and data quality are all related.

OGC 12-160 OWS 9 Data Quality and Web Mapping Engineering Report (2013)
https://portal.opengeospatial.org/files/?artifact_id=52765

Cross Community Interoperability Conflation with Provenance (2013)
https://portal.opengeospatial.org/files/?artifact_id=51818

NetCDF Uncertainty Conventions (2012)
https://portal.opengeospatial.org/files/?artifact_id=46702

OGC activities and standards work related to uncertainty, data quality, and 
provenance are planned to continue in 2013 and beyond.

And another non-OGC reference used by our Members:

Bich W, Cox MG, Harris PM. Evolution of the Guide to the Expression of 
Uncertainty in Measurement_. Metrologia. 2006;43:S161_S166

While the OGC activities related to uncertainty may not be specifically 
relevant to the discussion here, please be aware that the requirements and 
approach being discussed in this thread become use cases and requirements 
for helping us (OGC) define a general abstract model for expressing 
uncertainty of geospatial/sensor observations and measurements, of 
geospatial analytic processing, simulation, and modeling.

Also, the OGC Board has a sub-group titled Spatial Legal. This group 
discusses issues and implications related to the legal aspects of using 
geospatial content and services. The group is lead by a lawyer who 
specializes in law related to things spatial and GIS. Central to many of 
their discussions are uncertainty, data quality, and uncertainty. A very 
important topic indeed!

Thanks and regards

Carl

-----Original Message----- 
From: Martin Thomson
Sent: Friday, March 22, 2013 5:38 PM
To: Winterbottom, James
Cc: [email-masked]
Subject: Re: [Geopriv] PIDF-LO uncertainty and confidence

> The confidence is simply the measure of that likelihood and as long as we 
> can constrain it to that area I don't really care where we put it.

> I really wish that we had kept the original gel circle construct now 
> though Martin as it would avoid the whole misconception that anyone point 
> is more important than any other.