Subject: [Geopriv] RFC 5491 clarification question

From: Ray Bellis <[email-masked]>
Date: Tue, 23 Apr 2013 13:20:43 +0000

RFC 5491 says:

"The use of the world geodetic system 1984 (WGS84) [WGS84]
 coordinate reference system and the usage of European
 petroleum survey group (EPSG) code 4326 (as identified by
 the URN urn:ogc:def:crs:EPSG::4326, [CRS-URN]) for two-
 dimensional (2d) shape representations and EPSG 4979 (as
 identified by the URN urn:ogc:def:crs:EPSG::4979) for
 three-dimensional (3d) volume representations is mandated."

Is this intended to constrain PIDF-LO to _only_ the above, or just make this the minimum required for "conformance" ?

My "plain English" reading of the text is that it's the former.

thanks,

Ray

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2013 09:11:59 -0700

Good question.

I think that either interpretation of the text is valid at face value.
 However, when you consider both production and consumption of
PIDF-LO, then I think that the only rational conclusion is that using
a different CRS would result in interoperability issues.

I wonder if this isn't worth an erratum.  Along with a suggested
reword.  Then we could avoid the passive voice.

"""
PIDF-LO documents MUST use the world geodetic system 1984 (WGS84)
[WGS84] coordinate reference system.  WGS84 MUST be idenfied using the
European petroleum survey group (EPSG) code 4326 (as identified by the
URN urn:ogc:def:crs:EPSG::4326, [CRS-URN]) for two-dimensional (2d)
shape representations or EPSG 4979 (as identified by the URN
urn:ogc:def:crs:EPSG::4979) for three-dimensional (3d) volume
representations.
"""

That encourages the former interpretation, I think.

--Martin

On 23 April 2013 06:20, Ray Bellis <[email-masked]> wrote:
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Carl Reed" <[email-masked]>
Date: Tue, 23 Apr 2013 11:30:11 -0600

Concur

Carl

-----Original Message----- 
From: Martin Thomson
Sent: Tuesday, April 23, 2013 10:11 AM
To: Ray Bellis
Cc: GEOPRIV WG
Subject: Re: [Geopriv] RFC 5491 clarification question

Good question.

"""

--Martin

On 23 April 2013 06:20, Ray Bellis <[email-masked]> wrote:
> Is this intended to constrain PIDF-LO to _only_ the above, or just make 
> this the minimum required for "conformance" ?
>

---

From: James Polk <[email-masked]>
Date: Tue, 23 Apr 2013 13:30:24 -0500

At 08:20 AM 4/23/2013, Ray Bellis wrote:
>Is this intended to constrain PIDF-LO to _only_ the above, or just 
>make this the minimum required for "conformance" ?
>

'WGS84 via both 4326 _and_ 4979 are mandated'.

should be enough said...

James

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 24 Apr 2013 06:06:11 +0800

I think that this is a sensible approach. Thanks Martin.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Martin Thomson
Sent: Wednesday, 24 April 2013 2:12 AM
To: Ray Bellis
Cc: GEOPRIV WG
Subject: Re: [Geopriv] RFC 5491 clarification question

Good question.

I think that either interpretation of the text is valid at face value.
 However, when you consider both production and consumption of PIDF-LO, then I think that the only rational conclusion is that using a different CRS would result in interoperability issues.

I wonder if this isn't worth an erratum.  Along with a suggested reword.  Then we could avoid the passive voice.

"""
PIDF-LO documents MUST use the world geodetic system 1984 (WGS84) [WGS84] coordinate reference system.  WGS84 MUST be idenfied using the European petroleum survey group (EPSG) code 4326 (as identified by the URN urn:ogc:def:crs:EPSG::4326, [CRS-URN]) for two-dimensional (2d) shape representations or EPSG 4979 (as identified by the URN
urn:ogc:def:crs:EPSG::4979) for three-dimensional (3d) volume representations.
"""

--Martin

On 23 April 2013 06:20, Ray Bellis <[email-masked]> wrote:
> RFC 5491 says:
>
> "The use of the world geodetic system 1984 (WGS84) [WGS84]  coordinate 
> reference system and the usage of European  petroleum survey group 
> (EPSG) code 4326 (as identified by  the URN 
> urn:ogc:def:crs:EPSG::4326, [CRS-URN]) for two-  dimensional (2d) 
> shape representations and EPSG 4979 (as  identified by the URN 
> representations is mandated."
>