Subject: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

From: Laura Liess <[email-masked]>
Date: Wed, 31 Jul 2013 13:56:41 +0200

Martin,

The German regulator requires the confidence to be sent to the PSAP.  The
regulator requirements are based on the ETSI specification, where
confidence is required, too.

We do not have a confidence element in PIDF-LO today. Your draft
http://tools.ietf.org/id/draft-thomson-geopriv-confidence-03.txt  proposes
this but it is currently expired. Is it possible for you to submit the
document again? I think this time we have a clear usecase for it.
Publishing this draft as an RFC would avoid national and maybe incompatible
extensions.

In this context I think the draft
http://tools.ietf.org/id/draft-thomson-geopriv-uncertainty-07.tx<http://tools.ietf.org/id/draft-thomson-geopriv-uncertainty-07.txt>
t <http://tools.ietf.org/id/draft-thomson-geopriv-uncertainty-07.txt> is
also a very useful document to educate people on how to use uncertainty and
confidence and that tey are used in the wrond way. I think it would be
usefull to get it published.

Please find below the link to the German regulatory requirements including
the requirement to send the confidence (Tables I4-A-5 and I4-A-7).
Unfortunately, I couldn't find an english version.
http://www.bundesnetzagentur.de/SharedDocs/Downloads/DE/Sachgebiete/Telekommunikation/Unternehmen_Institutionen/Notruf/TRNotruf.pdf;jsessionid=9741B92CDD3B4D7F25572343E81727F5?__blob=publicationFile&v=2

Thank you
Laura

---

From: James Winterbottom <[email-masked]>
Date: Wed, 31 Jul 2013 22:04:53 +1000

Hi Laura,

Several organisations would like to confidence in PIDF-LO and I raised this same question earlier this year. I think that this draft needs to move forward but unless we get enough support it won't be adopted as work by geopriv.

Cheers
James

Sent from my iPad

On 31/07/2013, at 9:56 PM, Laura Liess <[email-masked]> wrote:

> Martin,
> 
> The German regulator requires the confidence to be sent to the PSAP.  The regulator requirements are based on the ETSI specification, where confidence is required, too. 
> 
> We do not have a confidence element in PIDF-LO today. Your draft  http://tools.ietf.org/id/draft-thomson-geopriv-confidence-03.txt  proposes this but it is currently expired. Is it possible for you to submit the document again? I think this time we have a clear usecase for it.  Publishing this draft as an RFC would avoid national and maybe incompatible extensions.
>   
> In this context I think the draft http://tools.ietf.org/id/draft-thomson-geopriv-uncertainty-07.txt is also a very useful document to educate people on how to use uncertainty and confidence and that tey are used in the wrond way. I think it would be usefull to get it published. 
> 
> Please find below the link to the German regulatory requirements including the requirement to send the confidence (Tables I4-A-5 and I4-A-7). Unfortunately, I couldn't find an english version. 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 14:10:15 +0200

I'm prepared to revive these drafts if there is sufficient interest in
doing so.  Either or both.

Both are, in my opinion at least, in a fairly good state.  Uncertainty
has actually had a lot of review.

On 31 July 2013 13:56, Laura Liess <[email-masked]> wrote:
> regulator requirements are based on the ETSI specification, where confidence
> is required, too.
>
> http://tools.ietf.org/id/draft-thomson-geopriv-uncertainty-07.txt is also a
> very useful document to educate people on how to use uncertainty and

---

From: James Winterbottom <[email-masked]>
Date: Wed, 31 Jul 2013 22:11:56 +1000

I agree Martin and I would like to see both progress.

Sent from my iPad

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 31 Jul 2013 08:17:03 -0400

+1

As for Germany, there is a regulatory requirement in Canada to pass the confidence % and the uncertainty value along with the lat/long to PSAPs.

Guy

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de James Winterbottom
Envoyé : 31 juillet 2013 08:12
À : Martin Thomson
Cc : GEOPRIV WG
Objet : Re: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

Sent from my iPad

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 31 Jul 2013 14:25:58 +0200

I also think it would be good to get those completed.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 14:32:00 +0200

I have recovered my copy of -uncertainty and put it up on github.  I
am happy to accept contributions.

https://github.com/martinthomson/drafts

I don't have the source for -confidence, which got lost when I moved,
but James is looking into this.  At worst, I can easily recreate this
(it's just a little tedious to do so).

---

From: James Winterbottom <[email-masked]>
Date: Wed, 31 Jul 2013 22:37:04 +1000

I hope to get this tomorrow.

Sent from my iPad

---

From: Brian Rosen <[email-masked]>
Date: Wed, 31 Jul 2013 08:38:20 -0400

I have opposed this draft in the past, because it makes uncertaintyn(and
confidence) useless at the receiver.  In the environments I am aware of,
when both are provided,  both are IGNORED, because no one had any idea what
to do with it.  If the confidence is fixed at 95%, most users consider the
uncertainty area to represent a search area, in which the target will be
found, allowing for the 5 % possibility that it won't.

The draft says that the problem is that the sender may not have enough
information to do an accurate conversion to a confidence of 95%. True, but
the recipient has even less information.  It would be better to get the
sender to do the conversion than to expect the recipient to do it.

The only reason to have confidence at less than 95% is to make uncertainty
appear smaller.  It's marketing.

I challenge anyone who supports this for any reason other than "my
regulator told me to" to describe how you would display a location on a
map when confidence ranges between 50 and 95% in some way that a human
could understand it, or describe an automaton that can actually use the
data in some useful way in the same circumstances.

If we have to solve a "my regulator told me to", okay, but I want a huge
disclaimer that screams don't do this.

Brian

On Wednesday, July 31, 2013, Martin Thomson wrote:

> On 31 July 2013 13:56, Laura Liess <[email-masked]<javascript:;>>
> wrote:
> > Martin,
> >
> [email-masked] <javascript:;>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 14:45:00 +0200

> appear smaller.  It's marketing.

That's just not true.  Unless you are the entity performing location
determination, it is impossible to increase confidence in location.
And in the systems that the folks on this list are talking about rely
on location determination that does not produce 95% confidence.  This
is an interoperability issue.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 14:50:49 +0200

Laura found me the source.  Thanks Laura.  (I know that I should have
thought to ask my favorite search engine before looking foolish and
making people do my work for me.)

---

From: Brian Rosen <[email-masked]>
Date: Wed, 31 Jul 2013 08:53:24 -0400

As I understand it, all of this is statistics, and the location
determination mechanisms could produce 95% confidence, but some vendors
choose not to.

But back to the challenge.  If you allow confidence to vary, how do you
display the data, or how do you use it I a downstream system?

Brian
On Wednesday, July 31, 2013, Martin Thomson wrote:

> On 31 July 2013 14:38, Brian Rosen <[email-masked] <javascript:;>>
> wrote:

---

From: Laura Liess <[email-masked]>
Date: Wed, 31 Jul 2013 14:54:43 +0200

Brian,

I will try to find out if DT has any information on this issue.
Anyway, having the draft published with the huge disclaimer would be better
than leaving to national bodies to add the field (because they will do it
for sure without disclaimer).

Thank you
Laura

2013/7/31 Brian Rosen <[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 15:01:05 +0200

> determination mechanisms could produce 95% confidence, but some vendors

It is not always possible to simply scale up at the location generator either.

> display the data, or how do you use it I a downstream system?

It *is* a challenge, but I believe it's a challenge that PSAPs deal
with today.  That is, they deal with it, even if they might wish they
didn't have to.

As Laura says, this is better published with an appropriate warning,
than not at all.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 31 Jul 2013 09:06:45 -0400

> It is not always possible to simply scale up at the location generator either.

I'm assuming that's because errors do not have an approximately normal (Gaussian) distribution for some or all location determination methods?

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 15:23:38 +0200

> I'm assuming that's because errors do not have an approximately normal (Gaussian) distribution for some or all location determination methods?

In part.  Gaussian distributions are actually becoming the exception
rather than the rule.

Also, it's possible that provisioning errors contribute a greater than
5% reduction in confidence.  Getting good databases is a really hard
operational problem.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 15:25:49 +0200

> 5% reduction in confidence.  Getting good databases is a really hard

I should expand on that.  A lot of location determination relies on
having good databases of reference locations, for example cell sites.
Network operators spend a lot of time and effort on maintaining these
databases, but errors do inevitably occur.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 31 Jul 2013 09:32:40 -0400

But can you capture these provisioning problems in any kind of confidence indication? If an error occurs that places a Berlin base station in Orlando (e.g., due to a typo in the long/lat data), the notion of a confidence ring doesn't make a whole lot of sense. (Yes, the example is based on what somebody mentioned regarding where his iPhone thought he was.)

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2013 15:41:26 +0200

On 31 July 2013 15:32, Henning Schulzrinne <[email-masked]> wrote:
> But can you capture these provisioning problems in any kind of confidence indication? If an error occurs that places a Berlin base station in Orlando (e.g., due to a typo in the long/lat data), the notion of a confidence ring doesn't make a whole lot of sense.

You cannot capture these sorts of errors in an *uncertainty*
indication (larger circles, etc..)  But the purpose of confidence is
to say: the location you have is probably correct 68% of the time,
based on what I know about similar situations.

Thus, if you have a large and dodgy database (say of WiFi access
points) that has a particular high, but historically known, error
rate, you can factor that into any expression of confidence.

---

From: Roger Marshall <[email-masked]>
Date: Wed, 31 Jul 2013 16:32:32 +0000

I support these two drafts moving forward.  And, rather than having to figure out some ideal way to display confidence as a gating factor right now, once we have real values conveyed, we can likely figure out something useful .  

These two drafts promote the ability to report actual numeric values.  That's a good place to start.  Leaving the value(s) as implied or assumed just doesn't make for good engineering.

-roger marshall.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Martin Thomson
Sent: Wednesday, July 31, 2013 6:41 AM
To: Henning Schulzrinne
Cc: GEOPRIV WG
Subject: Re: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

> But can you capture these provisioning problems in any kind of confidence indication? If an error occurs that places a Berlin base station in Orlando (e.g., due to a typo in the long/lat data), the…

You cannot capture these sorts of errors in an *uncertainty* indication (larger circles, etc..)  But the purpose of confidence is to say: the location you have is probably correct 68% of the time, based on what I know about similar situations.

Thus, if you have a large and dodgy database (say of WiFi access
points) that has a particular high, but historically known, error rate, you can factor that into any expression of confidence.
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.