Subject: Re: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

From: Martin Thomson <[email-masked]>
Date: Sat, 3 Aug 2013 15:05:15 +0200

On 31 July 2013 18:32, Roger Marshall <[email-masked]> wrote:
> I support these two drafts moving forward.  And, rather than having to figure out some ideal way to display confidence as a gating factor right now, once we have real values conveyed, we can likely figure out something useful .
>
> These two drafts promote the ability to report actual numeric values.  That's a good place to start.  Leaving the value(s) as implied or assumed just doesn't make for good engineering.

Roger makes a good point.  However, having spoken with Brian, I think
that it is important to highlight the implications of expressing
confidence, with an appropriate amount of discouragement.  This is
really only for cases where it's difficult to get location with a high
confidence.

I've done a little editing, though I don't know if this is actually
going to make sense, since it was all done on the train, and I don't
remember the entire journey because I was so tired, but here's what
I'm proposing to add to the draft.

2.2.  Consuming and Presenting Confidence

   The inclusion of confidence that is anything other than 95% presents
   a potentially difficult usability for applications that use location
   information.  Effectively communicating the probability that a
   location is incorrect to a user can be difficult.

   It is inadvisable to simply display locations of any confidence, or
   to display confidence in a separate or non-obvious fashion.  If
   locations with different confidence levels are displayed such that
   the distinction is subtle or easy to overlook - such as using fine
   graduations of color or transparency for graphical uncertainty
   regions, or displaying uncertainty graphically, but providing
   confidence as supplementary text - a user could fail to notice a
   difference in the quality of the location information that might be
   significant.

   Depending on the circumstances, different ways of handling confidence
   might be appropriate.  [I-D.thomson-geopriv-uncertainty] describes
   techniques that could be appropriate for consumers that use automated
   processing as well as background on the issue.

   Providing that the full implications of any choice for the
   application are understood, some amount of automated processing could
   be appropriate.  In a simple example, applications could choose to
   discard or suppress the display of location information if confidence
   does not meet a pre-determined threshold.

   In settings where there is an opportunity for user training, some of
   these problems might be mitigated by defining different operational
   procedures for handling location information at different confidence
   levels.

Now that I look at it, it's a lot of text, so it can probably be cut
down, but I think that it conveys the right sentiment.

---

From: James Winterbottom <[email-masked]>
Date: Mon, 26 Aug 2013 09:59:23 +1000

Do we have enough consensus to proceed with this drafts become WG items,
WG, Chairs?

On Sat, Aug 3, 2013 at 11:05 PM, Martin Thomson <[email-masked]>wrote:

> > I support these two drafts moving forward.  And, rather than having to
> figure out some ideal way to display confidence as a gating factor right
> now, once we have real values conveyed, we can likely figure out something
> useful .
> >
> > These two drafts promote the ability to report actual numeric values.
>  That's a good place to start.  Leaving the value(s) as implied or assumed
> just doesn't make for good engineering.
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 26 Aug 2013 05:53:41 -0400

I think these are both obviously in scope of our charter, so if the authors want to rev them, we can do a consensus call for WG adoption and see what we get. It would be helpful to get a sense of who is willing to review these drafts if we do adopt them.

Alissa

On Aug 25, 2013, at 7:59 PM, James Winterbottom <[email-masked]> wrote:

> Do we have enough consensus to proceed with this drafts become WG items, WG, Chairs?
> 
> 
> On Sat, Aug 3, 2013 at 11:05 PM, Martin Thomson <[email-masked]> wrote:

---

From: Roger Marshall <[email-masked]>
Date: Mon, 26 Aug 2013 20:28:35 +0000

I support the adoption.  I'm confident that we can get some reviewers!

-roger marshall.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Monday, August 26, 2013 2:54 AM
To: James Winterbottom
Cc: GEOPRIV WG
Subject: Re: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

Alissa

> down, but I think that it conveys the right sentiment.

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

---

From: Roger Marshall <[email-masked]>
Date: Mon, 26 Aug 2013 20:30:19 +0000

Martin:
I think the text is good enough for now - for inclusion.

-roger.

-----Original Message-----
From: Martin Thomson [mailto:[email-masked]] 
Sent: Saturday, August 03, 2013 6:05 AM
To: GEOPRIV WG; Brian Rosen
Cc: Roger Marshall
Subject: Re: [Geopriv] Progressing the draft draft-thomson-geopriv-confidence-03

> These two drafts promote the ability to report actual numeric values.  That's a good place to start.  Leaving the value(s) as implied or assumed just doesn't make for good engineering.

Roger makes a good point.  However, having spoken with Brian, I think that it is important to highlight the implications of expressing confidence, with an appropriate amount of discouragement.  This is really only for cases where it's difficult to get location with a high confidence.

I've done a little editing, though I don't know if this is actually going to make sense, since it was all done on the train, and I don't remember the entire journey because I was so tired, but here's what I'm proposing to add to the draft.

Now that I look at it, it's a lot of text, so it can probably be cut down, but I think that it conveys the right sentiment.

---

From: James Winterbottom <[email-masked]>
Date: Tue, 27 Aug 2013 06:44:15 +1000

I am happy to review the confidence draft.

Sent from my iPad

---

From: Laura Liess <[email-masked]>
Date: Tue, 27 Aug 2013 08:44:06 +0200

The same for me.

Thank you
Laura

2013/8/26 James Winterbottom <[email-masked]>

> > I think these are both obviously in scope of our charter, so if the
> authors want to rev them, we can do a consensus call for WG adoption and
> see what we get. It would be helpful to get a sense of who is willing to
> review these drafts if we do adopt them.
> >
> > Alissa
> >
> > CONFIDENTIALITY NOTICE: The information contained in this message may be
> privileged and/or confidential. If you are not the intended recipient, or
> responsible for delivering this message to the intended recipient, any
> review, forwarding, dissemination, distribution or copying of this
> communication or any attachment(s) is strictly prohibited. If you have
> received this message in error, please notify the sender immediately, and
> delete it and all attachments from your computer and network.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Aug 2013 10:44:47 -0700

> I think these are both obviously in scope of our charter, so if the authors want to rev them, we can do a consensus call for WG adoption and see what we get. It would be helpful to get a sense of w…

I'm certainly able to update these documents if the WG is happy to
proceed with them.

I've revived -uncertainty.  I'm having a little trouble with the tools
for -confidence, but I'll get that sorted out eventually.