Subject: [Geopriv] IETF 88 Minutes

From: Alissa Cooper <[email-masked]>
Date: Wed, 13 Nov 2013 16:15:32 -0800

=== Summary of action items ===

1. Confirm the room's consensus to adopt draft-thomson-geopriv-uncertainty and draft-thomson-geopriv-confidence as WG items.

2. Seek further discussion of draft-google-self-published-geofeeds on the list prior to call for adoption before IETF 89.

=== Raw notes from note-taker Jean Mahoney ===

IETF-88 geopriv

Session 2013-11-07 1730-1830: Regency A 

==============================================================          
5m Chair's intro & administrivia
Presentation: http://www.ietf.org/proceedings/88/slides/slides-88-geopriv-0.pptx

Alissa Cooper presented.

Jabber scribe: Nick Doty     
Jabber log: http://www.ietf.org/jabber/logs/geopriv/2013-11-08.html
Note taker: Jean Mahoney          
      
No changes to the agenda.

slide - Document Status

The working group hasn't met for a year.
Geolocation-Policy has been published - applause

==============================================================          
15m draft-thomson-geopriv-uncertainty (M. Thomson)
Presentation: http://www.ietf.org/proceedings/88/slides/slides-88-geopriv-1.pptx slides 1-11

Martin Thomson presented. 

slide - Civic addresses for identification

Brian Rosen - The terms by which we refer to uncertainty in civic addresses - you don't use the same terms or measure in the same way. We won't talk about them here.

Martin - ….

Marc Linsner - Are you proposing to delete section 3.2?

Martin - I want to make sure it's clear. And it's applicable to civic addresses. Not using to … Use of civic addresses to describe location of another thing. 

Marc - there's definition issues here. The use of uncertainty to civic locations. My problem is mixing it in the same doc. Let's write another doc.

Martin - it's such a small section.

Nick Doty - we might get to the right answer. You can have some interesting uncertainty with civic addresses. If people care about only point uncertainty in this doc … That means there are only certain use cases for civic addresses.

Alissa - Is there a … geo coding?

Martin - it's to highlight civic addresses in this way can be considered in same way as geodetic.

Brian - when you geo code, you go from geo address to civic address. There's info that you used, that's the only hook you've used. You can mention that there's uncertainty in a civic address. We don't measure it. They way we describe it is different. The text doesn't apply. Let's see the next revision. People can contribute text.

Nick - Example - if I give you a piece of data in pidf-lo, can I say this is a civic address with this uncertainty. Or do I really mean this person is from Oakland? 

Martin - l don't think we've written that down. I want to avoid proposed standard on this. 

slide - use of point + uncertainty

Brian - I don't care how this doc does this. I'll help. I'm ok with the proposal to do it in a separate doc that this doc will refer to. 

Brian - I think this is awesome work. I'm glad you're doing it.

==============================================================          
          15m draft-thomson-geopriv-confidence (M. Thomson)
Presentation: http://www.ietf.org/proceedings/88/slides/slides-88-geopriv-1.pptx, slides 12-17

Martin presented.

Brian - My problem with the combo of these 2 things. It's allowing something … don't want to recommend. In any given system of senders and receivers of info, the senders and receivers have to agree on the confidence. The sender does the conversion, not the receiver. Receivers ignore confidence. We need stronger text. In any given system, determine the level of confidence. If you have to scale, let the sender do it. Point at the upscale/downscale problem. I'd like to see that in the combo of the docs.

Martin - if you system has a requirement for 67% confidence, there is nothing wrong with sending 95%. Need to cover that.

Roger Marshall - I don't know if I understand your 67-95 comparison. 

Martin - if are are expecting 67%, the sender can give 95%. To brian - pick one - per industry, per value?

Brian - It's a system - a set of senders and receivers. Could you send with a higher confidence? Sure. Better if everyone in the system agrees on the confidence. 

Roger - Martin said early on - you can't always achieve what you pick. 911 has picked 95%, but they can't achieve it. There's an educational gap. I think the drafts are fabulous and help educate. Knowing what confidence is, is useful. The 911 industry doesn't understand confidence. Throwing away probability is ridiculous. 

Alissa - Show of hands - who has read these drafts, who wants to adopt? 

Room - People have read them. Large number of people not in the room have read them. 

Alissa - Who does not want to adopt? 

Room - silence

==============================================================          
10m draft-google-self-published-geofeeds (E. Kline)
Presentation:  

Eric Kline presented.         

slide - And now for some XML

Brian - You will get into a North America bias problem here. Country, State is A1, A2 is like county in the US. You will need that for non-high metro areas. A3 is city. If you need to go less than that - A4 - a ward or borough. Important for NYC. Postal codes are non-intersecting. Seriously consider copying A1-A4 from pidf, and that will work for a large percentage of the world. 

Alissa - Do you think operators maintain A4 data?

Brian - no, but if they wanted to come up with something that was not operator specific, they could. The areas they cover don't match borough or whatever. No one knows what the infrastructure is for service area.

Richard Barnes - let's not rat hole.

Martin - I don't think building is necessary. 

Kaveh ? - We support this work. 

slide - from here

Andy ??? - this is needed. People ask for this. Would be helpful to define a mime type specific to this. application/text-???

Michael ???  - This is a real problem. Would like to see default allocation. Have same prefix span whatever. You need to have multiple prefixes in multiple areas. 

Eric - hierarchies don't work in real life.

Martin - Yes

Alissa - figuring out privacy on this is not straightforward. Sounds like people are interested. Get discussion on the list. Sometime before london, do a call for adoption.

==============================================================          
10m Location services and surveillance (M. Thomson)
Presentation: http://www.ietf.org/proceedings/88/slides/slides-88-geopriv-2.pptx

Not presented due to time constraints.

---

From: James Winterbottom <[email-masked]>
Date: Thu, 14 Nov 2013 12:41:17 +1100

Hi Alissa,

I support the adoption of the confidence and uncertainty drafts as WG items.

I have not yet read the google contribution but I plan to shortly.

Cheers
James

Sent from my iPad

On 14/11/2013, at 11:15 AM, Alissa Cooper <[email-masked]> wrote:

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv