Subject: [Geopriv] draft-ietf-geopriv-uncertainty-00

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Thu, 17 Apr 2014 17:05:33 +0000

I’m still not comfortable with this draft and it’s representations of uncertainty wrt to civic locations.

The way I understand the document.

Uncertainty wrt to a measured location, expressed as 95% confidence, equates to a 5% chance the target is OUTSIDE the given polygon.

Uncertainty wrt to a civic location equates to the size of the target compared to the most precise element supplied.  There is ZERO CHANCE the target is outside the supplied elements.

IOW, the target is ALWAYS within the boundary described by the civic location, which is not the case with geolocation.

Yes, there is uncertainty as to where within the polygon the target is located, but this is the case with both geo and civic locations, but that’s precision issue, not uncertainty.

As stated before, there is enough difference between application of uncertainty between the two location types, that it will cause confusion of the reader of the draft.

I believe the conversation about civic uncertainty should be removed from the draft.

-Marc-

---

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Apr 2014 10:16:24 -0700

I see where this is coming from now.  I disagree with your conclusion.

On 17 April 2014 10:05, Marc Linsner (mlinsner) <[email-masked]> wrote:
> Uncertainty wrt to a measured location, expressed as 95% confidence,
> equates to a 5% chance the target is OUTSIDE the given polygon.

To be precise, it means that there is a *less than* 5% chance that the
target is somewhere else.

> There is ZERO CHANCE the target is outside the supplied elements.

There is *never* a zero chance that the information is wrong.  Because
that would require an infallible determination of the supplied
elements.  100% confidence is basically impossible [1].

Civic address information is still prone to provisioning errors.
You'd think that with systems like MSAG, the error rate would be much
lower than 5% and you are probably right.  Feel free to indicate
99.999% confidence.  Though I think that I'd want you to back that
claim with some fairly extensive testing.  But don't ever think that a
mistake can't happen.

Then there are the cases where the input information has been tweaked
to affect the outcome.  And the outright lies.

--Martin

[1] Which is one reason that climate science has such a hard time in
the court of popular opinion.

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Thu, 17 Apr 2014 17:33:27 +0000

I will guarantee 100% I am in the state of Florida, USA as I type this.
Zero uncertainty!

-Marc-

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Thu, 17 Apr 2014 17:46:07 +0000

But my real point is that uncertainty wrt civic locations is completely
different than uncertainty wrt measured/geolocation.  I believe that
difference is great enough that they two topics should not be discussed in
the same document.  The reader will think there is uncertainty wrt to the
boundaries for the various elements of the civic location.  And my point
is the boundaries of the civic elements are known and are 100% certain.

Now you are citing entry errors and lying as uncertainty, while those can
fit within the common understanding of uncertainty, that has not been
mentioned in this draft.

"Section 2  A General Definition of Uncertainty

Uncertainty results from the limitations of measurement.²

There are no realtime measurements associated with civic locations (in the
context of GeoPriv).

-Marc-

---

From: TGLASSEY <[email-masked]>
Date: Thu, 17 Apr 2014 10:52:14 -0700

Civic uncertainty is a use model Virtaualized location info has to be 
able to take this as part of a large virtual reporting framework.

Todd

On 4/17/2014 10:05 AM, Marc Linsner (mlinsner) wrote:
> I'm still not comfortable with this draft and it's representations of 
> uncertainty wrt to civic locations.
> Uncertainty wrt to a civic location equates to the size of the target 
> compared to the most precise element supplied. There is ZERO CHANCE 
> the target is outside the supplied elements.
> IOW, the target is ALWAYS within the boundary described by the civic 
> location, which is not the case with geolocation.
> Yes, there is uncertainty as to where within the polygon the target is 
> located, but this is the case with both geo and civic locations, but 
> that's precision issue, not uncertainty.
> As stated before, there is enough difference between application of 
> uncertainty between the two location types, that it will cause 
> confusion of the reader of the draft.
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

-- 
-------------

Personal Email - Disclaimers Apply

---

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Apr 2014 10:55:27 -0700

> I will guarantee 100% I am in the state of Florida, USA as I type this.

Your confidence is immaterial in this case.  It's my confidence as a
Location Recipient that is what is relevant.  In this case, I'd say
that there's a fair chance you are right, but not 100%.

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Thu, 17 Apr 2014 18:00:46 +0000

But I¹m the entity sending the PIDF-LO, hence I¹m the entity declaring the
uncertainty value.  You don¹t get a vote!

---

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Apr 2014 11:09:20 -0700

> uncertainty value.  You don¹t get a vote!

It doesn't work that way.  You don't get to validate your own claims.
If it worked that way, confidence would be 100%.

The only way you get that is if you include a fiat declaration that
your current location is X.  But that would require that X is a new
definition, not a widely accepted civic address.  e.g., I'm in Narnia.
 Where's that?  Where I am, of course.

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Thu, 17 Apr 2014 19:19:33 +0000

Huh?

So I tell you with 100% confidence in a PIDF-LO that my location 123 N.
Main St., Buffalo, NY, USA and you are saying I can’t possibly claim that?

Hmm, so where does my PIDF-LO get sent so the location gods can change my
claimed confidence level?

---

From: "Carl Reed" <[email-masked]>
Date: Thu, 17 Apr 2014 16:30:03 -0600

I grew up in Buffalo NY!

Anyway, perhaps the issue is that we are looking at two different mechanisms 
for specifying location. Traditional measures of confidence/uncertainty 
apply to coordinates and the measurement process used to obtain those 
coordinates. A civic address is an entirely different matter. I know my 
address (mail, IP, whatever). I understand the issue of coding errors, 
spoofing, hacking, etc. I am 100% certain and confident that my grandmother 
used to live at 33 Gates Circle Apt 6a, Buffalo New York. Now whether a 
database of addresses is 100% correct is a different question. I have never 
seen an address database that is 100% correct. I would guess that the US 
Postal Service, the local 911 call center, Google, Pitney Bowes all have 
measure of the level of confidence (uncertainty) they have in their address 
holdings. These are reflected in the certainty related to geocoding based on 
addresses. For example, check out 
http://www.mapquestapi.com/geocoding/geocodequality.html and 
http://support.pb.com/help/spectrum/9.0/webhelp/en/AddressingGuide/UNC/source/VAConfidenceAlgorithm/algorithm_for_international.html

I suppose the should focus on the problem we are trying to solve and then 
agree on the solution.

Cheers

Carl

-----Original Message----- 
From: Marc Linsner (mlinsner)
Sent: Thursday, April 17, 2014 1:19 PM
To: Martin Thomson
Cc: [email-masked]
Subject: Re: [Geopriv] draft-ietf-geopriv-uncertainty-00

Huh?

---

From: Ray Bellis <[email-masked]>
Date: Tue, 22 Apr 2014 08:44:03 +0000

On 17 Apr 2014, at 23:30, Carl Reed <[email-masked]> wrote:

> I grew up in Buffalo NY!
> 
> Anyway, perhaps the issue is that we are looking at two different mechanisms for specifying location. Traditional measures of confidence/uncertainty apply to coordinates and the measurement process used to obtain those coordinates. A civic address is an entirely different matter. I know my address (mail, IP, whatever). I understand the issue of coding errors, spoofing, hacking, etc. I am 100% certain and confident that my grandmother used to live at 33 Gates Circle Apt 6a, Buffalo New York.

It seems to me that this issue requires resolution before we proceed to WGLC.

I'm not convinced by Marc's argument that section 3.3 should be removed, though.

Martin, is there anything you can take from this thread that might help clarify the text?

Ray

---

From: Roger Marshall <[email-masked]>
Date: Tue, 22 Apr 2014 14:48:12 +0000

I agree with Marc that uncertainty as it applies to a civic (i.e., non-measured) location, should be removed from the draft.

Civic location is always, either provisioned (declared via manual input) or derived (reverse geocoded) from a geographic estimate.

Carl's point makes sense to me that a database of values might deserve some sort of quality rating, but it probably wouldn't be the same two terms (uncertainty & confidence) that we use for measured position estimates.

-roger.

-----Original Message-----
From: Geopriv [mailto:[email-masked]] On Behalf Of Ray Bellis
Sent: Tuesday, April 22, 2014 1:44 AM
To: GEOPRIV WG
Subject: Re: [Geopriv] draft-ietf-geopriv-uncertainty-00

Ray

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

---

From: James Winterbottom <[email-masked]>
Date: Wed, 23 Apr 2014 05:15:05 +1000

Hi Roger,

It is the reserve geocoded mechanism that concerns me in this discussion.
In order to reverse geocode you need to have a geolocation to begin with, that must have been measured and therefore will have uncertainty and confidence, and those values will be at least as bad in the provided civic result and probably worse as some error is likely to have been introduced. Indeed, if you use a point to do the reverse geocode then the confidence approach zero. So I think, if reverse geocode is used then we need to keep civic in the current document.

Cheers
James

---

From: "Carl Reed" <[email-masked]>
Date: Tue, 22 Apr 2014 15:05:58 -0600

There is a good discussion on reverse geocoding, including issues, here:

http://en.wikipedia.org/wiki/Reverse_geocoding

Cheers

Carl

-----Original Message----- 
From: James Winterbottom
Sent: Tuesday, April 22, 2014 1:15 PM
To: Roger Marshall
Cc: GEOPRIV WG
Subject: Re: [Geopriv] draft-ietf-geopriv-uncertainty-00

Hi Roger,

It is the reserve geocoded mechanism that concerns me in this discussion.
In order to reverse geocode you need to have a geolocation to begin with, 
that must have been measured and therefore will have uncertainty and 
confidence, and those values will be at least as bad in the provided civic 
result and probably worse as some error is likely to have been introduced. 
Indeed, if you use a point to do the reverse geocode then the confidence 
approach zero. So I think, if reverse geocode is used then we need to keep 
civic in the current document.

Cheers
James

On 23 Apr 2014, at 12:48 am, Roger Marshall <[email-masked]> 
wrote:

> I agree with Marc that uncertainty as it applies to a civic (i.e., 
> non-measured) location, should be removed from the draft.
>
> Civic location is always, either provisioned (declared via manual input) 
> or derived (reverse geocoded) from a geographic estimate.
>
> Carl's point makes sense to me that a database of values might deserve 
> some sort of quality rating, but it probably wouldn't be the same two 
> terms (uncertainty & confidence) that we use for measured position 
> estimates.
>
> -roger.
>
>> Anyway, perhaps the issue is that we are looking at two different 
>> mechanisms for specifying location. Traditional measures of 
>> confidence/uncertainty apply to coordinates and the measurement process 
>> used to obtain those coordinates. A civic address is an entirely 
>> different matter. I know my address (mail, IP, whatever). I understand 
>> the issue of coding errors, spoofing, hacking, etc. I am 100% certain and 
>> confident that my grandmother used to live at 33 Gates Circle Apt 6a, 
>> Buffalo New York.
>
> CONFIDENTIALITY NOTICE: The information contained in this message may be 
> privileged and/or confidential. If you are not the intended recipient, or 
> responsible for delivering this message to the intended recipient, any 
> review, forwarding, dissemination, distribution or copying of this 
> communication or any attachment(s) is strictly prohibited. If you have 
> received this message in error, please notify the sender immediately, and 
> delete it and all attachments from your computer and network.
>