Subject: [Geopriv] Proposal for uncertainty

From: Martin Thomson <[email-masked]>
Date: Fri, 23 May 2014 13:12:20 -0700

I spoke about the one remaining issue with -uncertainty yesterday with
Ray.  That conversation, along with Roger's comments regarding
automated location determination helped me realize what I think the
source of the disconnect here is.

Based on this, I've tentatively concluded that the difference between
civic and geodetic location is not what is at the core of the issue,
though it's probably true that the issue only manifests with civic
location information.  Primarily because of our better intuition
regarding civic addresses.

The core of the concern is that confidence - as a statistical measure
- doesn't really make any sort of sense for location information that
is a bald assertion, as opposed to locations that are generated by
some measurement process (and here I give a nod to Carl for pointing
out reverse geocoding as an example of a measurement process that ends
with civic location).  For example, the assertion "I am at home" is
verifiable and basically either correct or not, usually the former.

It's only when taken in a larger context that terms like "confidence"
even apply.  In particular, that means automated location
determination.

I've taken a stab at clarifying this in the draft.

I've also permitted 100% confidence in the schema.  At the same time,
I've retained the text describing this as impossible, but that text is
all in the context of the statistical work, so I hope that the
introductory material makes that clear enough.

The changes are here:
https://github.com/martinthomson/drafts/commit/c2207408af95de74d1f4bb7d790965d69d4b3045
A readable copy is here:
http://martinthomson.github.io/drafts/draft-ietf-geopriv-uncertainty.html

Happy as always to take suggestions.  I'd like to think that this
helps address Marc's concern without needing to cut Section 3.3
entirely.

---

From: Henning G Schulzrinne <[email-masked]>
Date: Fri, 23 May 2014 19:27:54 -0400

This is a reasonably-well known problem and seems similar to the "there is
a 30% chance that it rains today" - it either rains, or it doesn't. The
same can be said about a "home detection" algorithm that is based (for
example) on some inferences (e.g., time of day and last GPS coordinates).
In that context, it does make sense to say "there's an 80% chance that the
caller is at home", which really means "in 80% of cases with the same
amount of information, the person was indeed at home". It's relatively easy
to calculate the weather case (although there's the rumor that weather
forecasts over-predict rain since nobody complains if their BBQ does NOT
get rained out), but probably hard for our case, given the lack of
retrospective ground truth.

Henning

On Fri, May 23, 2014 at 4:12 PM, Martin Thomson <[email-masked]>wrote:

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>

---

From: Roger Marshall <[email-masked]>
Date: Sat, 24 May 2014 00:48:57 +0000

I would agree that getting everyone to agree on how they see probabilities used with civic addresses is a stretch.  Yet, the fact that the draft now allows for 100%, yet with cautionary language is a good thing to have.

All the other changes looks good to me.

Thanks Martin.

-roger marshall.

From: Henning G Schulzrinne [mailto:[email-masked]]
Sent: Friday, May 23, 2014 4:28 PM
To: Martin Thomson
Cc: GEOPRIV WG; Marc Linsner; Roger Marshall; Ray Bellis
Subject: Re: [Geopriv] Proposal for uncertainty

This is a reasonably-well known problem and seems similar to the "there is a 30% chance that it rains today" - it either rains, or it doesn't. The same can be said about a "home detection" algorithm that is based (for example) on some inferences (e.g., time of day and last GPS coordinates). In that context, it does make sense to say "there's an 80% chance that the caller is at home", which really means "in 80% of cases with the same amount of information, the person was indeed at home". It's relatively easy to calculate the weather case (although there's the rumor that weather forecasts over-predict rain since nobody complains if their BBQ does NOT get rained out), but probably hard for our case, given the lack of retrospective ground truth.

Henning

On Fri, May 23, 2014 at 4:12 PM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

The changes are here:

_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 27 May 2014 15:40:38 +0000

No mechanism to collect location, especially civic location, is error free.

There is a statistical probability a civic location supplied as “THE” location of some target is incorrect.
It might be a small probability, it may be hard to calculate what it is, but there is some probability.

With enough data, it IS possible to quantify the error.  I think we will be able to do that in environments like emergency calling.

So, I’d like to see some language addressing the issue.

Brian

On May 23, 2014, at 8:48 PM, Roger Marshall <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Martin.

-roger marshall.

Henning

The changes are here:

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 May 2014 11:00:09 -0700

That speaks to keeping Section 3.3.  I am, as always, happy to accept
text suggestions.

Henning is right to identify the analogy to weather predictions.  This
is basic metrology, which is mercifully easier to grok than
meteorology.

On 27 May 2014 08:40, Rosen, Brian <[email-masked]> wrote:
> With enough data, it IS possible to quantify the error.  I think we will be
> able to do that in environments like emergency calling.
>
> On May 23, 2014, at 8:48 PM, Roger Marshall <[email-masked]>
> wrote:
>
> I would agree that getting everyone to agree on how they see probabilities
> used with civic addresses is a stretch.  Yet, the fact that the draft now
> allows for 100%, yet with cautionary language is a good thing to have.
>
> This is a reasonably-well known problem and seems similar to the "there is a
> 30% chance that it rains today" - it either rains, or it doesn't. The same
> can be said about a "home detection" algorithm that is based (for example)
> on some inferences (e.g., time of day and last GPS coordinates). In that
> context, it does make sense to say "there's an 80% chance that the caller is
> at home", which really means "in 80% of cases with the same amount of
> information, the person was indeed at home". It's relatively easy to
> calculate the weather case (although there's the rumor that weather
> forecasts over-predict rain since nobody complains if their BBQ does NOT get
> rained out), but probably hard for our case, given the lack of retrospective
> ground truth.
>
> Henning
>
>
>
> CONFIDENTIALITY NOTICE: The information contained in this message may be
> privileged and/or confidential. If you are not the intended recipient, or
> responsible for delivering this message to the intended recipient, any
> review, forwarding, dissemination, distribution or copying of this
> communication or any attachment(s) is strictly prohibited. If you have
> received this message in error, please notify the sender immediately, and
> delete it and all attachments from your computer and network.
>

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Tue, 27 May 2014 20:54:03 +0000

Brian,

Please read the draft.

Section 2 of the draft is “A General Definition of Uncertainty” that discusses "uncertainty results from the limitations of measurement”.

If you want the draft to talk about errors in wire map databases and MSAGs that can cause uncertainty with civic locations, you’ll need to send lots of text.

-Marc-

From: <Rosen>, Brian <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 27, 2014 at 11:40 AM
To: Roger Marshall <[email-masked]<mailto:[email-masked]>>
Cc: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>, Martin Thomson <[email-masked]<mailto:[email-masked]>>, GEOPRIV WG <[email-masked]<mailto:[email-masked]>>, Marc Linsner <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Geopriv] Proposal for uncertainty

Brian

Thanks Martin.

-roger marshall.

Henning

The changes are here:

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 27 May 2014 20:56:36 +0000

Yes, I read the draft.

Yes, I understand what you are saying.

I’m not sure we need “lots” of text, but we need text.

I’ll have to suggest some if I want to get this idea in the draft.  I get that.

Brian

On May 27, 2014, at 4:54 PM, Marc Linsner (mlinsner) <[email-masked]<mailto:[email-masked]>> wrote:

Brian,

Please read the draft.

-Marc-

Brian

Thanks Martin.

-roger marshall.

Henning

The changes are here:

---

From: Ray Bellis <[email-masked]>
Date: Wed, 28 May 2014 08:12:25 +0000

> If you want the draft to talk about errors in wire map databases and MSAGs that can cause uncertainty with civic locations, you’ll need to send lots of text.

Marc,

Does the update that Martin sent to the list address your previous concerns with §3.3?

kind regards,

Ray

---

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Wed, 28 May 2014 13:04:30 +0000

Martin,

IMO, the draft still confuses the term uncertainty, and I believe it¹s due
to trying to cover both geo and civic locations in the same draft.

S2: You define uncertainty as the results of limitations of measurement.

S2.3: You state that accuracy is a qualitative concept, hence not part of
the quantitative uncertainty concept.

S3.3: You (re)define uncertainty as accuracy/precision wrt civic.

WRT measured location, uncertainty goes down and confidence goes up as the
size of the polygon gets bigger (less accurate).  According to S3.3 wrt to
civic the opposite is true.  Is that what you are trying to say?

-Marc-

-----Original Message-----
From: Martin Thomson <[email-masked]>
Date: Friday, May 23, 2014 at 4:12 PM
To: GEOPRIV WG <[email-masked]>, Marc Linsner <[email-masked]>,
Roger Marshall <[email-masked]>, Ray Bellis
<[email-masked]>
Subject: Proposal for uncertainty

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 May 2014 11:00:09 -0700

> S3.3: You (re)define uncertainty as accuracy/precision wrt civic.

The definition is consistent.  More elements means a smaller area of
intersection of those areas:

"The resulting spatial partition can be considered as a region of uncertainty. "

> civic the opposite is true.  Is that what you are trying to say?

If that's your interpretation of the text, then I'm at a loss as to
how to fix it.