Subject: [Geopriv] draft-ietf-geopriv-uncertainty

From: Julian Reschke <[email-masked]>
Date: Wed, 22 Oct 2014 12:49:46 +0200

Hi there.

I was asked to review the XML namespace registration, and I have  minor 
editorial comments.

<http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-8.1> 
defines the XML namespace

   "urn:ietf:params:xml:ns:geopriv:conf"

But that namespace name only occurs once more in the document (in the 
XML schema).

It *ought* to appear in 
<http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-4.1> 
(where the confidence element is described); alternatively, that section 
could refer to the schema.

Note that 
<http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-6.4> 
has the following example:

>      <pidf:presence
>          xmlns:pidf="urn:ietf:params:xml:ns:pidf"
>          xmlns:dm="urn:ietf:params:xml:ns:pidf:data-model"
>          xmlns:gp="urn:ietf:params:xml:ns:pidf:geopriv10"
>          xmlns:gs="http://www.opengis.net/pidflo/1.0"
>          xmlns:gml="http://www.opengis.net/gml"
>          xmlns:con="urn:ietf:params:xml:ns:pidf:geopriv:conf"
>          entity="pres:[email-masked]">
>        <dm:device id="sg89ab">
>          <pidf:status>
>            <gp:geopriv>
>              <gp:location-info>
>                <gs:Circle srsName="urn:ogc:def:crs:EPSG::4326">
>                  <gml:pos>42.5463 -73.2512</gml:pos>
>                  <gs:radius uom="urn:ogc:def:uom:EPSG::9001">
>                    850.24
>                  </gs:radius>
>                </gs:Circle>
>    <!-- c -->  <con:confidence pdf="normal">67</con:confidence>
>              </gp:location-info>
>              <gp:usage-rules/>
>            </gp:geopriv>
>          </pidf:status>
>          <dm:deviceID>mac:010203040506</dm:deviceID>
>        </dm:device>
>      </pidf:presence>

That example isn't XMLNS-wellformed, as the "con" namespace is undefined 
(and yes, that's why I couldn't find it when looking for uses of the 
newly defined namespace).

Best regards, Julian

---

From: Ray Bellis <[email-masked]>
Date: Wed, 22 Oct 2014 15:00:11 +0000

> On 22 Oct 2014, at 11:49, Julian Reschke <[email-masked]> wrote:
> 
> Hi there.
> 
> I was asked to review the XML namespace registration, and I have  minor editorial comments.
> 
> <http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-8.1> defines the XML namespace
> 
> But that namespace name only occurs once more in the document (in the XML schema).
> 
> It *ought* to appear in <http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-4.1> (where the confidence element is described); alternatively, that section could refer to the schema.
> 
> Note that <http://tools.ietf.org/html/draft-ietf-geopriv-uncertainty-03#section-6.4> has the following example:
> 
>>     <pidf:presence
> That example isn't XMLNS-wellformed, as the "con" namespace is undefined (and yes, that's why I couldn't find it when looking for uses of the newly defined namespace).

Julian,

I’m not an XMLNS guru, but isn’t the line at the top reading xmlns:con=“urn:ietf:params:xml:ns:pidf:geopriv:conf” creating “con” as an alias for that namespace?

kind regards,

Ray

---

From: Ray Bellis <[email-masked]>
Date: Wed, 22 Oct 2014 15:44:44 +0000

> On 22 Oct 2014, at 16:35, Julian Reschke <[email-masked]> wrote:
> 
> On 2014-10-22 17:00, Ray Bellis wrote:
>> 
>> Julian,
>> 
>> ...
> Good catch (so yes, it's XMLNS-wellformed after all), but that one maps "con" to
> 
>  urn:ietf:params:xml:ns:pidf:geopriv:conf
> 
> while the namespace being registered is:
> 
>   urn:ietf:params:xml:ns:geopriv:conf
> 
> So maybe it's just a typo in the namespace registration?

More likely in the example, I think, looking at other recent extensions to PIDF-LO which have used …:ns:geopriv:*

I’ll ensure that the author corrects either the registration or the example accordingly.

kind regards,

Ray

---

From: Julian Reschke <[email-masked]>
Date: Wed, 22 Oct 2014 17:35:14 +0200

> I’m not an XMLNS guru, but isn’t the line at the top reading xmlns:con=“urn:ietf:params:xml:ns:pidf:geopriv:conf” creating “con” as an alias for that namespace?

Good catch (so yes, it's XMLNS-wellformed after all), but that one maps 
"con" to

Best regards, Julian

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Oct 2014 11:23:37 -0700

Thanks for catching that.  6fc08dd fixes it.

On 22 October 2014 08:44, Ray Bellis <[email-masked]> wrote:
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv