Subject: [Geopriv] New indoor location - standards needed

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 25 Nov 2014 17:32:24 +0000

See

http://apps.fcc.gov/ecfs/document/view?id=60000986637

In particular, the need for standards is called out in two areas:

- for the National Emergency Address Database (NEAD)

- for delivery of barometric pressure information to obtain z-axis (altitude) information.

The FCC is not a party to the agreement. It seems at least plausible that existing GEOPRIV work, such as HELD, or RFC 7105, can be extended to meet those needs. I'd appreciate hearing opinions on technical options from the WG.

Henning

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Nov 2014 18:51:00 +0000

I certainly think HELD is appropriate for NEAD query (query with MAC, respond with address in PIDF-LO form), but the general problem is that creating a centralized database is difficult, and it’s much more likely to be highly distributed.  I think the IETF is the ideal venue for working on that problem.  I think the problem the NAED deals with is that the WiFi AP is not operated by the origination service provider, and that service provider doesn’t know which AP/WiFi network the MAC address is connected to.  So, what is needed is a way to connect the WiFi networks in a way where you can reasonably query only those networks that might reasonably have that MAC address.  I think that’s probably based on serving cell site.  The NAED would know which WiFi networks were inside the serving cell area, and it would query (all of) them to see which one has the MAC address, and thus the location (if nothing else, the location of the AP that is serving the MAC).  That’s a guess based on some existing work done by some geoprivers who might give us more information.

I think working on the barometric pressure thing would be fascinating, and I think we’re probably at least as qualified to do the work as anyone else.  Perhaps we could get the OGC to work on in with us.  I think of that as combining the existing elevation datasets with building floor height data to produce a floor number from the barometric data.  I’d guess some compensation from weather data would be needed.   Crowdsourcing might be interesting, but what would we use to actually get the right data (how does the source know/enter floor data?)  Hah - sound analysis on an elevator ride!  Listen for the dings and floor announcements.  Watching steps and pressure is probably a decent way to figure out what floor you are on if you walk up a stairway.

Brian

> On Nov 25, 2014, at 12:32 PM, Henning Schulzrinne <[email-masked]> wrote:
> 
> See
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: Henning G Schulzrinne <[email-masked]>
Date: Tue, 25 Nov 2014 14:44:17 -0500

For related work on the second topic, see

Finding 9-1-1 Callers in Tall Buildings
Wonsang Song, Jae Woo Lee, Byung Suk Lee, Henning Schulzrinne
https://mice.cs.columbia.edu/getTechreport.php?techreportID=1525&format=pdf&

*IEEE WoWMoM '14*. Sydney, Australia, June 2014.

and

Improving the Vertical Accuracy of Indoor Positioning for Emergency
Communication
https://mice.cs.columbia.edu/getTechreport.php?techreportID=1525&format=pdf&

For one evaluation of barometric sensing, see Appendix A in Wonsang's
thesis:

http://academiccommons.columbia.edu/catalog/ac:175653

Henning

On Tue, Nov 25, 2014 at 1:51 PM, Rosen, Brian <[email-masked]>
wrote:

>
>
> I think working on the barometric pressure thing would be fascinating, and
> I think we’re probably at least as qualified to do the work as anyone
> else.  Perhaps we could get the OGC to work on in with us.  I think of that
> as combining the existing elevation datasets with building floor height
> data to produce a floor number from the barometric data.  I’d guess some
> compensation from weather data would be needed.   Crowdsourcing might be
> interesting, but what would we use to actually get the right data (how does
> the source know/enter floor data?)  Hah - sound analysis on an elevator
> ride!  Listen for the dings and floor announcements.  Watching steps and
> pressure is probably a decent way to figure out what floor you are on if
> you walk up a stairway.
>
> Brian
>
>
> > The FCC is not a party to the agreement. It seems at least plausible
> that existing GEOPRIV work, such as HELD, or RFC 7105, can be extended to
> meet those needs. I'd appreciate hearing opinions on technical options from
> the WG.
> >
> > Henning
> >

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Nov 2014 20:23:37 +0000

Fascinating.

On Nov 25, 2014, at 2:44 PM, Henning G Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:

IEEE WoWMoM '14. Sydney, Australia, June 2014.

and

Improving the Vertical Accuracy of Indoor Positioning for Emergency Communication
https://mice.cs.columbia.edu/getTechreport.php?techreportID=1525&format=pdf&

For one evaluation of barometric sensing, see Appendix A in Wonsang's thesis:

Henning

On Tue, Nov 25, 2014 at 1:51 PM, Rosen, Brian <[email-masked]<mailto:[email-masked]>> wrote:

Brian

> On Nov 25, 2014, at 12:32 PM, Henning Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:
>
> See
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 26 Nov 2014 10:00:39 +0100

Le 25/11/2014 19:51, Rosen, Brian a écrit :
[...]
> I think working on the barometric pressure thing would be
> fascinating, and I think we’re probably at least as qualified to do
> the work as anyone else.  Perhaps we could get the OGC to work on in
> with us.  I think of that as combining the existing elevation
> datasets with building floor height data to produce a floor number
> from the barometric data.  I’d guess some compensation from weather
> data would be needed.

Certainly yes - compensation from weather data is needed, as a fixed 
reference pressure level at a given point does not exist - it varies 
with weather.

On another hand, with 'sealed' buildings the pressure is independent 
from weather _and_ altitude (pretty much as the pressure in a flying 
airplane says on-ground).  A connection to the HVAC should be made.

Af447 experience taught one should worry when pressure sensors are 
flawed by freeze.

Alex

>  Crowdsourcing might be interesting, but what
> would we use to actually get the right data (how does the source
> know/enter floor data?)  Hah - sound analysis on an elevator ride!
> Listen for the dings and floor announcements.  Watching steps and
> pressure is probably a decent way to figure out what floor you are on
> if you walk up a stairway.
>
> Brian
>
>
>> The FCC is not a party to the agreement. It seems at least
>> plausible that existing GEOPRIV work, such as HELD, or RFC 7105,
>> can be extended to meet those needs. I'd appreciate hearing
>> opinions on technical options from the WG.
>>
>> Henning
>>
>> _______________________________________________ Geopriv mailing
>> list [email-masked]
> _______________________________________________ Geopriv mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/geopriv
>