Subject: [Geopriv] Fwd: Forming and chartering a GeoJSON WG

From: Alissa Cooper <[email-masked]>
Date: Tue, 10 Feb 2015 13:45:36 -0800

Folks who may have thoughts about this should send them on the dispatch list ...

Begin forwarded message:

> From: Erik Wilde <[email-masked]>
> Subject: Re: Forming and chartering a GeoJSON WG
> Date: February 5, 2015 at 9:59:04 AM PST
> To: [email-masked]
> Cc: Richard Barnes <[email-masked]>, Sean Gillies <[email-masked]>, Alissa Cooper <[email-masked]>, Barry Leiba <[email-masked]>, Pete Resnick <[email-masked]>, [email-masked]
> 
> hello.
> 
> On 2015-02-03 16:40 , Richard Barnes wrote:
>> Sorry for the delay here.  It looks like the next step here is to send a
>> charter proposal to the DISPATCH mailing list, [email-masked]
> 
> we have had conversations about establishing an IETF WG for GeoJSON, which would be chartered with taking the current GeoJSON definition, and turning it into an IETF RFC. the next step in this process seems to be proposing a charter. please find the proposed charter in this email to [email-masked], and it also is available online here:
> 
> https://github.com/geojson/draft-geojson/blob/master/charter.md
> 
> ==============================================================
> 
> Proposed GeoJSON WG Charter
> 
> GeoJSON
> 
> GeoJSON is a geospatial data interchange format based on JavaScript Object Notation (JSON). It was published at http://geojson.org in 2008. It has succeeded in streamlining geographic information system standards and making them accessible to practitioners of modern web development. GeoJSON today plays an important role in many spatial databases, web APIs, and open data platforms.
> 
> This WG will work on a GeoJSON Format RFC that specifies the format more precisely and serves as a better guide for implementers. The work will start from an Internet-Draft written by the original authors. This I-D, draft-butler-geojson-04, substantially improves the format specification. The remaining tasks of the WG are:
> 
> * Further clarification of the GeoJSON format specification.
> * Addition of implementation advice based on lessons learned since 2008.
> * geoAddition of more explicit extension advice to the specification.
> 
> The addition of new features to the GeoJSON format is not within the scope of this WG. One possible exception to this (depending on WG consensus) is the adoption of JSON Text Sequences as an alternative way of serializing sets of GeoJSON objects.
> 
> ==============================================================
> 
> thanks a lot and kind regards,
> 
> dret.
> 
> -- 
> erik wilde | mailto:[email-masked]  -  tel:+1-510-2061079 |
>           | UC Berkeley  -  School of Information (ISchool) |
>           | http://dret.net/netdret http://twitter.com/dret |

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 12 Feb 2015 15:43:05 +0100

The abstract of this draft-butler-geojson-05 says:
> This document recommends a single coordinate reference system based
>    on WGS 84.  Other coordinate reference systems are not recommended.

I think the draft should be revised in this sense.

JSON/IP will reach a number of reference systems in wide use, 
non-WGS-84, which deserve direct use instead of through conversion.

Alex

Le 10/02/2015 22:45, Alissa Cooper a écrit :
>> *From: *Erik Wilde <[email-masked] <mailto:[email-masked]>>
>> *Subject: **Re: Forming and chartering a GeoJSON WG*
>> *Date: *February 5, 2015 at 9:59:04 AM PST
>> *To: [email-masked] <mailto:[email-masked]>
>> *Cc: *Richard Barnes <[email-masked] <mailto:[email-masked]>>, Sean Gillies
>> <[email-masked] <mailto:[email-masked]>>, Alissa
>> Cooper <[email-masked] <mailto:[email-masked]>>, Barry Leiba
>> <[email-masked] <mailto:[email-masked]>>, Pete
>> Resnick <[email-masked]
>> <mailto:[email-masked]>>, [email-masked]
>> <mailto:[email-masked]>
>>
>> hello.
>>
>>> <mailto:[email-masked]>
>>
>> we have had conversations about establishing an IETF WG for GeoJSON,
>> which would be chartered with taking the current GeoJSON definition,
>> and turning it into an IETF RFC. the next step in this process seems
>> to be proposing a charter. please find the proposed charter in this
>> email to [email-masked] <mailto:[email-masked]>, and it also is
>> available online here:
>>
>> GeoJSON is a geospatial data interchange format based on JavaScript
>> Object Notation (JSON). It was published at http://geojson.org in
>> 2008. It has succeeded in streamlining geographic information system
>> standards and making them accessible to practitioners of modern web
>> development. GeoJSON today plays an important role in many spatial
>> databases, web APIs, and open data platforms.
>>
>> This WG will work on a GeoJSON Format RFC that specifies the format
>> more precisely and serves as a better guide for implementers. The work
>> will start from an Internet-Draft written by the original authors.
>> This I-D, draft-butler-geojson-04, substantially improves the format
>> specification. The remaining tasks of the WG are:
>>
>> The addition of new features to the GeoJSON format is not within the
>> scope of this WG. One possible exception to this (depending on WG
>> consensus) is the adoption of JSON Text Sequences as an alternative
>> way of serializing sets of GeoJSON objects.
>>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 12 Feb 2015 13:36:26 -0800

Please send your comments to [email-masked].

On Feb 12, 2015, at 6:43 AM, Alexandru Petrescu <[email-masked]> wrote:

> JSON/IP will reach a number of reference systems in wide use, non-WGS-84, which deserve direct use instead of through conversion.
> 
> Alex
> 
>