Subject: Re: [GROW] FIB scaling through configuration

From: Paul Francis <[email-masked]>
Date: Tue, 10 Jun 2008 14:53:33 -0400

I plan to create an ID, but it'll be pretty last minute.

Thanks,

PF

> -----Original Message-----
> From: Peter Schoenmaker [mailto:[email-masked]] 
> Sent: Tuesday, June 10, 2008 1:19 PM
> To: Paul Francis
> Cc: [email-masked]
> Subject: Re: [GROW] FIB scaling through configuration
> 
> Paul,
> 
> We are interested in having you present your ideas at GROW.
> 
> I've been negligent in requesting a time slot for dublin.  If 
> would be great for you to create a ID and discuss it on this 
> list.  If we end up having a time slot in dublin, we can give 
> you time to present.
> 
> peter
> 
> 
> On May 28, 2008, at 12:36 AM, Paul Francis wrote:
> 
> >
> > Gang,
> >
> > As some of you may know, my students and I have been 
> working of a way 
> > to reduce DFZ FIB size in routers using a technique that 
> requires only 
> > modifications in router configuration...no software or protocol 
> > changes are
> > needed...and that can be independently deployed by 
> individual ISPs.   
> > The
> > approach is called Virtual Aggregation (VA), because 
> effectively what 
> > it does is create virtual (MPLS tunneled) networks around "virtual 
> > prefixes" (i.e.
> > the collection of destinations within a large, otherwise 
> > unaggregatable prefix like a /7).  VA has a trade-off of increasing 
> > path-length and load with shrinking the FIB, but the increase is 
> > negligible for even a 10x FIB reduction, which can extend 
> the lifetime 
> > of a router for years.
> >
> > I was giving a talk on this at the last RIPE, and Jari 
> Arkko suggested 
> > that I should see if GROW is interested in pursuing this.  
> (It doesn't 
> > appear appropriate for either RRG or IDR, in effect because those 
> > groups are looking at mechinisms that actually change routers.)
> >
> > The idea would be to have GROW flush out and improve the basic 
> > approach we have specified so far, with a goal of writing a best 
> > practices type RFC.
> >
> > Details of VA can be found in
> > http://www.cs.cornell.edu/people/francis/va-wp.pdf.  I'd be very 
> > willing to turn this into an I-D that could be discussed in Dublin.
> >
> > I need to point out that Cornell owns IPR on this.  Though Cornell 
> > hasn't released an official statement about it, at worst it 
> would be 
> > offered on fair and reasonable terms, and at best for free with no 
> > restrictions.
> >
> > Thanks,
> >
> > PF
> >
> > ps. We have an analogous piece of work that effectively 
> eliminates the 
> > FIB for L3-VPN entries, but that is probably a topic for a 
> different 
> > WG.
> >
> > _______________________________________________
> > GROW mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/grow
> 
> 
_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

---

From: Peter Schoenmaker <[email-masked]>
Date: Tue, 10 Jun 2008 10:19:16 -0700

Paul,

I've been negligent in requesting a time slot for dublin.  If would be  
great for you to create a ID and discuss it on this list.  If we end  
up having a time slot in dublin, we can give you time to present.

peter

On May 28, 2008, at 12:36 AM, Paul Francis wrote:

>
> Gang,
>
> As some of you may know, my students and I have been working of a  
> way to
> reduce DFZ FIB size in routers using a technique that requires only
> needed...and that can be independently deployed by individual ISPs.   
> The
> approach is called Virtual Aggregation (VA), because effectively  
> what it does
> is create virtual (MPLS tunneled) networks around "virtual  
> prefixes" (i.e.
> unaggregatable
> prefix like a /7).  VA has a trade-off of increasing path-length and  
> load
> with shrinking the FIB, but the increase is negligible for even a  
> 10x FIB
> reduction, which can extend the lifetime of a router for years.
>
> I was giving a talk on this at the last RIPE, and Jari Arkko  
> suggested that I
> should see if GROW is interested in pursuing this.  (It doesn't appear
> appropriate for either RRG or IDR, in effect because those groups  
> are looking
> at mechinisms that actually change routers.)
>
> approach we
> have specified so far, with a goal of writing a best practices type  
> RFC.
>
> willing to
> turn this into an I-D that could be discussed in Dublin.
>
> hasn't
> released an official statement about it, at worst it would be  
> offered on fair
> and reasonable terms, and at best for free with no restrictions.
>
> Thanks,
>
> PF
>
> ps. We have an analogous piece of work that effectively eliminates  
> the FIB
> for L3-VPN entries, but that is probably a topic for a different WG.
>