Subject: [GROW] Final feedback please - kirkham-private-ip-sp-cores

From: Anthony Kirkham <[email-masked]>
Date: Fri, 09 Sep 2011 14:27:39 +1000

All,

I have just posted a new draft. There has only been one minor modification.

Filename:	 draft-kirkham-private-ip-sp-cores
Revision:	 06
Title:		 Issues with Private IP Addressing in the Internet
Creation date:	 2011-09-09
WG ID:		 Individual Submission
Number of pages: 13

I believe this is ready for publication. Any advice on the next step 
would be appreciated.

Regards
Tony K

-- 

*Anthony Kirkham*
*Solution Architect

***World Wide Security
Service Practice
**
[email-masked] <mailto:[email-masked]>
Phone: *+61 (0)7 3238 8203*
Mobile: *+61 (0)401 890 494*

CISSP, CCIE# - 1378

**

Level 12, 300 Adelaide Street
Brisbane, Qld, 4000
Australia
Cisco home page <http://www.cisco.com/global/AU/>

---

From: "George, Wes" <[email-masked]>
Date: Fri, 30 Sep 2011 12:58:05 -0400

I might note that the more common term for what you're calling "stolen" address space is squat space, but that's a minor nit at best.

Also, I think it's important to make a distinction between setups where there are no global addresses on a given router at all  vs situations where the router has one or more loopbacks or other interfaces which are publicly routable, but the individual PTP interfaces are using 1918 space (or are configured with "unnumbered"). I think that this is equally uncommon within a tier-1 ISP, but some of the accompanying problems can be managed better with configuration tweaks to force the box to use a certain source address for "from us" packets. This also helps in situations where ISIS core hiding is being used, since if a traceroute is sourced from the wrong IP, the boxes on the path may not know the route back to it and the trace fails in similar fashion.
Your illustration of problems with traceroute would be one scenario that might benefit from this variant, assuming that the specific implementation in question can be configured to respond using a specific address as the source IP, rather than simply responding on whatever the ingress interface's IP address is.
You may want to discuss this in section 11.

Thanks,

Wes George

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anthony Kirkham
Sent: Friday, September 09, 2011 12:28 AM
To: [email-masked]; [email-masked]
Subject: [GROW] Final feedback please - kirkham-private-ip-sp-cores

All,

Revision:       06

Number of pages: 13
I believe this is ready for publication. Any advice on the next step would be appreciated.

Regards
Tony K
--

Anthony Kirkham
Solution Architect

World Wide Security
Service Practice

[email-masked]<mailto:[email-masked]>
Phone: +61 (0)7 3238 8203
Mobile: +61 (0)401 890 494

CISSP, CCIE# - 1378

Level 12, 300 Adelaide Street
Brisbane, Qld, 4000
Australia
Cisco home page<http://www.cisco.com/global/AU/>

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.