Subject: [GROW] I-D Action: draft-ietf-grow-ops-reqs-for-bgp-error-handling-04.txt

From: [email-masked]
Date: Wed, 06 Jun 2012 08:04:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Global Routing Operations Working Group of the IETF.

	Title           : Operational Requirements for Enhanced Error Handling Behaviour in BGP-4
	Author(s)       : Rob Shakir
	Filename        : draft-ietf-grow-ops-reqs-for-bgp-error-handling-04.txt
	Pages           : 29
	Date            : 2012-06-06

   BGP-4 is utilised as a key intra- and inter-Autonomous System routing
   protocol in modern IP networks.  The failure modes as defined by the
   original protocol standards are based on a number of assumptions
   around the impact of session failure.  Numerous incidents both in the
   global Internet routing table and within Service Provider networks
   have been caused by strict handling of a single invalid UPDATE
   message causing large-scale failures in one or more Autonomous
   Systems.

   This memo describes the current use of BGP-4 within Service Provider
   networks, and outlines a set of requirements for further work to
   enhance the mechanisms available to a BGP-4 implementation when
   erroneous data is detected.  Whilst this document does not provide
   specification of any standard, it is intended as an overview of a set
   of enhancements to BGP-4 to improve the protocol's robustness to suit
   its current deployment.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-04.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-grow-ops-reqs-for-bgp-error-handling/

---

From: Rob Shakir <[email-masked]>
Date: Wed, 6 Jun 2012 16:34:23 +0100

Hi GROW,

Following the discussion and comments on and off the list over the last few weeks, I have made some modifications to some of the discussion within this draft.

Particularly, the changes are:

- As per Wes George's suggestion (and Sue Hares' request), added a statement that future updates to the BGP specification should define the category of error, and expected error handling class within which errors in each attribute fall.

- Updated the discussion of scaling considerations for both automated response to semantic errors, and the behaviour during repeated critical errors, as per the discussion on the GROW list. I think that this captures the conclusions that were reached, but comments are welcome.

- Some minor changes to wording and bringing drafts referenced in the informational references in line with the current drafts (mainly in light of a number of these drafts being adopted as IDR working group items).

Chris, Peter - I would like to request that this version of the draft is submitted for WGLC as I think this addresses all the outstanding comments both from the Paris meeting, and that I have received via on- and off-list mail.

Many thanks in advance for any comments and/or LC initiation!

Kind regards,
r.

On 6 Jun 2012, at 16:04, [email-masked] wrote:

> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 11 Jun 2012 16:19:45 -0400

> Chris, Peter - I would like to request that this version of the draft is submitted for WGLC as I think this addresses all the outstanding comments both from the Paris meeting, and that I have recei…

sounds good to me... look for that in a moment.