Subject: Re: [GROW] MRT

From: Christopher Morrow <[email-masked]>
Date: Fri, 7 Dec 2012 12:52:51 -0500

On Thu, Nov 29, 2012 at 3:00 AM, Mattia Rossi
<[email-masked]> wrote:
> Am 28.11.2012 13:01, schrieb Arturo Servin:
>
>> Chris,
>>
>>         The problem that I had is that it pybgpdum requires dpkt and it
>> did not
>> support 4 byte ASN and you need a hack.
>>
>>         Not sure if that is was problem as well. If it were, let me know
>> and I
>> will try to remember what I did to make it work but I think this is the
>> place with the answer:
>>
>> http://caia.swin.edu.au/urp/bgp/tools.html
>>
> Yes, the 4 Byte AS patch is part of the MDFMT. I would have hoped that by
> now somebody would have included it in dpkt, but it seems it didn't happen.
> The patch includes support for TABLE_DUMP_V2 as well, which is also not in
> dpkt by default.
> Dpkt still has an issue with certain RIPE MRT dumps, as some of the BGP4MP
> messages in there contain more entries than a Python String can handle, and
> thus dpkt will crash. (Dpkt will try to read the whole BGP4MP message in one
> go into a Python String).
>

ah, ok... so this patch set does work (for me in some brief testing),
did it get submitted to jon or was somethign waiting on that for a
reason not obvious to me?

> Cheers,
>
> Mat
>
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Christopher Morrow <[email-masked]>
Date: Fri, 7 Dec 2012 12:53:17 -0500

> reason not obvious to me?

oh, unittests requests, yes....