Subject: Re: [GROW] [sidr] I-D Action: draft-ietf-sidr-bgpsec-threats-06.txt

From: Dave Mitchell <[email-masked]>
Date: Thu, 5 Sep 2013 16:06:28 -0700

Seems related to our draft on MITM attacks with BGPSEC lacking path
validation, but expands on other attack vectors.

https://datatracker.ietf.org/doc/draft-ietf-grow-simple-leak-attack-bgpsec-no-help/

Thanks.

-d

On Thu, Sep 5, 2013 at 3:36 PM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the Secure Inter-Domain Routing Working
> Group of the IETF.
>
>         Title           : Threat Model for BGP Path Security
>         Author(s)       : Stephen Kent
>                           Andrew Chi
>         Filename        : draft-ietf-sidr-bgpsec-threats-06.txt
>         Pages           : 19
>         Date            : 2013-09-05
>
> Abstract:
>    This document describes a threat model for the context in which
>    (E)BGP path security mechanisms will be developed.  The threat model
>    includes an analysis of the RPKI, and focuses on the ability of an AS
>    to verify the authenticity of the AS path info received in a BGP
>    update.  We use the term PATHSEC to refer to any BGP path security
>    technology that makes use of the RPKI.  PATHSEC will secure BGP
>    [RFC4271], consistent with the inter-AS security focus of the RPKI
>    [RFC6480].
>
>    The document characterizes classes of potential adversaries that are
>    considered to be threats, and examines classes of attacks that might
>    be launched against PATHSEC.  It does not revisit attacks against
>    unprotected BGP, as that topic has already been addressed in
>    [RFC4271].  It concludes with brief discussion of residual
>    vulnerabilities.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-sidr-bgpsec-threats
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-sidr-bgpsec-threats-06
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-sidr-bgpsec-threats-06
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Dave Mitchell <[email-masked]>
Date: Fri, 6 Sep 2013 11:25:46 -0700

That's exactly what I meant to say. :) Apologies. Been a long, long week. 

Being new to the IETF process, but not the industry, I have some confusion about GROW I-D's as they can sometimes be very similar or partially overlapping with IDR and SIDR drafts. Just trying to understand which WG's are responsible for what, how overlap is handled and where combining efforts makes the most sense. 

Thanks in advance.

Have a great weekend! 

-d

On Sep 6, 2013, at 11:14 AM, Stephen Kent <[email-masked]> wrote:

> Dave,
> 
> This is just a cleanup pass on this doc, to address IESG comments. The doc dates back to June, 2011.
> 
> So, perhaps you mean to say that your doc is related to his one :-).
> 
> Steve
>> Seems related to our draft on MITM attacks with BGPSEC lacking path validation, but expands on other attack vectors.
>>

---

From: Christopher Morrow <[email-masked]>
Date: Fri, 6 Sep 2013 22:54:23 -0400

On Fri, Sep 6, 2013 at 4:38 PM, Stephen Kent <[email-masked]> wrote:
> Dave,
>
> Fair questions for a somewhat complex environment.
>
> SIDR develops security standards for inter-domain routing, working within
> the context of
> BGP standards developed by IDR.
>
> GROW has more of an operations focus, and is intended to provide input to
> IDR.
>
> So, your doc on route leaks, if approved in GROW, could inform IDR about
> changes
> needed to BGP to counter this problem (which is not contrary to current BGP
> semantics). In turn, IDR could elect to revise BGP to address this problem,
> and
> then IDR could ask SIDR to develop security mechanisms to enable ASes to
> enforce the
> revised BGP specs, for example.

this does sound like the agreed upon plan ... yes.

---

From: Stephen Kent <[email-masked]>
Date: Fri, 06 Sep 2013 14:14:35 -0400

Dave,

This is just a cleanup pass on this doc, to address IESG comments. The 
doc dates back to June, 2011.

Steve

---

From: Stephen Kent <[email-masked]>
Date: Fri, 06 Sep 2013 16:38:22 -0400

Dave,

SIDR develops security standards for inter-domain routing, working 
within the context of
BGP standards developed by IDR.

GROW has more of an operations focus, and is intended to provide input 
to IDR.

semantics). In turn, IDR could elect to revise BGP to address this 
problem, and

Steve

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 9 Sep 2013 12:59:48 -0400

Chris:

Yes, this is the correct process.  You are welcome to discuss mechanism on
the IDR list.  Summarize the route leak context for people not reading both
lists. 

Sue 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Christopher Morrow
Sent: Friday, September 06, 2013 10:54 PM
To: Stephen Kent
Cc: [email-masked] [email-masked]; sidr
Subject: Re: [GROW] [sidr] I-D Action: draft-ietf-sidr-bgpsec-threats-06.txt

On Fri, Sep 6, 2013 at 4:38 PM, Stephen Kent <[email-masked]> wrote:
> within the context of BGP standards developed by IDR.
>
> So, your doc on route leaks, if approved in GROW, could inform IDR 
> about changes needed to BGP to counter this problem (which is not 
> contrary to current BGP semantics). In turn, IDR could elect to revise 
> BGP to address this problem, and then IDR could ask SIDR to develop 
> security mechanisms to enable ASes to enforce the revised BGP specs, 
> for example.

this does sound like the agreed upon plan ... yes.
_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

---

From: "Murphy, Sandra" <[email-masked]>
Date: Mon, 9 Sep 2013 17:31:27 +0000

There's even a chair consensus statement on route leaks and forward plan:

http://www.ietf.org/mail-archive/web/sidr/current/msg06014.html

--Sandy, speaking as wg co-chair
________________________________________
From: [email-masked] [[email-masked]] on behalf of Christopher Morrow [[email-masked]]
Sent: Friday, September 06, 2013 10:54 PM
To: Stephen Kent
Cc: [email-masked] [email-masked]; sidr
Subject: Re: [sidr] I-D Action: draft-ietf-sidr-bgpsec-threats-06.txt

---

From: Dave Mitchell <[email-masked]>
Date: Mon, 9 Sep 2013 14:41:08 -0700

Great, thanks all. Appreciate the clarification!

Lots of docs and history to wade through as a process n00b and I apologize
for any wasted cycles.

</thread>

-dave

On Mon, Sep 9, 2013 at 10:31 AM, Murphy, Sandra
<[email-masked]>wrote:

> From: [email-masked] [[email-masked]] on behalf of
> Christopher Morrow [[email-masked]]
> problem,