Subject: Re: [GROW] current state of BMP implementations?

From: Stephen Stuart <[email-masked]>
Date: Mon, 9 Dec 2013 12:32:57 -0800

If you can send me some output of your BMP implementation captured with
netcat (or equivalent), I'd be happy to work on making the receiver
implementation work against it (see https://code.google.com/p/bmpreceiver).

Thanks,
Stephen

On Tue, Nov 5, 2013 at 12:06 PM, Bertrand Duvivier (bduvivie) <
[email-masked]> wrote:

> Hi,
>
> FYI for Cisco,
>
> BMP development is completed for IOS-XE and IOS classic.
>
> Implementation is based on BMPv7
> FCS target Nov 2013 (few more weeks)
>
> One small deviation from the BMPv7 draft:
> We also added few extra BMP statistics: few TCP stats, the goal is to
> monitor/detect slow peers by monitoring TCP.
>
> Current BMP (cisco) stats and values are:
> 32767 : SRTT: the Smooth Round-Trip Timer is a measurement of the average
> time that it takes a packet to be sent and acknowledged by the remote peer.
> 32768 : RTTO: the round-trip timeout in milliseconds.
> 32769 : RTV: the variance of the round-trip time in milliseconds.
> 32770 :KRTT: the new round-trip (K stands for Karn's algorithm) timeout.
> It measures the round-trip time, in milliseconds, for packets that have
> been retransmitted.
> 32771 :minRTT: the smallest round-trip timeout.
> 32772 :maxRTT: the largest round-trip timeout.
> 32773 :ACK hold: the acknowledgment delay timeout used to delay
> acknowledgements to allow time to add data to the packet.
> 32774 :Datagrams: the largest data segment in bytes
>
> Working with author to standardize these stats, will update our
> implementation as soon as standardized.
>
> BRGDS Bertrand
> Cisco BGP product manager.
>
> From: Jeffrey Haas <[email-masked]>
> Subject: Re: [GROW] current state of BMP implementations?
> Date: November 5, 2013 8:07:36 PM GMT+01:00
> To: John Kemp <[email-masked]>
> Cc: [email-masked]
>
> On Tue, Nov 05, 2013 at 09:32:16AM -0800, John Kemp wrote:
>
> Can anyone summarize the current state
> of the Juniper or Quagga work on BMP?
>
> BMPv1 support has been available in JUNOS for a while now.
> BMPv3 support will be in 13.3.
>
> -- Jeff
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>

---

From: Thomas Mangin <[email-masked]>
Date: Tue, 10 Dec 2013 09:20:02 +0000

Feel free to CC me so I can make sure the capture(s) work with ExaBGP too when I upgrade BMP v7 :-)

Thank you,

Thomas

On 9 Dec 2013, at 20:32, Stephen Stuart <[email-masked]> wrote:

> If you can send me some output of your BMP implementation captured with netcat (or equivalent), I'd be happy to work on making the receiver implementation work against it (see https://code.google.com/p/bmpreceiver).
> 
> Thanks,
> Stephen
> 
> 
> On Tue, Nov 5, 2013 at 12:06 PM, Bertrand Duvivier (bduvivie) <[email-masked]> wrote:
> Hi,
> 
> FYI for Cisco,
> 
> We also added few extra BMP statistics: few TCP stats, the goal is to monitor/detect slow peers by monitoring TCP.
> 
> 32767 : SRTT: the Smooth Round-Trip Timer is a measurement of the average time that it takes a packet to be sent and acknowledged by the remote peer.
> 32770 :KRTT: the new round-trip (K stands for Karn's algorithm) timeout. It measures the round-trip time, in milliseconds, for packets that have been retransmitted.
> 32773 :ACK hold: the acknowledgment delay timeout used to delay acknowledgements to allow time to add data to the packet.
> Working with author to standardize these stats, will update our implementation as soon as standardized.
> 
> BRGDS Bertrand

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 10 Dec 2013 10:24:10 +0100

Do you have also plan to add MRT encap to ExaBGP ?

Thx,
r.

---

From: Thomas Mangin <[email-masked]>
Date: Tue, 10 Dec 2013 09:35:00 +0000

Hello Robert,

Some people have asked for it ... I have been quite busy recently so it did not make it to the top of the list.

At the moment, BMP is processed by a separate application but I intend to change this when I implement v7. Like everyone my issue is that I need more hours in my days :-)
This year, I updated ExaBGP's code to be able to pass raw packets to the backend process (and not only a text or JSON representation) so serialising them on disk using the MTR container format should not be to hard to add. 

If many people are saying that they would use it, then I will bump the feature up the list.

Thomas

On 10 Dec 2013, at 09:24, Robert Raszuk <[email-masked]> wrote:

> On Tue, Dec 10, 2013 at 10:20 AM, Thomas Mangin <[email-masked]> wrote: