Subject: Re: [GROW] current state of BMP implementations?

From: Stephen Stuart <[email-masked]>
Date: Tue, 3 Jun 2014 09:55:16 -0700

Bertrand Duvivier was kind enough to refer me to someone at Cisco who
provided some BMP V3 sample data, so the monitoring station code at
https://code.google.com/p/bmpreceiver/ has been updated to understand BMP
V3 as spoken by a Cisco (thanks, Bertrand!). I'm happy to take patches to
fix assertions or expand the printing of BGP message content (especially
multi-protocol NLRI information), and it's always nice to get new files of
sample data.

Stephen

On Tue, Nov 5, 2013 at 3:34 PM, Stephen Stuart <[email-masked]> wrote:

> https://code.google.com/p/bmpreceiver/
>
> Tested against the JUNOS draft -01 sender implementation.
>
> Stephen
>
>
> On Tue, Nov 5, 2013 at 2:21 PM, John Kemp <
> [email-masked]> wrote:
>
>> On 11/5/13 11:07 AM, Jeffrey Haas wrote:
>> > On Tue, Nov 05, 2013 at 09:32:16AM -0800, John Kemp wrote:
>> >> Can anyone summarize the current state
>> >> of the Juniper or Quagga work on BMP?
>> > BMPv1 support has been available in JUNOS for a while now.
>> > BMPv3 support will be in 13.3.
>> >
>> > -- Jeff
>>
>> Anyone publish any client station code?
>>
>> John Kemp
>>
>> _______________________________________________
>> GROW mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/grow
>>
>
>

---

From: Thomas Mangin <[email-masked]>
Date: Tue, 3 Jun 2014 18:15:17 +0100

Hi Stephen,

This is great news. Thank you for this work,

Thomas

On 3 Jun 2014, at 17:55, Stephen Stuart <[email-masked]> wrote:

> Bertrand Duvivier was kind enough to refer me to someone at Cisco who provided some BMP V3 sample data, so the monitoring station code at https://code.google.com/p/bmpreceiver/ has been updated to understand BMP V3 as spoken by a Cisco (thanks, Bertrand!). I'm happy to take patches to fix assertions or expand the printing of BGP message content (especially multi-protocol NLRI information), and it's always nice to get new files of sample data.
> 
> Stephen
> 
> 
> On Tue, Nov 5, 2013 at 2:21 PM, John Kemp <[email-masked]> wrote: