Subject: [GROW] FW: New Version Notification for draft-sriram-route-leak-protection-00

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Sat, 5 Jul 2014 22:40:49 +0000

This is a -00 individual draft contribution. 
I will consult with GROW and SIDR chairs regarding a 
possible presentation of this work in Toronto.
Your comments, suggestions requested. 

Sriram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 04, 2014 7:17 PM
To: Sriram, Kotikalapudi; Montgomery, Douglas; Montgomery, Douglas; Sriram, Kotikalapudi
Subject: New Version Notification for draft-sriram-route-leak-protection-00.txt

A new version of I-D, draft-sriram-route-leak-protection-00.txt
has been successfully submitted by Kotikalapudi Sriram and posted to the IETF repository.

Name:		draft-sriram-route-leak-protection
Revision:	00
Title:		Enhancement to BGPSEC for Protection against Route Leaks
Document date:	2014-07-04
Group:		Individual Submission
Pages:		11
URL:            http://www.ietf.org/internet-drafts/draft-sriram-route-leak-protection-00.txt
Status:         https://datatracker.ietf.org/doc/draft-sriram-route-leak-protection/
Htmlized:       http://tools.ietf.org/html/draft-sriram-route-leak-protection-00

Abstract:
   This document enumerates different types of route leaks based on
   observed events on the Internet.  It illustrates how BGPSEC in its
   current form (as described in draft-ietf-sidr-bgpsec-protocol-09)
   already provides protection against all but one of these route-leaks
   scenarios.  The document further discusses a design enhancement to
   the BGPSEC protocol that will extend protection against this one
   remaining type of route-leak attack as well.  With the inclusion of
   this enhancement, BGPSEC is expected to provide protection against
   all types of route-leaks.  The document also includes a stopgap
   method for detection and mitigation of route leaks for the phase when
   BGPSEC (path validation) is not yet deployed but only origin
   validation is deployed.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Danny McPherson <[email-masked]>
Date: Thu, 17 Jul 2014 05:58:52 -0600

Sriram,
I support this draft and think spitting it and possibley merging part 
of it with the bgpsec-no-help draft might be useful.

GROW would seem the right place for at least half, methinks.

-danny

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Thu, 17 Jul 2014 12:53:08 +0000

>Sriram,
>I support this draft and think spitting it and possibley merging part of it with the bgpsec-no-help draft might be useful.

Thank you, Danny.
Chris Morrow also offered a similar suggestion to authors.
I think splitting it into two drafts, perhaps something along the lines of -
1.  route-leaks-problem-definition
2.  route-leaks-detection
would make sense. We can merge bgpsec-no-help into the first one.

Sriram

On 2014-07-05 16:40, Sriram, Kotikalapudi wrote:
> I will consult with GROW and SIDR chairs regarding a possible 
> presentation of this work in Toronto.

---

From: "Osterweil, Eric" <[email-masked]>
Date: Thu, 17 Jul 2014 15:02:19 +0000

+1

On Jul 17, 2014, at 7:58 AM, Danny McPherson <[email-masked]> wrote:

> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 18 Jul 2014 13:14:05 -0400

+1