Subject: [GROW] BMP server implementation

From: Shishio Tsuchiya <[email-masked]>
Date: Thu, 07 Aug 2014 16:35:13 +0900

F.Y.I
Ishida-san who is NTT R&D announced Ryu has implemented BMPv3 on JANOG ml .

https://github.com/osrg/ryu

It supports BMPv3 and we confirmed interoperability with Cisco ASR1000 and Juniper MX960.

Regards,
-Shishio

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 7 Aug 2014 11:03:43 +0200

Hello Shishio,

Sorry to ask the messenger, but what Ryu has to do with BMP ? Or for
that matter OpenFlow or OpenStack ? Enhancing Ryu with BMP is like
attaching a flower to the elephant :).

Is Ryu suffering from such lack of popularity that bad so it is now
trying to enter BGP protocol monitoring space with its overhead ? What
value add Ryu provides to BMP processing or for that matter any
routing protocols ?

BMP server and parser is just tiny user space code. The best is to
keep it standalone as far as possible from such "frameworks".

You may find an example of an open source BMP receiver code from Stephen here:

https://code.google.com/p/bmpreceiver/source/browse/#svn%2Ftags%2Frelease-1.1

Best regards,
R.

On Thu, Aug 7, 2014 at 9:35 AM, Shishio Tsuchiya <[email-masked]> wrote:
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Thomas Mangin <[email-masked]>
Date: Thu, 7 Aug 2014 11:53:31 +0200

Robert,

You are perfectly entitled to this opinion - however but demoralising Shishio I fail to see what your post achieves ...

I welcome any new implementation of any RFC defined standard. I may not have a use for ruy's but giving others the option can not be a bad thing.

Sincerely,

Thomas 
---
from my iPhone

> On 7 Aug 2014, at 11:03, Robert Raszuk <[email-masked]> wrote:
> 
> Hello Shishio,
>

---

From: Shishio Tsuchiya <[email-masked]>
Date: Thu, 07 Aug 2014 19:10:27 +0900

Robert
Thanks comment.
Yes, I'm just messenger.:P
But according to Ishida-san ,Ryu is collections of a lot of modules.
Actually it works by one python module.

run ./ryu-master/ryu/app/bmpstation.py
loading app ./ryu-master/ryu/app/bmpstation.py
instantiating app ./ryu-master/ryu/app/bmpstation.py of BMPStation

I agree your comment.
If bmpstation.py could be published on standalone,then it would be more flexible for operators.

Regards,
-Shishio

(2014/08/07 18:03), Robert Raszuk wrote:
> .

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 7 Aug 2014 12:19:41 +0200

Thank you Shishio-san.

If you have any further details regarding standalone bmp server
description, demo and hooks to external linux env I would highly welcome to
see it.

Running it with Ryu or as an integral part of Ryu is not interesting to me.

Best,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 7 Aug 2014 12:22:48 +0200

Thomas,

I did not demoralize anyone.

I simply question how bmp fits Ryu. If you would know what Ryu is perhaps
typu would share similar doubts.

Thx,
R.
On Aug 7, 2014 11:53 AM, "Thomas Mangin" <[email-masked]>
wrote:

> Robert,
>
> You are perfectly entitled to this opinion - however but demoralising
> Shishio I fail to see what your post achieves ...
>
> I welcome any new implementation of any RFC defined standard. I may not
> have a use for ruy's but giving others the option can not be a bad thing.
>
> Sincerely,
>
> Thomas
> ---
> from my iPhone
>

---

From: Thomas Mangin <[email-masked]>
Date: Thu, 7 Aug 2014 12:58:00 +0200

Hello Robert,

I follow Ryu in relation with openstack  where it seems there is now several effort to use BGP for service IP announcement and migration.

With decentralised announcements having a way to check that expected announcement correctly propagated make sense. 

I have indeed not looked at its openflow side and may well have read more to your post than was.

Thomas
---
from my iPhone

> On 7 Aug 2014, at 12:22, Robert Raszuk <[email-masked]> wrote:
> 
> Thomas,
> 
> I simply question how bmp fits Ryu. If you would know what Ryu is perhaps typu would share similar doubts.
> 
> Thx,
> R.
> 
>> On Aug 7, 2014 11:53 AM, "Thomas Mangin" <[email-masked]> wrote:
>> Robert,
>>