Subject: [GROW] I-D Action: draft-ietf-grow-bmp-08.txt

From: [email-masked]
Date: Fri, 22 May 2015 10:01:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Global Routing Operations Working Group of the IETF.

        Title           : BGP Monitoring Protocol
        Authors         : John Scudder
                          Rex Fernando
                          Stephen Stuart
	Filename        : draft-ietf-grow-bmp-08.txt
	Pages           : 25
	Date            : 2015-05-22

Abstract:
   This document defines a protocol, BMP, which can be used to monitor
   BGP sessions.  BMP is intended to provide a more convenient interface
   for obtaining route views for research purpose than the screen-
   scraping approach in common use today.  The design goals are to keep
   BMP simple, useful, easily implemented, and minimally service-
   affecting.  BMP is not suitable for use as a routing protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-grow-bmp/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-grow-bmp-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-grow-bmp-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 22 May 2015 13:28:33 -0400

Hi Everybody,

You'll see I've submitted the long-promised 08 draft of BMP. This is a fairly big revision, so I recommend looking at it with rfcdiff, but here are the highlights:

- Adds a "route mirroring" mode. This in fact is what the 00 individual submission specified to begin with. I had long ago backed it out thinking it not valuable, but others seem to disagree.
- Add an option to use the old-school AS Path instead of the four byte format. Adds a peer flag for that purpose.
- Some verbiage about locally-sourced routes and how to export them.
- Allow a string to be sent with the peer up message. Factored out the definition of the string TLV so I could reuse it here.
- A bunch more statistics types.
- A code to distinguish a peer that's just been bounced from one that's been deconfigured. Likewise, a code to distinguish bouncing of the BMP session versus deconfiguring it.

If you requested a change that doesn't appear here, now would be a good time to remind me (and the working group) about it.

At this point I think we finally have sufficient multivendor implementation experience of both the router and collector sides of the protocol for us to consider moving it forward, although I'm not completely satisfied with the organization of the document. I'd be interested in the opinions of fresh readers – is the organization okay, or should I do one more editing pass before calling it done? Keep in mind that "one more editing pass" can sometimes take longer than desired, so if people think it's "good enough" maybe we should just skip the polishing phase.

Thanks,

– John