Subject: [GROW] A question to draft-ietf-grow-bmp-17

From: Zhuangshunwan <[email-masked]>
Date: Thu, 31 Mar 2016 07:34:37 +0000

Hi all,
I have a minor question to draft-ietf-grow-bmp-17.
Please help me to understand correctly, thanks.

In draft-ietf-grow-bmp-17, Route Monitoring message was documented as follows:
4.6.  Route Monitoring

   Route Monitoring messages are used for initial synchronization of
   ADJ-RIBs-In.  They are also used for ongoing monitoring of ADJ-RIB-In
   state.  Route monitoring messages are state-compressed.  This is all
   discussed in more detail in Section 5.

   Following the common BMP header and per-peer header is a BGP Update
   PDU.

My question:
How to understand "Following the common BMP header and per-peer header is a BGP Update PDU." ?
Does it mean that "only" one BGP Update PDU can be encapsulated after a per-peer header?
When multiple BGP Update PDUs share the same per-peer header, can it support "1 per-peer header + multiple BGP Update PDUs" ?

Thanks,
Shunwan

---

From: Ebben Aries <[email-masked]>
Date: Thu, 31 Mar 2016 16:25:32 -0600

> Does it mean that "only" one BGP Update PDU can be encapsulated after a

Yes

> When multiple BGP Update PDUs share the same per-peer header, can it
> support "1 per-peer header + multiple BGP Update PDUs" ?
> 

No - each UPDATE msg is encapsulated in a separate Route Monitoring msg.
 The text could probably be adjusted to spell this out better.

Is your concern the overhead introduced by replicated common/per-peer
headers should processing be common across multiple UPDATE msg (down to
the timestamp)?

>  
> 
>  
> 
> Thanks,
> 
> Shunwan
> 
> 
> 
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>