Subject: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

From: Christopher Morrow <[email-masked]>
Date: Sun, 5 Mar 2017 16:30:00 -0500

Howdy WG folks,
This request starts the WGLC for:
  <https://datatracker.ietf.org/doc/draft-ietf-grow-bgp-reject/>

with abstract:
  "This document defines the default behavior of a BGP speaker when
   there is no import or export policy associated with an External BGP
   session."

please have a read-through, decide if this needs more work and then speak
up on list.
thanks!
-chris
co-chair-personage.

---

From: Gert Doering <[email-masked]>
Date: Mon, 6 Mar 2017 20:21:14 +0100

Hi,

> please have a read-through, decide if this needs more work and then speak

Still supporting it.  Go for it.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444           USt-IdNr.: DE813185279

---

From: "Smith, Donald" <[email-masked]>
Date: Mon, 6 Mar 2017 20:27:04 +0000

I too support.

if (initial_ttl!=255) then (rfc5082_compliant==0)
[email-masked]<mailto:[email-masked]>
________________________________
From: GROW [[email-masked]] on behalf of Gert Doering [[email-masked]]
Sent: Monday, March 06, 2017 12:21 PM
To: Christopher Morrow
Cc: [email-masked]; [email-masked] [email-masked]; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

Hi,

Gert Doering
        -- NetMaster

_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Mon, 6 Mar 2017 20:35:57 +0000

+1 
I support.

Sriram

________________________________________
From: GROW <[email-masked]> on behalf of Smith, Donald <[email-masked]>
Sent: Monday, March 6, 2017 3:27 PM
To: Gert Doering; Christopher Morrow
Cc: [email-masked]; [email-masked] [email-masked]; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

I too support.

Hi,

Gert Doering
        -- NetMaster

---

From: Guillermo Cicileo <[email-masked]>
Date: Mon, 6 Mar 2017 18:03:49 -0300

Support.

Saludos,

      Guillermo.

On Mon, Mar 6, 2017 at 5:35 PM, Sriram, Kotikalapudi (Fed) <
[email-masked]> wrote:

> This communication is the property of CenturyLink and may contain
> confidential or privileged information. Unauthorized use of this
> communication is strictly prohibited and may be unlawful. If you have
> received this communication in error, please immediately notify the sender
> by reply e-mail and destroy all copies of the communication and any
> attachments.
>

---

From: Christopher Morrow <[email-masked]>
Date: Sun, 19 Mar 2017 21:47:30 -0400

Howdy folks!
There were 3 people, 4 if you include me, that had something to say here...

it'd be nice if a few more folk had read through and agreed/disagreed :)

I'll delay decision making until Tues (3/21/2017)... read and respond pls :)
-chris

---

From: Jared Mauch <[email-masked]>
Date: Mon, 20 Mar 2017 07:20:45 -0400

> I'll delay decision making until Tues (3/21/2017)... read and respond pls :)

	I have read this and support it :-)

	- Jared

-- 
Jared Mauch  | pgp key available via finger from [email-masked]
clue++;      | http://puck.nether.net/~jared/  My statements are only mine.

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 20 Mar 2017 11:24:23 +0000

> it'd be nice if a few more folk had read through and agreed/disagreed :)

violent support for this.

This is something that should have been in bgp on day one, and its
omission has caused and continues to cause a tremendous amount of damage
on the internet.

Nick

---

From: "Dickinson, Ian" <[email-masked]>
Date: Mon, 20 Mar 2017 11:36:25 +0000

Concur. This is a sane default that would have avoid many leaks over the years, so I support this.

Ian

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of Nick Hilliard
Sent: 20 March 2017 11:24
To: Christopher Morrow <[email-masked]>
Cc: [email-masked]; [email-masked] [email-masked] <[email-masked]>; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

Nick

Information in this email including any attachments may be privileged, confidential and is intended exclusively for the addressee. The views expressed may not be official policy, but the personal views of the originator. If you have received it in error, please notify the sender by return e-mail and delete it from your system. You should not reproduce, distribute, store, retransmit, use or disclose its contents to anyone. Please note we reserve the right to monitor all e-mail communication through our internal and external networks. SKY and the SKY marks are trademarks of Sky plc and Sky International AG and are used under licence.
Sky UK Limited (Registration No. 2906991), Sky-In-Home Service Limited (Registration No. 2067075) and Sky Subscribers Services Limited (Registration No. 2340150) are direct or indirect subsidiaries of Sky plc (Registration No. 2247735). All of the companies mentioned in this paragraph are incorporated in England and Wales and share the same registered office at Grant Way, Isleworth, Middlesex TW7 5QD.

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Mar 2017 07:36:22 -0400

Grow folks: 

Section 2 aligns with the intent of RFC4271.   I feel this concise draft address appropriate security considerations. I believe this drafts is ready from a technical viewpoint for publication.  

I am not an operator of a network, so I cannot comment on operator issues. 

Sue 

From: GROW [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Sunday, March 19, 2017 9:48 PM
To: [email-masked] [email-masked]; [email-masked]; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

Howdy folks!

-chris

On Sun, Mar 5, 2017 at 4:30 PM, Christopher Morrow <[email-masked]> wrote:

Howdy WG folks,

with abstract:

   session."

please have a read-through, decide if this needs more work and then speak up on list.

thanks!

-chris

co-chair-personage.

---

From: "Smith, Donald" <[email-masked]>
Date: Mon, 20 Mar 2017 13:47:56 +0000

Support, the basic concept that if I am not configured to speak to you, I don't listen, nor announce to you, is sound and should be the default behavior.

if (initial_ttl!=255) then (rfc5082_compliant==0)
[email-masked]<mailto:[email-masked]>
________________________________
From: GROW [[email-masked]] on behalf of Susan Hares [[email-masked]]
Sent: Monday, March 20, 2017 5:36 AM
To: 'Christopher Morrow'; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

Grow folks:

Sue

Howdy folks!

On Sun, Mar 5, 2017 at 4:30 PM, Christopher Morrow <[email-masked]<mailto:[email-masked]>> wrote:
Howdy WG folks,
This request starts the WGLC for:
  <https://datatracker.ietf.org/doc/draft-ietf-grow-bgp-reject/>

with abstract:

---

From: Ignas Bagdonas <[email-masked]>
Date: Mon, 20 Mar 2017 14:06:13 +0000

Fully support. Speaking as an operator, this is the right thing to do, 
and it has been deployed as a standard practice either natively if 
implementations do support this now or as an initial policy 
preconfiguration if it is not yet supported.

A small nit on the clarity of the applicability to al address families - 
the way how it is worded now seems to assume global and VPN address 
families only. What about explicitly requiring all address families 
active on the session to be affected by this?

OLD:
    This specification intends to improve this situation by requiring the
    explicit configuration of a BGP import and export policy for any
    External BGP (EBGP) session such as customers, peers, or
    confederation boundaries in a base router or VPN instances.

NEW:
    This specification intends to improve this situation by requiring the
    explicit configuration of a BGP import and export policy for any
    External BGP (EBGP) session such as customers, peers, or
    confederation boundaries for all enabled address families.

Ignas

On 20/03/2017 01:47, Christopher Morrow wrote:
> On Sun, Mar 5, 2017 at 4:30 PM, Christopher Morrow 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     Howdy WG folks,
>       <https://datatracker.ietf.org/doc/draft-ietf-grow-bgp-reject/
>     <https://datatracker.ietf.org/doc/draft-ietf-grow-bgp-reject/>>
>
>     with abstract:

---

From: Job Snijders <[email-masked]>
Date: Mon, 20 Mar 2017 15:43:12 +0100

On Mon, Mar 20, 2017 at 02:06:13PM +0000, Ignas Bagdonas wrote:
> Fully support. Speaking as an operator, this is the right thing to do, and
> it has been deployed as a standard practice either natively if
> implementations do support this now or as an initial policy preconfiguration
> if it is not yet supported.
> 
> A small nit on the clarity of the applicability to al address families - the
> way how it is worded now seems to assume global and VPN address families
> only. What about explicitly requiring all address families active on the
> session to be affected by this?
> 
> OLD:

I'd like to incorporate your suggestion, I agree it adds clarity.

Kind regards,

Job

---

From: Ben Maddison <[email-masked]>
Date: Mon, 20 Mar 2017 14:49:27 +0000

Fully support this. It adds a much needed sanity check to the behavior of BGP in the wild.

Cheers,

Ben Maddison

Director
Workonline Communications (Pty) Ltd

Office:     +27 (0) 21 200 9000
Mobile:   +27 (0) 82 415 5545
Email:      [email-masked]
SIP:          [email-masked]

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of Dickinson, Ian
Sent: Monday, March 20, 2017 1:36 PM
To: [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

Ian

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of Nick Hilliard
Sent: 20 March 2017 11:24
To: Christopher Morrow <[email-masked]>
Cc: [email-masked]; [email-masked] [email-masked] <[email-masked]>; [email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar 19)

This is something that should have been in bgp on day one, and its omission has caused and continues to cause a tremendous amount of damage on the internet.

Nick

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Mar 2017 10:46:54 -0400

+1 to change - good catch by Ignas. 

Sue 

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of Job Snijders
Sent: Monday, March 20, 2017 10:43 AM
To: Ignas Bagdonas
Cc: [email-masked]; [email-masked] [email-masked];
[email-masked]
Subject: Re: [GROW] WGLC draft-ietf-grow-bgp-reject - ends 3/19/2017 (mar
19)

On Mon, Mar 20, 2017 at 02:06:13PM +0000, Ignas Bagdonas wrote:
> A small nit on the clarity of the applicability to al address families 
> - the way how it is worded now seems to assume global and VPN address 

Kind regards,

Job

---

From: Tore Anderson <[email-masked]>
Date: Mon, 20 Mar 2017 18:29:59 +0100

* Ben Maddison

> behavior of BGP in the wild.

Concur.

Tore

---

From: Theodore Baschak <[email-masked]>
Date: Mon, 20 Mar 2017 18:04:51 -0500

> On Mar 20, 2017, at 12:29 PM, Tore Anderson <[email-masked]> wrote:
> 
> * Ben Maddison
> 

Many new/inexperienced operators who go from 1 to 2 upsteams will continue to  cause leaks and experience problems until this is default.

Fully support this default behavior.

Theodore Baschak - AS395089 - Hextet Systems
https://bgp.guru/ - https://hextet.net/
http://mbix.ca/ - http://mbnog.ca/