Subject: [GROW] Making BMP registries FCFS

From: John Scudder <[email-masked]>
Date: Thu, 20 Sep 2018 08:12:36 +0000

Hi All,

A while ago we talked about this. I finally wrote a draft for it, https://www.ietf.org/id/draft-scudder-grow-bmp-registries-change-00.txt:

Abstract

   This document updates RFC 7854, BGP Monitoring Protocol (BMP) by
   making a change to the registration procedures for several
   registries.  Specifically, any BMP registry with a range of
   32768-65530 designated "Specification Required" has that range re-
   designated as "First Come First Served".

It's super short, 3 pages including all the boilerplate. I'd like to propose it as a WG item (and ideally, move it quickly to WGLC).

Thanks,

--John

P.S.: I'm one of the designated experts for those registries ("Specification Required" requires designated experts who review all requests). So I have the ulterior motive of trying to get rid of work. :-)

---

From: Randy Bush <[email-masked]>
Date: Thu, 20 Sep 2018 10:26:40 +0200

> A while ago we talked about this. I finally wrote a draft for it,
> https://www.ietf.org/id/draft-scudder-grow-bmp-registries-change-00.txt:
> 
> Abstract
> 
> It's super short, 3 pages including all the boilerplate. I'd like to
> propose it as a WG item (and ideally, move it quickly to WGLC).

make it so

randy

---

From: Jared Mauch <[email-masked]>
Date: Thu, 20 Sep 2018 06:13:57 -0400

I would also support adoption on the part of the WG if the chairs were to ask for it. 

Jared Mauch

On Sep 20, 2018, at 4:26 AM, Randy Bush <[email-masked]> wrote:

> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 20 Sep 2018 13:33:53 -0700

Hello Grow Folks,
This seems like a sane plan ... I or Job can either unilaterally accept
this, or ask for adoption...

If there's enough immediate call to avoid the 2wk call for adoption I'd be
happy to just put it on the docket...

On Thu, Sep 20, 2018 at 1:12 AM John Scudder <[email-masked]> wrote:

> P.S.: I'm one of the designated experts for those registries
> ("Specification Required" requires designated experts who review all
> requests). So I have the ulterior motive of trying to get rid of work. :-)

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 20 Sep 2018 22:29:19 +0100

LGTM. No issues with waving this through with minimal bureaucracy.

Nick

Christopher Morrow wrote on 20/09/2018 21:33:
> If there's enough immediate call to avoid the 2wk call for adoption I'd 
> be happy to just put it on the docket...
> 
> 
> 
> On Thu, Sep 20, 2018 at 1:12 AM John Scudder <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hi All,
> 
>     [email-masked] <mailto:[email-masked]>

---

From: Joel Jaeggli <[email-masked]>
Date: Fri, 21 Sep 2018 09:05:10 +0200

Sent from my iPhone

> On Sep 20, 2018, at 22:33, Christopher Morrow <[email-masked]> wrote:
> 
> Hello Grow Folks,
> This seems like a sane plan ... I or Job can either unilaterally accept this, or ask for adoption...
> 
> If there's enough immediate call to avoid the 2wk call for adoption I'd be happy to just put it on the docket...

I think you can adopt it and move on.  Support making registries low effort as a general principle.

---

From: Job Snijders <[email-masked]>
Date: Fri, 21 Sep 2018 13:54:31 +0200

Read the doc, looks fine to me. I support adoption.

Let’s give folks a few more days to comment.

Kind regards,

Job

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 21 Sep 2018 14:03:37 +0000

I support adoption as well.
Thanks,
Acee

From: GROW <[email-masked]> on behalf of Job Snijders <[email-masked]>
Date: Friday, September 21, 2018 at 7:55 AM
To: Joel Jaeggli <[email-masked]>
Cc: "[email-masked] [email-masked]" <[email-masked]>
Subject: Re: [GROW] Making BMP registries FCFS

Kind regards,

Job

On Fri, 21 Sep 2018 at 09:06, Joel Jaeggli <[email-masked]<mailto:[email-masked]>> wrote:

Sent from my iPhone

On Sep 20, 2018, at 22:33, Christopher Morrow <[email-masked]<mailto:[email-masked]>> wrote:
Hello Grow Folks,
This seems like a sane plan ... I or Job can either unilaterally accept this, or ask for adoption...

On Thu, Sep 20, 2018 at 1:12 AM John Scudder <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Abstract

Thanks,

--John

P.S.: I'm one of the designated experts for those registries ("Specification Required" requires designated experts who review all requests). So I have the ulterior motive of trying to get rid of work. :-)
_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow
_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow
_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow

---

From: Randy Bush <[email-masked]>
Date: Mon, 24 Sep 2018 12:29:33 -0700

> happy to just put it on the docket...

is there a problem following normal process?  is there a criterion for
skipping it?

randy

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 24 Sep 2018 15:39:39 -0400

Job and Chris: 

May I politely suggest we should just follow the normal course of things.  I
see moderate to good response, but not 400+ messages on the topic.  If this
occurs, we can start the WG LC after the adoption completes. 

IANA will need time to set this up, so going through the 2 weeks of WG LC is
fine for now. 

Cheerily,

Sue Hares
Idr-co-chair 

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of Randy Bush
Sent: Monday, September 24, 2018 3:30 PM
To: Christopher Morrow
Cc: [email-masked] [email-masked]
Subject: Re: [GROW] Making BMP registries FCFS

> If there's enough immediate call to avoid the 2wk call for adoption 
> I'd be happy to just put it on the docket...

randy

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 24 Sep 2018 22:23:41 -0400

yeeesh :) people are touchy this week :)

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 25 Sep 2018 11:46:00 +0100

> yeeesh :) people are touchy this week :)

Randy pushing for more process and bureaucracy?  This is new.  You 
should print this out and frame it.

Nick

---

From: Randy Bush <[email-masked]>
Date: Tue, 25 Sep 2018 07:45:35 -0700

> Randy pushing for more process and bureaucracy?

no, just the current process.

when under heavy load, i prefer not to start new tcp sessions,
especially ones where i do not know the authentication model.

randy