Subject: [GROW] Agenda Slot Requests - IETF 103

From: Christopher Morrow <[email-masked]>
Date: Thu, 18 Oct 2018 12:16:14 -0400

Howdy GrowFolks:

Please send along agenda requests as time permits... We are planning to
meet in Bangkok, unless no one can find agenda topics? :)

-chris

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 23 Oct 2018 16:40:45 -0400

Howdy Grow Folks... topics for discussion?

---

From: "Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked]>
Date: Wed, 24 Oct 2018 01:41:33 +0000

Hi Chris,

I’d like to request a 15 min discussion for “draft-gu-grow-bmp-route-leak-detection-00”

Thanks.

Yunan

A new version of I-D, draft-gu-grow-bmp-route-leak-detection-00.txt

has been successfully submitted by Shunwan Zhuang and posted to the IETF repository.

Name:             draft-gu-grow-bmp-route-leak-detection

Revision:         00

Title:                BMP for BGP Route Leak Detection

Document date:         2018-10-22

Group:            Individual Submission

Pages:             8

URL:            https://www.ietf.org/internet-drafts/draft-gu-grow-bmp-route-leak-detection-00.txt

Status:         https://datatracker.ietf.org/doc/draft-gu-grow-bmp-route-leak-detection/

Htmlized:       https://tools.ietf.org/html/draft-gu-grow-bmp-route-leak-detection-00

Htmlized:       https://datatracker.ietf.org/doc/html/draft-gu-grow-bmp-route-leak-detection

Abstract:

   According to RFC7908 [RFC7908], Route leaks refer to case that the

   delivery range of route advertisements is beyond the expected range.

   For many current security protection solutions, the ISPs (Internet

   Service Providers) are focusing on finding ways to detect the

   happening of route leaks.  However, the real-time route leak

   detection if any occurs is important as well.  This document extends

   the BGP Monitoring Protocol (BMP) [RFC7854] to provide a routing

   security scheme suitable for ISPs to detect BGP route leaks within

   their own networks.

From: GROW [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: 2018年10月24日 4:41
To: [email-masked] [email-masked] <[email-masked]>; <[email-masked]> <[email-masked]>; [email-masked]
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

On Thu, Oct 18, 2018 at 12:16 PM Christopher Morrow <[email-masked]<mailto:[email-masked]>> wrote:
Howdy GrowFolks:

Please send along agenda requests as time permits... We are planning to meet in Bangkok, unless no one can find agenda topics? :)

-chris

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 23 Oct 2018 21:45:40 -0400

Can we get some discussion on-list prior please?

On Tue, Oct 23, 2018 at 9:41 PM Guyunan (Yunan Gu, IP Technology Research
Dept. NW) <[email-masked]> wrote:

> *Hi Chris,*
>
>
>
> *I’d like to request a 15 min discussion for
> “draft-gu-grow-bmp-route-leak-detection-00”*
>
>
>
> *Thanks.*
>
>
>
> *Yunan*
>
>
>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-gu-grow-bmp-route-leak-detection-00.txt
>
> Status:
> https://datatracker.ietf.org/doc/draft-gu-grow-bmp-route-leak-detection/
>
> Htmlized:
> https://tools.ietf.org/html/draft-gu-grow-bmp-route-leak-detection-00
>
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-gu-grow-bmp-route-leak-detection
>
>
>
>
>
> Abstract:
>
> *From:* GROW [mailto:[email-masked]] *On Behalf Of *Christopher
> Morrow
> *Sent:* 2018年10月24日 4:41
> *To:* [email-masked] [email-masked] <[email-masked]>; <[email-masked]>
> <[email-masked]>; [email-masked]
> *Subject:* Re: [GROW] Agenda Slot Requests - IETF 103
>
>
>

---

From: "Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked]>
Date: Wed, 24 Oct 2018 02:28:06 +0000

Hi Chris,

Sure! We’d also like to solicit some comments on our draft.

Hi, Grow folks,

This draft proposes a method for detecting BGP route leaks using BMP. We mainly identified the requirements and concerns for the route leak detection, such as implementation dependency on other ISPs, detection accuracy and so on. We feel that BMP might be a good choice for the detection information collection with minor extension work while meeting these requirements.

Please, feel free to comment on either the motivation or solution.

Yunan

From: Christopher Morrow [mailto:[email-masked]]
Sent: 2018年10月24日 9:46
To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>
Cc: [email-masked] [email-masked] <[email-masked]>; <[email-masked]> <[email-masked]>; [email-masked]
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

On Tue, Oct 23, 2018 at 9:41 PM Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chris,

Thanks.

Yunan

Revision:         00

Pages:             8

Abstract:

   their own networks.

From: GROW [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Christopher Morrow
Sent: 2018年10月24日 4:41
To: [email-masked]<mailto:[email-masked]> [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

-chris

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Wed, 24 Oct 2018 16:04:25 +0000

Chris,

>Please send along agenda requests as time permits... We are planning to meet in Bangkok, unless no one can find agenda topics? :)

If possible to accommodate, I would like to request 10 to 15 minutes.

We have this updated WG draft in IDR on route leaks detection and mitigation.
There is a shift towards using BGP Community (previously it was BGP Attribute) for carrying
the Route Leak Protection (RLP) information.
The thinking behind this is potentially quicker deployment without  
dependence on vendor implementation changes.
It will be good to discuss this in GROW and get operator inputs on the type of
Community (transitive) that might be best suited (Large, Extended, etc.).

Updated IDR WG draft: https://tools.ietf.org/html/draft-ietf-idr-route-leak-detection-mitigation-10   

Authors’ Team Discussion Slides provide helpful graphics and scenario analyses:

https://www.nist.gov/sites/default/files/documents/2018/10/22/rlp_using_bgp_community-v4.pdf  

Sriram

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Wed, 24 Oct 2018 17:45:31 +0000

I am creating this separate thread for this draft.
Better to have the subject line relevant to the comments/discussion.
The authors would love to hear your comments/questions. 

Sriram

--------------------

Sriram

---

From: Paolo Lucente <[email-masked]>
Date: Wed, 24 Oct 2018 22:15:44 +0200

Hi Chris,

There has been some discussion on the mailing-list about draft-ietf-grow-bmp-local-rib and draft-ietf-grow-bmp-adj-rib-out; if time permits, I’d like to get some minimal time (15-20 mins total) to provide an update on the two drafts. 

Paolo

> On 23 Oct 2018, at 22:40, Christopher Morrow <[email-masked]> wrote:
> 
> On Thu, Oct 18, 2018 at 12:16 PM Christopher Morrow <[email-masked]> wrote:
> Howdy GrowFolks:
> 
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 24 Oct 2018 22:08:27 -0400

Sounds good to me.

On Wed, Oct 24, 2018 at 4:15 PM Paolo Lucente <[email-masked]> wrote:

>
> Hi Chris,
>
> There has been some discussion on the mailing-list about
> draft-ietf-grow-bmp-local-rib and draft-ietf-grow-bmp-adj-rib-out; if time
> permits, I’d like to get some minimal time (15-20 mins total) to provide an
> update on the two drafts.
>
> Paolo
>

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 24 Oct 2018 22:08:36 -0400

sounds good to me.

On Wed, Oct 24, 2018 at 12:04 PM Sriram, Kotikalapudi (Fed) <
[email-masked]> wrote:

> Updated IDR WG draft:
> https://tools.ietf.org/html/draft-ietf-idr-route-leak-detection-mitigation-10
>
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 25 Oct 2018 09:14:51 -0700

grow may, or may not, be interested in our imc paper, also presented at
ripe77, on bgp communities as weapons.

    https://ripe77.ripe.net/presentations/40-communities_slides.pdf

though my slides are different and more tuned to an ietf audience.

randy

---

From: Job Snijders <[email-masked]>
Date: Thu, 25 Oct 2018 18:28:26 +0200

I’d be interested.