Subject: [GROW] [Technical Errata Reported] RFC6396 (5511)

From: RFC Errata System <[email-masked]>
Date: Mon, 1 Oct 2018 14:40:53 -0700 (PDT)

The following errata report has been submitted for RFC6396,
"Multi-Threaded Routing Toolkit (MRT) Routing Information Export Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5511

--------------------------------------
Type: Technical
Reported by: James Clarke <[email-masked]>

Section: Appendix A

Original Text
-------------
|  BGP Update =

                ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
                00 3e 02 00 00 00 1f 40 01 01 02 40 02 0e 02 03
                00 00 fb f0 00 00 fb ff 00 00 fb f6 40 03 04 c6
                33 64 55 c0 08 04 fb f0 00 0e 18 cb 00 71

                 Figure 16: MRT BGP4MP_MESSAGE_AS4 Example

Corrected Text
--------------
|  BGP Update =

                ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
                00 3e 02 00 00 00 23 40 01 01 02 40 02 0e 02 03
                00 00 fb f0 00 00 fb ff 00 00 fb f6 40 03 04 c6
                33 64 bc c0 08 04 fb f0 00 0e 18 cb 00 71

                 Figure 16: MRT BGP4MP_MESSAGE_AS4 Example

Notes
-----
The total path attribute length is incorrectly encoded as 0x001F when it should be 0x0023 and the next hop ip address is incorrectly encoded as 0xc6336455 when it should be 0xc63364bc

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6396 (draft-ietf-grow-mrt-17)
--------------------------------------
Title               : Multi-Threaded Routing Toolkit (MRT) Routing Information Export Format
Publication Date    : October 2011
Author(s)           : L. Blunk, M. Karir, C. Labovitz
Category            : PROPOSED STANDARD
Source              : Global Routing Operations
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Warren Kumari <[email-masked]>
Date: Tue, 2 Oct 2018 14:43:55 -0400

James is correct -- I'll mark this one as verified.

For those whose hex-dump reading skill have atrophied, here is the fixed
version:
Border Gateway Protocol - UPDATE Message
    Marker: ffffffffffffffffffffffffffffffff
    Length: 62
    Type: UPDATE Message (2)
    Withdrawn Routes Length: 0
    Total Path Attribute Length: 35
    Path attributes
        Path Attribute - ORIGIN: INCOMPLETE
            Type Code: ORIGIN (1)
            Length: 1
            Origin: INCOMPLETE (2)
        Path Attribute - AS_PATH: 64496 64511 64502
            Type Code: AS_PATH (2)
            Length: 14
            AS Path segment: 64496 64511 64502
                Segment type: AS_SEQUENCE (2)
                Segment length (number of ASN): 3
                AS4: 64496
                AS4: 64511
                AS4: 64502
        Path Attribute - NEXT_HOP: 198.51.100.188
            Type Code: NEXT_HOP (3)
            Length: 4
            Next hop: 198.51.100.188
        Path Attribute - COMMUNITIES: 64496:14
            Type Code: COMMUNITIES (8)
            Length: 4
            Communities: 64496:14
                Community: 64496:14
                    Community AS: 64496
                    Community value: 14
    Network Layer Reachability Information (NLRI)
        203.0.113.0/24
            NLRI prefix length: 24
            NLRI prefix: 203.0.113.0

and here is what the RFC says the UPDATE should look like:

ORIGIN: INCOMPLETE
     ASPATH: 64496 64511 64502
     NEXT_HOP: 198.51.100.188
     COMMUNITY: 64496:14
     NLRI: 203.0.113.0/24

Thanks!
W

On Mon, Oct 1, 2018 at 5:41 PM RFC Errata System <[email-masked]>
wrote:

> The total path attribute length is incorrectly encoded as 0x001F when it
> should be 0x0023 and the next hop ip address is incorrectly encoded as
> 0xc6336455 when it should be 0xc63364bc
>
> Instructions:
> -------------

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf