Subject: Re: [GROW] Agenda Slot Requests - IETF 103

From: "Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked]>
Date: Sun, 4 Nov 2018 14:11:28 +0000

Dear Grow members,

We have attached the slides to better illustrate our draft: “draft-gu-grow-bmp-route-leak-detection-00”. We basically explained the ideas of 1. The conventional route leak PROTECTION methods; 2. the intra-AS route leak PROTECTION method -- using BGP open policy method proposed by “draft-ietf-idr-bgp-open-policy-03”, and 3. our intra-AS route leak DETECTION method.

We believe that our method provides a route leak self-checking method for a single ISP, which is complementary to any existing route leak protection methods as a way of validation.

Although we don’t have a slot for discussion tomorrow at the meeting, we do hope to solicit more comments.

Thanks.

Yunan

From: GROW [mailto:[email-masked]] On Behalf Of Guyunan (Yunan Gu, IP Technology Research Dept. NW)
Sent: Wednesday, October 24, 2018 9:28 AM
To: Christopher Morrow <[email-masked]>; [email-masked] [email-masked] <[email-masked]>
Cc: <[email-masked]> <[email-masked]>; [email-masked]
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

Hi Chris,

Sure! We’d also like to solicit some comments on our draft.

Hi, Grow folks,

This draft proposes a method for detecting BGP route leaks using BMP. We mainly identified the requirements and concerns for the route leak detection, such as implementation dependency on other ISPs, detection accuracy and so on. We feel that BMP might be a good choice for the detection information collection with minor extension work while meeting these requirements.

Please, feel free to comment on either the motivation or solution.

https://www.ietf.org/internet-drafts/draft-gu-grow-bmp-route-leak-detection-00.txt

Yunan

From: Christopher Morrow [mailto:[email-masked]]
Sent: 2018年10月24日 9:46
To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

Can we get some discussion on-list prior please?

On Tue, Oct 23, 2018 at 9:41 PM Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chris,

I’d like to request a 15 min discussion for “draft-gu-grow-bmp-route-leak-detection-00”

Thanks.

Yunan

A new version of I-D, draft-gu-grow-bmp-route-leak-detection-00.txt

has been successfully submitted by Shunwan Zhuang and posted to the IETF repository.

Name:             draft-gu-grow-bmp-route-leak-detection

Revision:         00

Title:                BMP for BGP Route Leak Detection

Document date:         2018-10-22

Group:            Individual Submission

Pages:             8

URL:            https://www.ietf.org/internet-drafts/draft-gu-grow-bmp-route-leak-detection-00.txt

Status:         https://datatracker.ietf.org/doc/draft-gu-grow-bmp-route-leak-detection/

Htmlized:       https://tools.ietf.org/html/draft-gu-grow-bmp-route-leak-detection-00

Htmlized:       https://datatracker.ietf.org/doc/html/draft-gu-grow-bmp-route-leak-detection

Abstract:

   According to RFC7908 [RFC7908], Route leaks refer to case that the

   delivery range of route advertisements is beyond the expected range.

   For many current security protection solutions, the ISPs (Internet

   Service Providers) are focusing on finding ways to detect the

   happening of route leaks.  However, the real-time route leak

   detection if any occurs is important as well.  This document extends

   the BGP Monitoring Protocol (BMP) [RFC7854] to provide a routing

   security scheme suitable for ISPs to detect BGP route leaks within

   their own networks.

From: GROW [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Christopher Morrow
Sent: 2018年10月24日 4:41
To: [email-masked]<mailto:[email-masked]> [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

Howdy Grow Folks... topics for discussion?

On Thu, Oct 18, 2018 at 12:16 PM Christopher Morrow <[email-masked]<mailto:[email-masked]>> wrote:
Howdy GrowFolks:

Please send along agenda requests as time permits... We are planning to meet in Bangkok, unless no one can find agenda topics? :)

-chris

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 02:52:38 +1100

Howdy, as earlier... if you have not sent slides please do by 9am tomorrow
:)
(I'll be adding yunan's slides in the morning, and paolo has not sent
slides as of yet)

On Mon, Nov 5, 2018 at 1:11 AM Guyunan (Yunan Gu, IP Technology Research
Dept. NW) <[email-masked]> wrote:

> Dear Grow members,
>
>
>
> We have attached the slides to better illustrate our draft:
> “draft-gu-grow-bmp-route-leak-detection-00”. We basically explained the
> ideas of 1. The conventional route leak PROTECTION methods; 2. the intra-AS
> route leak PROTECTION method -- using BGP open policy method proposed by
> “draft-ietf-idr-bgp-open-policy-03”, and 3. our intra-AS route leak
> DETECTION method.
>
>
>
> We believe that our method provides a route leak self-checking method for
> a single ISP, which is complementary to any existing route leak protection
> methods as a way of validation.
>
>
>
> *From:* GROW [mailto:[email-masked]] *On Behalf Of *Guyunan (Yunan
> Gu, IP Technology Research Dept. NW)
> *Sent:* Wednesday, October 24, 2018 9:28 AM
> *To:* Christopher Morrow <[email-masked]>; [email-masked]
> [email-masked] <[email-masked]>
> *Cc:* <[email-masked]> <[email-masked]>;
> [email-masked]
> *Subject:* Re: [GROW] Agenda Slot Requests - IETF 103
>
>
>
> *Hi Chris, *
>
>
>
> *Sure! We’d also like to solicit some comments on our draft. *
>
>
>
> *Hi, Grow folks,*
>
>
>
> *This draft proposes a method for detecting BGP route leaks using BMP. We
> mainly identified the requirements and concerns for the route leak
> detection, such as implementation dependency on other ISPs, detection
> accuracy and so on. We feel that BMP might be a good choice for the
> detection information collection with minor extension work while meeting
> these requirements. *
>
>
>
> *Please, feel free to comment on either the motivation or solution.*
>
>
> *Yunan*
> *From:* Christopher Morrow [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* 2018年10月24日 9:46
> *To:* Guyunan (Yunan Gu, IP Technology Research Dept. NW) <
> [email-masked]>
> *Cc:* [email-masked] [email-masked] <[email-masked]>; <[email-masked]>
> <[email-masked]>; [email-masked]
> *Subject:* Re: [GROW] Agenda Slot Requests - IETF 103
>
>
>
> On Tue, Oct 23, 2018 at 9:41 PM Guyunan (Yunan Gu, IP Technology Research
> Dept. NW) <[email-masked]> wrote:
>
> *Hi Chris,*
>
>
>
> *I’d like to request a 15 min discussion for
> “draft-gu-grow-bmp-route-leak-detection-00”*
>
>
>
> *Thanks.*
>
>
>
> *Yunan*
>
>
>
>
>
> URL:
> Status:
> https://datatracker.ietf.org/doc/draft-gu-grow-bmp-route-leak-detection/
>
> Htmlized:
> https://tools.ietf.org/html/draft-gu-grow-bmp-route-leak-detection-00
>
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-gu-grow-bmp-route-leak-detection
>
>
>
>
>
> Abstract:
>
> *From:* GROW [mailto:[email-masked]] *On Behalf Of *Christopher
> Morrow
> *Sent:* 2018年10月24日 4:41
> *To:* [email-masked] [email-masked] <[email-masked]>; <[email-masked]>
> <[email-masked]>; [email-masked]
> *Subject:* Re: [GROW] Agenda Slot Requests - IETF 103
>
>
>
> On Thu, Oct 18, 2018 at 12:16 PM Christopher Morrow <
> [email-masked]> wrote:
>
> Howdy GrowFolks:
>
>
>
> Please send along agenda requests as time permits... We are planning to
> meet in Bangkok, unless no one can find agenda topics? :)
>
>
>
> -chris
>
>

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:07:00 +1100

Paolo,
you have slides or not interested in presenting anymore?

On Thu, Oct 25, 2018 at 7:15 AM Paolo Lucente <[email-masked]> wrote:

>
> Hi Chris,
>
> There has been some discussion on the mailing-list about
> draft-ietf-grow-bmp-local-rib and draft-ietf-grow-bmp-adj-rib-out; if time
> permits, I’d like to get some minimal time (15-20 mins total) to provide an
> update on the two drafts.
>
> Paolo
>
> > On 23 Oct 2018, at 22:40, Christopher Morrow <
> > _______________________________________________
> > GROW mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/grow
>
>

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:08:18 +1100

Randy, I'm going to use your IEPG slides, please bear in mind that we have
1hr, so your time slot is ... short.

-chris

On Fri, Oct 26, 2018 at 3:14 AM Randy Bush <[email-masked]> wrote:

> grow may, or may not, be interested in our imc paper, also presented at
> ripe77, on bgp communities as weapons.
>
>     https://ripe77.ripe.net/presentations/40-communities_slides.pdf
>
> though my slides are different and more tuned to an ietf audience.
>
> randy
>

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:09:41 +1100

Yunan, was this set of slides what you wanted to present for today?
Did you have alternate slides?

---

From: "Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked]>
Date: Mon, 5 Nov 2018 02:13:53 +0000

Hi Chris,

That one will do.

Yunan

From: Christopher Morrow
To: Guyunan (Yunan Gu, IP Technology Research Dept. NW)<[email-masked]<mailto:[email-masked]>>
Cc: grow<[email-masked]<mailto:[email-masked]>>;grow-chairs<[email-masked]>" >;grow-ads<<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>>
Subject: Re: [GROW] Agenda Slot Requests - IETF 103
Time: 2018-11-05 09:10:05

On Mon, Nov 5, 2018 at 1:11 AM Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]<mailto:[email-masked]>> wrote:
Dear Grow members,

Thanks.

Yunan

From: GROW [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Guyunan (Yunan Gu, IP Technology Research Dept. NW)
Sent: Wednesday, October 24, 2018 9:28 AM
To: Christopher Morrow <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [GROW] Agenda Slot Requests - IETF 103

Hi Chris,

Hi, Grow folks,

Yunan

Thanks.

Yunan

Revision:         00

Pages:             8

Abstract:

   their own networks.

-chris

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:16:31 +1100

On Mon, Nov 5, 2018 at 1:13 PM Guyunan (Yunan Gu, IP Technology Research

> That one will do.
Terrific, uploaded to the materials site (and agenda adjusted)

> Yunan
>
> *From: *Christopher Morrow
> *To: *Guyunan (Yunan Gu, IP Technology Research Dept. NW)<
> [email-masked]>
> *Cc: *grow<[email-masked]>;grow-chairs<[email-masked]>" >;grow-ads<
> <[email-masked]%3E>[email-masked]>
> *Subject: *Re: [GROW] Agenda Slot Requests - IETF 103
> *Time: *2018-11-05 09:10:05
>
>> *From:* GROW [mailto:[email-masked]] *On Behalf Of *Guyunan
>> (Yunan Gu, IP Technology Research Dept. NW)

---

From: Paolo Lucente <[email-masked]>
Date: Mon, 5 Nov 2018 03:19:59 +0100

Hi Chris,

Yes. Apologies being last minute. Find them attached.

Paolo

> On 05 Nov 2018, at 03:07, Christopher Morrow <[email-masked]> wrote:
> 
> Paolo,
> There has been some discussion on the mailing-list about draft-ietf-grow-bmp-local-rib and draft-ietf-grow-bmp-adj-rib-out; if time permits, I’d like to get some minimal time (15-20 mins total) to provide an update on the two drafts. 
> 
> Paolo
> 
> > On 23 Oct 2018, at 22:40, Christopher Morrow <[email-masked]> wrote:
> > 
> > On Thu, Oct 18, 2018 at 12:16 PM Christopher Morrow <[email-masked]> wrote:
> > Howdy GrowFolks:
> >

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:21:22 +1100

Sorry, I should have said this much earlier: "please send PDF only, if you
send PPT, I convert and you will (likely) suffer"

want to convert to pdf and send me a copy of that? :)

On Mon, Nov 5, 2018 at 1:20 PM Paolo Lucente <[email-masked]> wrote:

> > > Please send along agenda requests as time permits... We are planning
> to meet in Bangkok, unless no one can find agenda topics? :)
> > >
> > > -chris

---

From: Paolo Lucente <[email-masked]>
Date: Mon, 5 Nov 2018 03:22:36 +0100

Done :)

Paolo

> On 05 Nov 2018, at 03:21, Christopher Morrow <[email-masked]> wrote:
> 
> Sorry, I should have said this much earlier: "please send PDF only, if you send PPT, I convert and you will (likely) suffer"
>

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:24:54 +1100

thanks!

All slides uploaded and agenda adjusted.
Thanks to the presenters and please remember that timeslots are very short
this meeting .... We'll be making a strong effort to keep folk to time.

On Mon, Nov 5, 2018 at 1:22 PM Paolo Lucente <[email-masked]> wrote:

> > Sorry, I should have said this much earlier: "please send PDF only, if
> you send PPT, I convert and you will (likely) suffer"
> >