Subject: [GROW] Notes on GROW "Living Document on routing security" meeting

From: Job Snijders <[email-masked]>
Date: Tue, 6 Nov 2018 08:26:47 +0000

Dear GROW,

As discussed in the GROW meeting yesterday, today a few folks met up to
discuss the concept of a 'Living Document'. Yesterday's presentation can
be reviewed here: https://youtu.be/XvVe2-51CQM?t=2322

[ TL;DR - we'll start writing in internet-draft format, treat the XML as
a software, use issues/pull requests through github, and by the time we
feel a first revision can be published we hope IETF can facilitate an
appropiate publication. ]

Below are my notes:

present:
    Warren Kumari (Ops AD), Nathalie Trenaman (participant),
    Alissa Cooper (IETF chair), Alice Russo (RFC Editor),
    Christoper Morrow (GROW chair), Job Snijders (GROW chair)

Todo items:

(job) write up a description of the experiment, document why rfcs or
drafts are not entirely suitable.

Nathalie shared some experience from RIPE NCC's training material
development process, for each Living Document we should specify:
    o scope
    o goals
    o audience

There should be an appendix that summarizes the changes between
revisions, so that people familiar with an earlier revision can catch up
more easily.

Expectations from IETF:
    o new stream/series? "living documents" (under label "experiment"?)
    o boilerplate texts, that describe what the document is and what kind
      of review took place (no IESG, no IETF last call, etc..)
    o stable URLs
    o consider what this should look and feel like (RFC like? memo like?)
    o consider what (if?) the datatracker needs to be do

review process per revision:
    o working group last call-ish
    o informal ietf review
    o routing directorate

Alice mentioned that perhaps we can take a look at W3C how they manage
and publish their living documents.

Alissa noted that this entire project should be considered an experiment
and not more.

In general security related themes may be suitable for this type of
document, as in security things change relatively quick compared to
protocol specifications.

GROW can start working on this now, I expect that perhaps in 6 to 9
months we have a 20-30 page document, so by then the IETF can facilitate
stable URLs.

Kind regards,

Job

---

From: <[email-masked]>
Date: Tue, 6 Nov 2018 11:52:25 +0000

On a side note, since the stable URL point is mentioned multiple times, it seems to me that the IETF is already capable of providing a stable URL including for draft. e.g.
https://tools.ietf.org/html/draft-ietf-grow-bmp-adj-rib-out

--Bruno

 > -----Original Message-----
 > From: GROW [mailto:[email-masked]] On Behalf Of Job Snijders
 > Sent: Tuesday, November 06, 2018 3:27 PM
 > To: [email-masked]
 > Subject: [GROW] Notes on GROW "Living Document on routing security" meeting
 > 
 > Dear GROW,
 > 
 > _______________________________________________
 > GROW mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/grow

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Job Snijders <[email-masked]>
Date: Tue, 6 Nov 2018 18:59:51 +0700

Hi Bruno,

On Tue, Nov 6, 2018 at 18:52 <[email-masked]> wrote:

> On a side note, since the stable URL point is mentioned multiple times, it
> seems to me that the IETF is already capable of providing a stable URL
> including for draft. e.g.

I’m aware of this feature, and appreciate its usefulness - however these
URL’s hardly roll of the tongue easily. :-) what I meant with “stable URLs”
is also an abbreviation with a unique number.

For the purpose of documenting a working group consensus on how to secure
EBGP sessions and regularly publishing updates; I think internet-drafts in
their current form are less suitable. Drafts expire every 6 months and it’s
not trivial to show what’s documentation in development and what’s a
published revision which was peer reviewed.

We’ll start with the draft format anyway, since we have nothing else at
this moment :-)

Kind regards,

Job

> <https://tools.ietf.org/html/draft-ietf-grow-bmp-adj-rib-out>