Subject: Re: [GROW] Value of timestamps in BMP header for local-rib monitoring

From: "Tim Evens (tievens)" <[email-masked]>
Date: Thu, 13 Jun 2019 16:02:05 +0000

Thanks Mukul. I'll also update this one as noted.

On 6/13/19, 8:16 AM, "GROW on behalf of Mukul Srivastava" <[email-masked]<mailto:[email-masked]> on behalf of msri=[email-masked]<mailto:msri=[email-masked]>> wrote:

Hi All

The current BMP Local-RIb draft doesn’t define what timestamp should be used in Per-Peer header for BMP local RIB monitoring.

BMP RFC 7854 defines “Timestamp” in Per-Peer header as below:

Timestamp: The time when the encapsulated routes were received(one may also think of this as the time when they were installed in the Adj-RIB-In), expressed in seconds and microseconds since midnight (zero hour), January 1, 1970 (UTC).  If zero, the time is unavailable.  Precision of the timestamp is implementation-dependent.

The above timestamp use doesn’t make much sense for local RIB monitoring case.

Proposal:
1.      Since local RIB is not specific to a peer, the time stamp could be the time when BMP RM message was created or sent to BMP collector.
2.      Another option would be that the timestamp value be the time when this prefix was installed in local RIB.

Otherwise the definition of “timestamp” would be the same as in RFC 7854. So, something like this:

   o  Timestamp: The time when the encapsulated routes were installed in
      The Loc-RIB, expressed in seconds and microseconds since
      midnight (zero hour), January 1, 1970 (UTC).  If zero, the time is
      unavailable.  Precision of the timestamp is implementation-
      dependent.
Thanks
Mukul

---

From: Jared Mauch <[email-masked]>
Date: Wed, 19 Jun 2019 08:41:36 -0400

> On Jun 13, 2019, at 12:02 PM, Tim Evens (tievens) <[email-masked]> wrote:
> 

Tim,

Sorry, are you saying you’re updating it to proposal #1 or #2 ?

(I would want #2)

- Jared

>  
> On 6/13/19, 8:16 AM, "GROW on behalf of Mukul Srivastava" <[email-masked] on behalf of msri=[email-masked]> wrote:
>  
> Hi All
>  
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Paolo Lucente <[email-masked]>
Date: Wed, 19 Jun 2019 13:03:25 +0000

Hi Jared,

We had a brief conversation. To confirm we went for #2, yes:

https://github.com/TimEvens/draft-ietf-grow-bmp-loc-rib/blob/master/draft-ietf-grow-bmp-local-rib.txt#L495-L499

Paolo

On 19 Jun 2019, at 14:41, Jared Mauch <[email-masked]<mailto:[email-masked]>> wrote:

On Jun 13, 2019, at 12:02 PM, Tim Evens (tievens) <[email-masked]<mailto:[email-masked]>> wrote:

Tim,

(I would want #2)

- Jared

Hi All

Proposal:

[email-masked]<mailto:[email-masked]>