Subject: [GROW] BMP compression Draft

From: Mukul Srivastava <[email-masked]>
Date: Wed, 16 Oct 2019 13:46:34 +0000

Hello GROW,

Myself and Paolo have submitted https://www.ietf.org/id/draft-msri-grow-bmp-compression-00.txt<https://urldefense.com/v3/__https:/www.ietf.org/id/draft-lucente-bmp-tlv-00.txt__;!8WoA6RjC81c!Ve6VOxjMty-V1IHnsYIbwkFNeemoNfQZHSV_wmwIEB33caxtUSW6gjozn7v6QA$> .
We would like to get opportunity to present it in Singapore (IETF 106) and would much welcome feedback on list meanwhile.

Abstract below for your convenience:

“This document provides specification for an optional compressed BMP Feed from a router to BMP station.”

Thanks
Mukul

---

From: Mukul Srivastava <[email-masked]>
Date: Wed, 16 Oct 2019 13:56:55 +0000

Hello GROW,

Looks like the link in my previous mail is wrong.

Corrected link:
https://tools.ietf.org/id/draft-msri-grow-bmp-compression-00.txt

Thanks
Mukul

From: Mukul Srivastava <[email-masked]>
Date: Wednesday, October 16, 2019 at 9:46 AM
To: "[email-masked]" <[email-masked]>
Cc: Paolo Lucente <[email-masked]>, Mukul Srivastava <[email-masked]>
Subject: BMP compression Draft

Hello GROW,

Thanks
Mukul

---

From: <[email-masked]>
Date: Wed, 16 Oct 2019 17:44:29 +0000

Hi Mukul and Paolo,

Thank you very much for this draft. I think it is a welcoming contribution to the other BMP drafts with the aim to reduce the encapsulation costs of BMP.

Swisscom as service provider has seen by using BMP RFC 7854 configured on MPLS PE routers, the burstiness at the data collection. In average, the amount of metrics are relatively small compared to YANG push and IPFIX. But when BMP peer is established, or BGP route refresh is in action or simply a major re-convergence in the network is ongoing, we see a spike in metrics and TCP re-transmits on the router side due to the nature of synchronization. Nothing to be alarmed of, since buffer on router side takes care of such congestions, but it does give the impression that with the increase of prefixes and TLV's a mitigation would be a good idea. Using compression, especially by following the same path as draft-przygienda-idr-compressed-updates-07 makes completely sense.

Looking forward for the WG adoption.

Best Wishes
Thomas Graf

From: GROW <[email-masked]> On Behalf Of Mukul Srivastava
Sent: Wednesday, October 16, 2019 3:57 PM
To: [email-masked]
Cc: Mukul Srivastava <[email-masked]>
Subject: Re: [GROW] BMP compression Draft

Hello GROW,

Corrected link:

Thanks
Mukul

From: Mukul Srivastava <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 16, 2019 at 9:46 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Paolo Lucente <[email-masked]<mailto:[email-masked]>>, Mukul Srivastava <[email-masked]<mailto:[email-masked]>>
Subject: BMP compression Draft

Hello GROW,

Thanks
Mukul