Subject: [GROW] Information model for BGP Communities (Was: Proposed updates to GROW charter)

From: Job Snijders <[email-masked]>
Date: Fri, 22 Nov 2019 04:02:59 +0000

Forking this thread.

On Fri, Nov 22, 2019 at 03:44:26AM +0000, [email-masked] wrote:
> Very good input regarding „Devise a BGP Community Description System
> to IESG.
> 
> I think a YANG informational BGP community modell might be the right
> thing to do. I would volunteer to support such an approach.
> 
> I think it is good to keep the charter generic. I like your proposal.
> 
> I would be interested to know if others on the mailing list share my
> opinion on using YANG information model.

I would suggest to talk technology specifics in a new thread, and would
also like to suggest we first get a better handle on the goal and
problem space definition. This probably is a quite large project.

Kind regards,

Job

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 22 Nov 2019 19:18:14 +0800

Having gone through a flavor of this issue as part of the wide communities work, I think you’ll find it a bit more constrained than you might think. 

For purposes of a yang model, the main short term question is whether you wish to collapse some of the actions to common ones that might be modeled as Yang identities. 

Examples of this would include prepend N times. Set local preference. Set or adjust MED. Etc. 

Once the catalog is built, standardization is no longer the hard part. 

Jeff

> On Nov 22, 2019, at 12:07, Job Snijders <[email-masked]> wrote:
> 
> Forking this thread.
> 
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 22 Nov 2019 15:18:09 +0100

All,

I think the common description is a good thing and not so hard to build.

What I think would be a bit more challenging is to create a protocol
extension where each AS (adjucent or not) would be able to signal set of
communities it honors and supports in an automated way.

Today it is all manual web based thing ... I think sooner or later we need
to depart from it.

Cheers,
R.

On Fri, Nov 22, 2019 at 12:18 PM Jeffrey Haas <[email-masked]> wrote:

> Having gone through a flavor of this issue as part of the wide communities
> work, I think you’ll find it a bit more constrained than you might think.
>
> For purposes of a yang model, the main short term question is whether you
> wish to collapse some of the actions to common ones that might be modeled
> as Yang identities.
>