Subject: Re: [GROW] Proposed updates to GROW charter

From: Job Snijders <[email-masked]>
Date: Fri, 23 Oct 2020 15:47:37 +0000

Dear group,

Taking Alvaro's and other people's feedback into account, here is the
fourth version of the charter.

OK? good to go? Warren Kumari? :-)

Kind regards,

Job
GROW co-chair

====

Charter for Working Group
 
The purpose of GROW is to consider the operational problems associated
with the Internet Protocol (IP) global routing systems, including but
not limited to default-free zone routing table growth, effects of the
interactions between interior and exterior routing protocols, the effect
of address allocation policies, or practices on the global routing
system. Where appropriate, GROW documents the operational aspects of
measurement, monitoring, policy, routing system security, VPN
infrastructures, or safe default behavior of IP routing protocol
implementations and deployments.

GROW will also advise various working groups, mainly IDR and SIDROPS,
with respect to whether it is addressing the relevant operational and
routing security requirements of Internet-connected networks, and where
appropriate, suggest course corrections. Finally, operational
requirements developed in GROW can also be used by any working group
chartered with standardizing a next generation inter-domain routing
protocol.
  
Goals:
------

Provide stewardship and maintenance for the BGP Monitoring  Protocol (BMP)
Provide stewardship and maintenance for the Multi-Threaded Routing Toolkit (MRT) Routing Information Export Format
Document Best Current Practises for operations of the Internet global routing system.
Analyze aspects for supporting new applications, including extending existing routing protocols or creating new ones. This includes risk, interference, and application fit.
Document the operational aspects of securing the Internet routing system, and provide recommendations to other WGs.
Provide documentation to assist in preventing malpractice in the global routing system.

Milestones
----------

Nov 2020 - "Support for Local RIB in BGP Monitoring Protocol (BMP)" to IESG
Jun 2021 - "BMP Peer Up Message Namespace" to IESG
Jun 2021 - "Revision to Registration Procedures for Multiple BMP Registries" to IESG.
Jul 2021 - “Document negative consequences of de-aggregating received  routes for traffic engineering purposes” - to IESG
Nov 2021 - "TLV support for BMP Route Monitoring and Peer Down Messages" to IESG.
Jan 2022 - “A BCP on using IRR and RPKI data to improve filtering of BGP peering sessions” to IESG or via “Evolving Documents”

---

From: Christopher Morrow <[email-masked]>
Date: Fri, 23 Oct 2020 12:31:44 -0400

whoops, this slipped through email cracks :(

On Wed, Jul 29, 2020 at 7:54 PM UTTARO, JAMES <[email-masked]> wrote:
>
> I understand that GROW is specific to Global Routing Operations at the current time. Is the intention of the new charter to address BGP as a protocol when explicitly dealing with routing state for standalone or inter-connected ... or is the scope expanded to include BGP as it is currently deployed to support non-routing and hybrid use cases?
>

I think GROW is 'global routing operations' yes.
I think the charter's re-work is to update our view on bgp
scalability/operations/measurement, just what GROW has always done.

I think your point about hybrid and non-routing use-cases applies to
the global internet as well, if only because in a wide variety of
instances (CBB being a local-to-you example, i think) BGP is 1 process
on a device that has many 'views' of the routing system that the
particular device manages, if there are failures in processing BGP
updates from any of the subordinate 'views' those failures could spill
over into the whole set of 'views' as performance impacts.

Simple examples of this exist:
  o Attribute 128 leakage into the global table causes wide spread
panic at the disco:
  o 'overly chatty' bgp speakers 'stealin ma bucket' (resource
starvation problems due to lack of resource controls in a
shared-tenant system)
  o Accidental leakages between address-families/vrfs/etc - exposure
due to complexity in the configuration/policy system
     (admittedly this is a form of the first item, almost certainly)
  o Additional testing requirements to cover 'unused' code paths
exposed in BGP speakers due to additional 'not global internet' (or
not other 'views') requirements

The BGP system today spans from the transport to dollar-centric parts
of the world, mistakes/problems/destruction in the BGP world have wide
ranging and very damaging impacts :( Trying to tighten up operations,
measurement, management, deployment of BGP in the world benefits both
the Global Internet and all other networks, actually.

I don't necessarily think GROW should go diving into the other
'views', but noting that the use/misuse/abuse of these other 'views'
can  substantially impact the global system is certainly something
GROW has done and should keep doing when appropriate.

> BGP is used for across multiple FOUs i.e Kompella, EVPN, FlowSpec, BGP-LS etc... Each of these present unique operational challenges.

I 100% agree with you here, I do also think that all of these (except
in some very exceptional cases) end up having the ability to impact
the global view as well.

> Will the charter address these and other FOUs BGP is used for?
>

sorry, I'm not sure I know what 'FOU' means here (which I should have
highlighted above, oops) .... I take it to mean something like: "other
use-cases" ?
as above: I don't think GROW needs/wants to go poking in (for
instance) BGP-LS directly, but as these technologies impact the global
system GROW should keep aware and be able to offer relevant
operational guidance to the community (and to the standards body)
about how to stay safe in this uncertain world.

-chris

> Thanks,
>         Jim Uttaro
>
> -----Original Message-----
> From: GROW <[email-masked]> On Behalf Of Christopher Morrow
> Sent: Wednesday, July 29, 2020 5:17 PM
> To: Alvaro Retana <[email-masked]>
> Cc: <[email-masked]> <[email-masked]>; [email-masked] [email-masked] <[email-masked]>; Warren Kumari <[email-masked]>
> Subject: Re: [GROW] Proposed updates to GROW charter
>
> On Wed, Jul 29, 2020 at 8:54 PM Alvaro Retana <[email-masked]> wrote:
> >
> > Job:
> >
> > Hi!
> >
> >
> > Thanks for addressing my comments!
> >
> >
> > I have just a couple more things:
> >
> > - The use of "Internet networks" doesn't sound right...perhaps "Internet-
> >   connected networks"?   Looking at the rest of the charter, I assume that,
>
> Job an I had a concern (I think we both shared this concern) about
> limiting the problems/solutions/monitoring/etc to
> 'internet-connected'.
> I think that 'bgp' (or external routing protocols) are used on both
> 'internet connected' and 'all the other' IP networks, right?
> should the benefits GROW pushes for be limited to 'internet connected' ?
>
> (I agree the current wording could use some help, how do we capture
> the idea that any IP network that ends up using a bgp can benefit?)
>
> >   for example, the operations of BGP in a non-Internet-connected network (a
> >   data center, for example) is not within the scope of grow.  Is that the
> >   intent, or am I reading too much into it?
>
> i think we were hoping to cover  both, actually. our wording choice
> wasn't great :)
>
> > - [nit] The last goal talks about "preventing malpractice in the global
> >   routing system".  I'm not sure documentation can stop someone from doing
> >   the wrong thing -- especially if they want to.  Maybe this goal can be
> >   worded positively: Document best practices and recommendations to assist
> >   in the proper operation of the global routing system.
>
> sounds ok to me :)
>
> > Thanks!
> >
> > Alvaro.
> >
> >
> >
> > On July 29, 2020 at 1:07:06 PM, Job Snijders
> > ([email-masked](mailto:[email-masked])) wrote:
> >
> > > Dear all,
> > >
> > > Below is a third revision of the charter proposal, we attempted to
> > > incorporate all the feedback received so far, specifically Alvaro's.
> > >
> > > Please let us know your feedback!
> > >
> > > Kind regards,
> > >
> > > Job & Chris
> > >
> > > ------------------------------------------------------
> > >
> > > ==========================
> > >
> > > GROW will also advise various working groups, specifically IDR and
> > > SIDROPS, with respect to whether it is addressing the relevant
> > > operational and routing security requirements of Internet networks,
> > > and where appropriate, suggest course corrections. Finally, operational
> > > GOALS
> > > -----
> > > * Provide stewardship and maintenance for the BGP Monitoring Protocol (BMP)
> > > * Provide stewardship and maintenance for the Multi-Threaded Routing
> > > Toolkit (MRT) Routing Information Export Format
> > > * Document Best Current Practises for operations of the Internet global
> > > routing system.
> > > * Analyze aspects for supporting new applications, including extending
> > > existing routing protocols or creating new ones. This includes risk,
> > > interference, and application fit.
> > > * Document the operational aspects of securing the Internet routing
> > > system, and provide recommendations to other WGs.
> > > * Provide documentation to assist in preventing malpractice in the
> > > global routing system.
> > >
> > > Milestones
> > > ----------
> > >
> > > 2020 - "Support for Local RIB in BGP Monitoring Protocol (BMP)" to IESG
> > > 2020 - "BMP Peer Up Message Namespace" to IESG
> > > 2020 - "Revision to Registration Procedures for Multiple BMP Registries" to IESG.
> > > 2021 - "Document negative consequences of de-aggregating received routes for traffic engineering purposes" - to IESG
> > > 2021 - "TLV support for BMP Route Monitoring and Peer Down Messages" to IESG.
> > > 2021 - "A BCP on using IRR and RPKI data to improve filtering of BGP peering sessions" to IESG or via "Evolving Documents"
> > >
> > >
> > > _______________________________________________
> > > GROW mailing list
> > > [email-masked]
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_grow&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=IojpM1TAAkTpS4ennajQ17-MgCMLHirQSt5AO_RHDJQ&s=elBh5rs6q5S7xQl2KMEIbFbYLdlPRgmKWPeej5I0pzo&e=
>
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_grow&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=IojpM1TAAkTpS4ennajQ17-MgCMLHirQSt5AO_RHDJQ&s=elBh5rs6q5S7xQl2KMEIbFbYLdlPRgmKWPeej5I0pzo&e=