Subject: [GROW] draft-spaghetti-grow-nrtm-v4-00

From: Sasha Romijn <[email-masked]>
Date: Fri, 04 Feb 2022 13:04:48 +0100

Hello,

We’ve submitted a draft for the Near Real Time Mirroring Protocol (NRTM) version 4: https://datatracker.ietf.org/doc/draft-spaghetti-grow-nrtm-v4/

This document specifies a one-way synchronization protocol for Internet Routing Registry (IRR) records. The protocol allows instances of IRR database servers to mirror IRR records, specified in in the Routing Policy Specification Language (RPSL), between each other.

NRTMv4 is intended as a replacement of current synchronization methods mainly based on FTP downloads and NRTM version 3, which have many problems that are addressed in NRTMv4.

The need for this originated from experiences by users of IRRD v4, and discussions in the RIPE Database working group, tracked under NWI-12:
https://www.ripe.net/ripe/mail/archives/db-wg/2020-November/006720.html

The broad strokes of this draft were previously discussed in a BoF in the RIPE Database wg, which included several operators of IRR databases, and responses were overall positive. I am also the maintainer of IRRD v4, one of the most widely used IRR database servers, and will implement it in there.

I’m proposing this draft for adoption by this working group. I would also be happy to present it in the IETF 113 session.

Sasha Romijn

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 10 Feb 2022 12:36:54 -0500

Sasha, would you be able to present this draft and reasoning/etc for it's
existence at the next f2f meeting?
(ietf 113 in vienna in ~1 month or so)

you can present virtually if travel to vienna is problematic (as it is for
me).

-chris
co-chair-persona

On Fri, Feb 4, 2022 at 7:05 AM Sasha Romijn <[email-masked]> wrote:

> Hello,
>
> We’ve submitted a draft for the Near Real Time Mirroring Protocol (NRTM)
> version 4: https://datatracker.ietf.org/doc/draft-spaghetti-grow-nrtm-v4/
>
> This document specifies a one-way synchronization protocol for Internet
> Routing Registry (IRR) records. The protocol allows instances of IRR
> database servers to mirror IRR records, specified in in the Routing Policy
> Specification Language (RPSL), between each other.
>
> NRTMv4 is intended as a replacement of current synchronization methods
> mainly based on FTP downloads and NRTM version 3, which have many problems
> that are addressed in NRTMv4.
>
> The need for this originated from experiences by users of IRRD v4, and
> discussions in the RIPE Database working group, tracked under NWI-12:
> The broad strokes of this draft were previously discussed in a BoF in the
> RIPE Database wg, which included several operators of IRR databases, and
> responses were overall positive. I am also the maintainer of IRRD v4, one
> of the most widely used IRR database servers, and will implement it in
> there.
>
> I’m proposing this draft for adoption by this working group. I would also
> be happy to present it in the IETF 113 session.
>
> Sasha Romijn
>
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>

---

From: Sasha Romijn <[email-masked]>
Date: Fri, 11 Feb 2022 19:15:53 +0100

Hello Chris,

Yes, I’d be happy to present it. Virtual is best for me.

Sasha

On 10 Feb 2022, at 18:36, Christopher Morrow wrote:

>> version 4: 
>> https://datatracker.ietf.org/doc/draft-spaghetti-grow-nrtm-v4/
>>