Subject: [GROW] Input on AS Prepend for draft-idr-rpd-15.txt - Ends 02/24/22

From: Keyur Patel <[email-masked]>
Date: Thu, 10 Feb 2022 21:53:44 +0000

[Sending it to IDR & GROW]

Hi Folks,

IDR is requesting input on the use of AS prepend in BGP policy. This begins a 2 week call for requested input on the beneficial use of AS Prepend. draft-ietf-grow-as-path-prepending-05.txt indicates there is a risk in excessive prepending. In section 5, this draft suggests there is no need to prepend more than 5 ASN in an AS Pathway by a single AS.  Is this recommendation firm or likely to change?  Should a comment be added to the draft-ietf-rpd-15.txt security section to point to the draft-ietf-grow-as-path-prepending-05.txt draft?

The RPD draft can be found at: https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd. The AS Path Prepending draft can be found at: https://datatracker.ietf.org/doc/html/draft-ietf-grow-as-path-prepending. This call will end on Feb 24th 2022.

Best Regards,
Keyur

---

From: Job Snijders <[email-masked]>
Date: Thu, 10 Feb 2022 23:05:15 +0100

Hi all,

(no hats)

On Thu, Feb 10, 2022 at 09:53:44PM +0000, Keyur Patel wrote:
> IDR is requesting input on the use of AS prepend in BGP policy. This
> begins a 2 week call for requested input on the beneficial use of AS
> Prepend. draft-ietf-grow-as-path-prepending-05.txt indicates there is
> a risk in excessive prepending. In section 5, this draft suggests
> there is no need to prepend more than 5 ASN in an AS Pathway by a
> single AS.  Is this recommendation firm or likely to change?  Should a
> comment be added to the draft-ietf-rpd-15.txt security section to
> point to the draft-ietf-grow-as-path-prepending-05.txt draft?
> 
> The RPD draft can be found at:
> https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd. The AS Path
> Prepending draft can be found at:
> https://datatracker.ietf.org/doc/html/draft-ietf-grow-as-path-prepending.
> This call will end on Feb 24th 2022.

A challenge with the recommendation as currently outlined in
draft-ietf-grow-as-path-prepending-05 ultimately is that it is a
so-called "magic constant". Magic constants in an ever growing routing
system could potentially impede future growth.

At GROW @ IETF 110 in the Q&A of an update on the draft I (and I believe
others) suggested to try to come up with a formula or some kind of
function into which certain properties of the default-free zone's
current observable state produce a useful number; rather than a magic
constant, to make the draft's recommendation somewhat future-proof. If
I'm not mistaken, an alternative to the 'magic constant' has not yet
materialized.

I'd be hesitant to reference draft-ietf-grow-as-path-prepending from
draft-ietf-rpd at this point in time.

Kind regards,

Job

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 10 Feb 2022 20:03:35 -0500

As co-author of both drafts I agree with Job to not reference
draft-ietf-grow-as-path-prepending-05.txt at this point in time for future
guidance on recommendations for prepending.

We also discussed this topic between the authors of the Grow draft and
agreed that at this point there is no alternative to a magic constant to
make the recommendation future proof.

Kind Regards

Gyan

On Thu, Feb 10, 2022 at 5:06 PM Job Snijders <job=
[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Randy Bush <[email-masked]>
Date: Fri, 11 Feb 2022 09:17:28 -0800

prepending has caused real problems.  an rfc damping prepending would be
useful and, imiho, this one is useful and does no harm.  like job, i am
not fond of magic numbers.  and, if i had to pick a magic number it
would be less than five.  but i am not a fan of prepending.

randy

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 12 Feb 2022 15:56:13 -0800

Fully agree with Job!

Cheers,
Jeff

> On Feb 10, 2022, at 14:05, Job Snijders <job=[email-masked]> wrote:
> 
> Hi all,
> 
> (no hats)
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 18 Feb 2022 08:10:43 -0500

[Speaking as an individual contributor.]

Prepending has been around for ages and it's well understood at this point in how it behaves.

An older version of the grow prepending document was nicely clear as to why excess prepending was problematic.  From that perspective, the document was useful.  More recent versions of the document have muddied its clarity.

I don't find it needful that BGP protocol documents reference this document in particular.

-- Jeff

> On Feb 10, 2022, at 4:53 PM, Keyur Patel <[email-masked]> wrote:
> 
> The RPD draft can be found at: https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd <https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd>. The AS Path Prepending draft can be found at:https://datatracker.ietf.org/doc/html/draft-ietf-grow-as-path-prepending <https://datatracker.ietf.org/doc/html/draft-ietf-grow-as-path-prepending>. This call will end on Feb 24th 2022.
>  
> Best Regards,
> Keyur
>  
> GROW mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/grow <https://www.ietf.org/mailman/listinfo/grow>

---

From: Keyur Patel <[email-masked]>
Date: Thu, 24 Feb 2022 22:17:22 +0000

Hi Folks,

This working group input call is closed now. The feedback is to not reference draft-ietf-grow-as-path-prepending-05.txt as of now.

Best Regards,
Keyur

From: Keyur Patel <[email-masked]>
Date: Thursday, February 10, 2022 at 1:53 PM
To: [email-masked] <[email-masked]>, GROW <[email-masked]>
Subject: Input on AS Prepend for draft-idr-rpd-15.txt - Ends 02/24/22
[Sending it to IDR & GROW]

Hi Folks,

Best Regards,
Keyur