Subject: RE: IP relatid forwarding info?

From: [email-masked]
Date: Thu, 30 Dec 1999 09:22:25 -0600

Hi,

The whole reason behind doing GSMP in the IETF is to support MPLS.
So, no, I think that if MPLS becomes a dominant method, then we
will see a need for GSMP, in that GSMP makes it possible for an
intelligent controller to do the MPLS signaling and handle routing
protocols etc., while a relatively specialized switch concentrates
on forwarding data.  GSMP is the protocol which enables the MPLS 
controller to control the data switch.  It is not another signaling
protocol.

a.
-----------------------------------
avri doria
+1 781 308 7680 
(this is a new number, please make a note.)

> -----Original Message-----
> From:	[email-masked] [mailto:[email-masked]]
> Sent:	30 December, 1999 7:39 AM
> To:	[email-masked]'
> Subject:	RE: IP relatid forwarding info?
> 
> Dear all:
		>      I think Mr. Patrick has asked a very good question!
Very 
		> nice. I think at persent gsmp is not perfect enough to 
		> include IP related forwarding information such as next hop

		> information for IP address prefixes or filter rules. I
think 
		> the main reason why gsmp protocol adopts extension label
is 
		> that gsmp wants to incorporate multiple label stack
supported 
		> by MPLS in near future. Otherwise, if MPLS becomes the
most 
		> popular signaling protocol, gsmp will have a bleak
prospect. 
		> Am I right? Give your opinion?
		>
Thanks 
		> & Regards!

		> 	Simon
		> 
> 
		> -----Original Message-----
		> From:	Patrick Droz [SMTP:[email-masked]]
		> Sent:	Thursday, December 30, 1999 3:36 PM
		> To:	[email-masked]
		> Subject:	IP relatid forwarding info?
		> 
		> The GSMP specification includes ATM, FR, and MPLS related
		> forwarding information. Was it ever considered to include
		> also IP related forwarding information such as next hop
		> information for IP address prefixes or filter rules?
		> 
		> Thanks,
		> Patrick
		> 
		> -- 
		>   Patrick Droz                | [email-masked]  
		>   IBM Zurich Research Laboratory  |
http://www.zurich.ibm.com/~dro 
		>   Saumerstrasse 4                 | Tel. +41-1-724-85-25

		>   CH-8803 Rueschlikon/Switzerland | Fax. +41-1-724-89-55

---

From: Clint Bishard <[email-masked]>
Date: Thu, 30 Dec 1999 13:37:29 -0600

Avri,

At the last MSF meeting in San Diego, the SCI working group discussed having
the GSMP protocol perform the function of mapping a list of IP addresses to
a label on the switch.  Therefore, the next hop forwarding function could be
performed by an external processor, however, the communication of mapping IP
address from the logical port function to a label on a switch could be
performed over GSMP.  Therefore, GSMP could realize the sp as well as the
vsc interfaces of the MSF architecture.  This was shown in MSF contribution
217.  I try to show this below:

	  Virtual Switch Control Function
		|			|
		|sp			|
		|			|vsc
Logical Port Function		|
____________|___			|
|              |     Virtual Switch Function
| IP1-label 1  |               |
| IP2-label 1  |-------Switching Function-------Other Logical Port Function
| IP3-label 2  |
| IP4-label 5  |
|______________|

The next hop routing would be performed in the control plane, and the GSMP
protocol would be utilized to realize the sp and vsc interfaces and
communicate this to the switch/adaptation planes.
I believe C-place mentioned that they may compile a contribution to add this
functionality to GSMP to be able to perform this IP to label mapping.

Clint

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Thursday, December 30, 1999 9:22 AM
To: [email-masked]
Subject: RE: IP relatid forwarding info?

Hi,

a.

Very

think
is
supported
most
prospect.
Thanks