Subject: A Gsmp doubt

From: Wang Shiming <[email-masked]>
Date: Wed, 29 Dec 1999 16:26:15 +0530

Hi, all:
     In the draft-ietf-gsmp-02.txt, the service configuration rsp msg can contain at most about 120 Service Capability Set Records.However, It's highly possible that a switch supports several hundred service capability set.So only one rsp msg can't contain all capability set information, but multiple rsp msg(or pdu) for service configuration request  doesn't seems to be allowed by gsmp protocol, so there is no way to do service configuration. For this problem, I think gsmp protocol should allow multiple rsp msg(or pdu) for service configuration request msg. What's your opinion?
      BTW, our discussing group doesn't seems very active at present, however, there are a lot of places that are far from  prefect in draft-ietf-gsmp-02.txt, So let's work together and made it better.
								Thanks & Regards!
									Wangs

---

From: "tom worster (fsb)" <[email-masked]>
Date: Wed, 29 Dec 1999 14:34:50 -0500

From: [email-masked] [mailto:[email-masked]]On Behalf Of
>
>      In the draft-ietf-gsmp-02.txt, the service configuration 
> rsp msg can contain at most about 120 Service Capability Set 
> Records.However, It's highly possible that a switch supports 
> several hundred service capability set.So only one rsp msg 
> can't contain all capability set information, but multiple 
> rsp msg(or pdu) for service configuration request  doesn't 
> seems to be allowed by gsmp protocol, so there is no way to 
> do service configuration. For this problem, I think gsmp 
> protocol should allow multiple rsp msg(or pdu) for service 
> configuration request msg. What's your opinion?

gsmp has a mechanism to allow the data of one gsmp
message to be conveyed in more than one gsmp pdu.

it's not an elegant mechanism but it will allow
what you are looking for. a proposal for a new
mechanism for segmentation of gsmp messages to
replace the existing one was discussed at the
last meeting. (chairs: correct me if i'm wrong)
i think the group welcomed the intent of the 
proposal but not the speific text provided. let's
hope we can find agreement on a mechanism in time
for the march meeting.

c u
tom