Subject: RE: IP related forwarding info?

From: [email-masked]
Date: Thu, 30 Dec 1999 08:23:54 -0600

Hi,

Several of us have talked about this.  It is not, however, 
in the current charter's list of activities.  It is also something
that will take time to work out and I am not sure of how much utilization
it would get.  One other related possibility that has been mentioned but not

yet taken very far is using GSMP to define IP headers as labels such 
that a switch with the capabilities can switch a packet from the IP hop 
by hop context to an MPLS path.

One of the things we hope to do in Adelaide, is discuss open 
requirements for GSMP so that we can submit a revised charter to
the ADs.  This is certainly a strong candidate.

I would welcome any ideas you have for to handle IP packets in GSMP
controlled switching.

Regards,

a.
-----------------------------------
avri doria
+1 617 678 9402

> -----Original Message-----
> From: EXT Patrick Droz [mailto:[email-masked]]
> Sent: 30 December, 1999 5:06 AM
> To: [email-masked]
> Subject: IP relatid forwarding info?
> 
> 
> The GSMP specification includes ATM, FR, and MPLS related
> forwarding information. Was it ever considered to include
> also IP related forwarding information such as next hop
> information for IP address prefixes or filter rules?
> 
> Thanks,
> Patrick
> 
> -- 
>   Patrick Droz                | [email-masked]  
>   IBM Zurich Research Laboratory  | http://www.zurich.ibm.com/~dro 
>   Saumerstrasse 4                 | Tel. +41-1-724-85-25           
>   CH-8803 Rueschlikon/Switzerland | Fax. +41-1-724-89-55
>

---

From: [email-masked]
Date: Thu, 30 Dec 1999 14:30:57 -0600

Hi Clint,

I think this an interesting idea.  
I look forward to the I-D which actually specifies the
GSMP changes that would be required to support this. 
Unfortunately the MSF99-217 draft is only available
to MSF members, which makes it difficult to discuss
in detail on this list.  Perhaps the MSF can make this
document available to the GSMP WG. 

One thing though, I have strong doubts that we can get
this into the GSMPv3 spec at this point in time.

Regards,

a.
-----------------------------------
avri doria
+1 781 308 7680 
(this is a new number, please make a note.)

> From: EXT Clint Bishard [mailto:[email-masked]]
> Sent: 30 December, 1999 2:37 PM
> To: [email-masked]
> Cc: Bishard, Clint
> Subject: RE: IP related forwarding info?
> 
> 
> Avri,
> 
> At the last MSF meeting in San Diego, the SCI working group 
> discussed having
> the GSMP protocol perform the function of mapping a list of 
> IP addresses to
> a label on the switch.  Therefore, the next hop forwarding 
> function could be
> performed by an external processor, however, the 
> communication of mapping IP
> address from the logical port function to a label on a switch could be
> performed over GSMP.  Therefore, GSMP could realize the sp as 
> well as the
> vsc interfaces of the MSF architecture.  This was shown in 
> MSF contribution
> 217.  I try to show this below:
> 
> 
> 	  Virtual Switch Control Function
> 		|			|
> 		|sp			|
> 		|			|vsc
> Logical Port Function		|
> ____________|___			|
> |              |     Virtual Switch Function
> | IP1-label 1  |               |
> | IP2-label 1  |-------Switching Function-------Other Logical 
> Port Function
> | IP3-label 2  |
> | IP4-label 5  |
> |______________|
> 
> 
> The next hop routing would be performed in the control plane, 
> and the GSMP
> protocol would be utilized to realize the sp and vsc interfaces and
> communicate this to the switch/adaptation planes.
> I believe C-place mentioned that they may compile a 
> contribution to add this
> functionality to GSMP to be able to perform this IP to label mapping.
> 
> Clint
> 
> 
> 
> 
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Thursday, December 30, 1999 9:22 AM
> To: [email-masked]
> Subject: RE: IP relatid forwarding info?
> 
> 
> Hi,
> 
> The whole reason behind doing GSMP in the IETF is to support MPLS.
> So, no, I think that if MPLS becomes a dominant method, then we
> will see a need for GSMP, in that GSMP makes it possible for an
> intelligent controller to do the MPLS signaling and handle routing
> protocols etc., while a relatively specialized switch concentrates
> on forwarding data.  GSMP is the protocol which enables the MPLS
> controller to control the data switch.  It is not another signaling
> protocol.
> 
> a.
> +1 781 308 7680
> (this is a new number, please make a note.)
> 
> 
> 
> > From:	[email-masked] 
> [mailto:[email-masked]]
> > Sent:	30 December, 1999 7:39 AM
> > To:	[email-masked]'
> > Subject:	RE: IP relatid forwarding info?
> >
> > Dear all:
> 		>      I think Mr. Patrick has asked a very 
> good question!
> Very
> 		> nice. I think at persent gsmp is not perfect enough to
> 		> include IP related forwarding information 
> such as next hop
> 
> 		> information for IP address prefixes or filter rules. I
> think
> 		> the main reason why gsmp protocol adopts 
> extension label
> is
> 		> that gsmp wants to incorporate multiple label stack
> supported
> 		> by MPLS in near future. Otherwise, if MPLS becomes the
> most
> 		> popular signaling protocol, gsmp will have a bleak
> prospect.
> 		> Am I right? Give your opinion?
> 		>
> Thanks
> 		> & Regards!
> 		>
> 
> 		> 	Simon
> 		>
> >
> 		> From:	Patrick Droz [SMTP:[email-masked]]
> 		> Sent:	Thursday, December 30, 1999 3:36 PM
> 		> To:	[email-masked]