Subject: [hiaps] Hiaps use cases

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 2 Dec 2013 10:32:32 -0600

I started a new tread on the use case issue that Med brought up.
Based on what Med said in his previous mail:

>IMHO before having solution-oriented discussion, let's see first if people
>understand well the problem space and the set of use cases identified
>so far.

for this we currently have:
http://tools.ietf.org/id/draft-boucadair-intarea-host-identifier-scenarios-03.txt

and
http://tools.ietf.org/id/draft-sarikaya-aps-prefix-sharing-usecase-00.txt

We are expecting a new draft on this and I know we already have some people
working on it.

Regards,

Behcet

---

From: Dan Wing <[email-masked]>
Date: Mon, 2 Dec 2013 11:28:50 -0800

> http://tools.ietf.org/id/draft-boucadair-intarea-host-identifier-scenarios-03.txt

It lists:

   (1)  Section 3.1: Carrier Grade NAT (CGN)
   (2)  Section 3.2: A+P (e.g., MAP )
   (3)  Section 3.3: Application Proxies
   (4)  Section 3.4: Provider Wi-Fi
   (5)  Section 3.5: Policy and Charging Architectures
   (6)  Section 3.6: Cellular Networks
   (7)  Section 3.7: Femtocells
   (8)  Section 3.8: Overlay Networks (e.g., CDNs)
   (9)  Section 3.9: Emergency Calls

but none of those are the 'roaming' situation which I believe Dirk von Hugo was concerned with, where he wanted an identifier to persist across network attach points.  (Veering into solutions, I wonder if an MPTCP-like connection identifier would solve the problem, even if MPTCP itself isn't used).

-d

> We are expecting a new draft on this and I know we already have some people working on it.
> 
> Regards,
> 
> Behcet
> _______________________________________________
> hiaps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hiaps

---

From: <[email-masked]>
Date: Tue, 3 Dec 2013 09:12:30 +0100

Hi all,

Dirk, would it be possible to have more details on the use case that requires a persistent identifier? Thanks.

Cheers,
Med

De : Dan Wing [mailto:[email-masked]]
Envoyé : lundi 2 décembre 2013 20:29
À : [email-masked]
Cc : [email-masked]; Xueli; BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : Re: [hiaps] Hiaps use cases

On Dec 2, 2013, at 8:32 AM, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:

It lists:

-d

and
[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Tue, 3 Dec 2013 10:51:12 +0100

Hi Med and all,
Frankly spoken I had no dedicated use case in mind but just thought of the several cases where a mobile terminal is involved at which an ongoing session may be active while moving between e.g. for Use Case 4: Open Wi-Fi or Provider Wi-Fi with visiting nodes, or UC5/6/7 which mention mobile operators networks or services.
Of course for sessions which start and complete while being served by an attach point under the same edge router no handover will occur.
What I had in mind are applications requiring session continuity such as VLAN connectivity for moving devices.
With a new session set up and new credentials to be exchanged and agreed on at each visit of a WiFi spot and corresponding service disruption the customer may be not amused ... the newly assigned Host_id might be the minor problem.
But maybe I misunderstood something here.
Should we discuss on this?

Best regards
Dirk
From: [email-masked] [mailto:[email-masked]]
Sent: Dienstag, 3. Dezember 2013 09:13
To: Dan Wing; [email-masked]; von Hugo, Dirk
Cc: [email-masked]; Xueli
Subject: RE: [hiaps] Hiaps use cases

Hi all,

Cheers,
Med

It lists:

-d

and

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 3 Dec 2013 11:08:25 -0600

>    (9)  Section 3.9: Emergency Calls
Are these use case well understood? Any issues with them?

There is also interest in combining Med's use cases draft with the prefix
sharing use case draft and also in the process concentrating on some of
them like emergency calls, CGNs and prefix sharing.

What do you think?

Behcet

> but none of those are the 'roaming' situation which I believe Dirk von
> Hugo was concerned with, where he wanted an identifier to persist across
> network attach points.  (Veering into solutions, I wonder if an MPTCP-like
> connection identifier would solve the problem, even if MPTCP itself isn't
> used).
>
> -d
>
>
>

---

From: Dan Wing <[email-masked]>
Date: Tue, 3 Dec 2013 15:49:12 -0800

> Are these use case well understood? Any issues with them?

I understand the first 4.  I understand the rest less.  Specifically, overlay networks (8) I understand because I have chatted several times with Brandon, but the I-D doesn't adequately motivate the use-case.  Emergency calls (9) is all over the map -- discusses solutions (which I believe is out of scope for the document, or should be?), some of which cannot work (specifically the location when using VPN cannot work).  Not sure of use-case #5, 6, or 7.

-d

> 
> There is also interest in combining Med's use cases draft with the prefix sharing use case draft and also in the process concentrating on some of them like emergency calls, CGNs and prefix sharing.
> 
> What do you think?
> 
> Behcet
>

---

From: <[email-masked]>
Date: Wed, 4 Dec 2013 11:35:31 +0100

Hi all,

regarding

RS: I do not understand why double NAT is not described or allowed

RS: do we have here also the use case for using private

Ipv4 addresses?

RS: this use case seems similar to the WiFi use case and

belongs IMHO to the "use case" heterogeneous networks in general

RS: This is a general use case and must be discussed for all use cases

What about the use case where mobile and/or fixed access are backup links for each other,
e.g. BBF use case? Is it included in Overlay Networks?

Regards

Roland

Von: hiaps [mailto:[email-masked]] Im Auftrag von Dan Wing
Gesendet: Mittwoch, 4. Dezember 2013 00:49
An: [email-masked]
Cc: [email-masked]; von Hugo, Dirk; Mohamed Boucadair; Xueli
Betreff: Re: [hiaps] Hiaps use cases

On Dec 3, 2013, at 9:08 AM, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Dec 2, 2013 at 1:28 PM, Dan Wing <[email-masked]<mailto:[email-masked]>> wrote:

It lists:

-d

-d

and