Subject: RE: [Hipsec] Base draft - 01-pre2

From: "Henderson, Thomas R" <[email-masked]>
Date: Wed, 20 Oct 2004 18:51:27 -0700

> The 01-pre2 version of the base draft is available at
> 
> http://hip4inter.net/drafts.php
> 

A few comments:

Section 5:

5.4.1-- CLOSED HIP SA clos, no data (ESP) can be sent
                         ^^ed
                        
in state CLOSING, receive I1, stay at UNASSOCIATED
                                       ^^^^^^^^^^^^
                                       CLOSING

(same copy and paste error for state CLOSED)
                                       
Section 6:

Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try to interoperate these packets.   Can we pick some values now? 

Section 8.16:

as i specified in Section 6.3.5.
   ^^
 (delete)

Section 13:     

NATing, etc.).  However, the optionnal behavior of replying to CLOSE
                             ^^^^^^^^^
                             optional
   
reflexion attacks.
^^^^^^^^^
reflection
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Petri Jokela <[email-masked]>
Date: Thu, 21 Oct 2004 09:32:16 +0300

Thanks for the fixes!

> Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try to interoperate these packets.   Can we pick some values now? 

How about 10 and 11?

/petri

---

From: Pekka Nikander <[email-masked]>
Date: Thu, 21 Oct 2004 18:15:37 +0300

>> Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try 
>> to interoperate these packets.   Can we pick some values now?
>
> How about 10 and 11?

I would suggest the following values, and also reordering
Sections 7 and 8 to reflect the same logic.

I1		1
R1		2
I2		3
R2		4
CER		5
UPDATE	6
NOTIFY	7
CLOSE	8
CACK	9
BOS	   	  --remove--  (should be an extension, separate document)
PAYLOAD   --remove--  (should be an extension, separate document)

I do see some strange beauty in the above series, but
that is minor.  If people prefer to retain existing
packet types, I don't have anything against it.

10 and 11 are fine.

--Pekka