Subject: [hiprg] HIPRG document process

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 1 Dec 2009 10:14:21 -0800

This note proposes a HIP RG process for advancing documents to draft-irtf-hip status.  Andrei and I have discussed formulating such a process for the past month or two, and have also raised the issue for discussion within the Internet Research Steering Group (IRSG).  Below is a policy that seems appropriate for our research group.

The purpose of advancing an independent submission to draft-irtf-hip status is to reflect that the HIP research group desires to work towards publishing the document as an IRTF-track RFC (http://www.ietf.org/id/draft-irtf-rfcs-05.txt).  It may also be the case that the document is later transferred to the HIP working group in the IETF if the HIP working group wants to adopt it.

The criteria for advancing an individual submission are:
1) the draft represents the consensus of the HIP research group, or even if the draft is not a consensus position, the HIP research group reached consensus that it should be published as a product of the RG
2) the document either already conforms to the guidelines posted at http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs, or there is a commitment from the authors to bring the draft into alignment
3) technical reviewers (non-authors) are identified

All drafts presented or posted for discussion on the HIP RG mailing list will be tracked on the wiki.  Anyone may propose (on the mailing list) a draft to be advanced to research group status, at which time the chairs will ask on the mailing list whether there is support. There must be some level of positive acknowledgment by non-authors to help review and improve the document to take this action.  If the chairs believe that the criteria are met, the draft can be advanced to research group status.  Authors may be asked to resolve comments or concerns and come back to the list with a revised draft at a later time.

Once the document reaches IRSG state, a document shepherd will be appointed (typically one of the RG chairs):
http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs#DocumentShepherds
The document shepherd will work with the authors to advance the document to the state at which it is ready for IRSG review:  http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs#IRSGReview.
While the RG will not officially have a "document shepherd" during the RG preparation stage, the technical reviewers reviewing this draft for the RG can look to the criteria in the above process in guiding their comments.

Not all HIP RG drafts will advance to IRSG review; some may migrate to the HIP WG, while some may never reach readiness for either state.  To keep things moving along, draft status will be reviewed at the beginning of each research group meeting.  Open issues may be tracked on the wiki or in an issue tracker.  If a draft languishes (no progress on open issues) after being identified as a research group draft, it may be taken off the list of research group drafts at a future date.

Below is a list of the drafts that have been discussed during the past year (aside from those that have been introduced to the RG for informational purposes such as RANGI and shim6 API) that we will add to the tracker.

1) Object naming with HIP
2) HIP for RF-ID
3) HIP and the IoT
4) HIP and user authentication
5) HI revocation
6) Hierarchical HI
7) HIT2IP
8) DNS Locators
9) HIP DHT interface
10) HIP services
11) HIP middleboxes
12) HIP SAVA
13) HIP SRP
14) Mobile router
15) HIP Proxy (Melen, Ylitalo, Salmela)
16) HIP proxies (Zhang, Xu, Yao)
17) ECC HIP

Of the above, we believe that the topics of HIP for Internet of Things, HI revocation, HIP
DHT interface, and proxies each probably meet the criteria for level of interest, although
in two cases (IoT and proxies) there are multiple contributions and we should try to chart
out a process to end up with RG-level drafts.   It may be that others are ready to move
forward at this time; please let us know your thoughts.

Please send your comments on the proposed process to the list, or let us know if we are missing any drafts above.

- Tom and Andrei

---

From: Pascal Urien <[email-masked]>
Date: Wed, 2 Dec 2009 09:58:12 +0100

Dear all,

I support the idea to introduce HIP for Internet Of things as WG working.
The draft HIP for RF-ID (HIP-Tag) is part of a reserach project funded by
the Frenc National Researck Agency, and has been implemented for test
purposes.

The draft HIP and the IoT is a

2009/12/1 Henderson, Thomas R <[email-masked]>

> This note proposes a HIP RG process for advancing documents to
> draft-irtf-hip status.  Andrei and I have discussed formulating such a
> process for the past month or two, and have also raised the issue for
> discussion within the Internet Research Steering Group (IRSG).  Below is a
> policy that seems appropriate for our research group.
>
> The purpose of advancing an independent submission to draft-irtf-hip status
> is to reflect that the HIP research group desires to work towards publishing
> the document as an IRTF-track RFC (
> http://www.ietf.org/id/draft-irtf-rfcs-05.txt).  It may also be the case
> that the document is later transferred to the HIP working group in the IETF
> if the HIP working group wants to adopt it.
>
> 1) the draft represents the consensus of the HIP research group, or even if
> the draft is not a consensus position, the HIP research group reached
> consensus that it should be published as a product of the RG
> 2) the document either already conforms to the guidelines posted at
> http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs, or there is a
> commitment from the authors to bring the draft into alignment
> All drafts presented or posted for discussion on the HIP RG mailing list
> will be tracked on the wiki.  Anyone may propose (on the mailing list) a
> draft to be advanced to research group status, at which time the chairs will
> ask on the mailing list whether there is support. There must be some level
> of positive acknowledgment by non-authors to help review and improve the
> document to take this action.  If the chairs believe that the criteria are
> met, the draft can be advanced to research group status.  Authors may be
> asked to resolve comments or concerns and come back to the list with a
> revised draft at a later time.
>
> The document shepherd will work with the authors to advance the document to
> the state at which it is ready for IRSG review:
> http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs#IRSGReview.
> While the RG will not officially have a "document shepherd" during the RG
> preparation stage, the technical reviewers reviewing this draft for the RG
> can look to the criteria in the above process in guiding their comments.
>
> Not all HIP RG drafts will advance to IRSG review; some may migrate to the
> HIP WG, while some may never reach readiness for either state.  To keep
> things moving along, draft status will be reviewed at the beginning of each
> research group meeting.  Open issues may be tracked on the wiki or in an
> issue tracker.  If a draft languishes (no progress on open issues) after
> being identified as a research group draft, it may be taken off the list of
> research group drafts at a future date.
>
> Below is a list of the drafts that have been discussed during the past year
> (aside from those that have been introduced to the RG for informational
> purposes such as RANGI and shim6 API) that we will add to the tracker.
>
> _______________________________________________
> hiprg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hiprg
>

---

From: Pascal Urien <[email-masked]>
Date: Wed, 2 Dec 2009 10:02:26 +0100

Dear all,

I support the idea to introduce HIP for Internet Of things as WG item. The
draft HIP for RF-ID (HIP-Tag) is part of a research project funded by the
Frenc National Researck Agency, and has been implemented for test purposes.
Code sources are available

The draft HIP and the IoT is a more general problem statement, dealing
with protocol issues for the Internet Of Things. My proposal sould be to
extend this draft as the first WG document for the IoT

Best Regards

Pascal

---

From: Varjonen Samu <[email-masked]>
Date: Wed, 02 Dec 2009 11:44:50 +0200

Hi,

I would change the point 13 in the list to HIP EAP since SRP has patent 
issues.

BR,
Samu

---

From: "Gyu Myoung Lee" <[email-masked]>
Date: Wed, 2 Dec 2009 12:22:06 +0100

Dear All

We have discussed several times for IoT related issues and many of you have
expressed the opinion that this topic is very interesting through HIP RG
meetings and mailing list discussion.

However, we still have various opinions on scope for this topic which the
HIP RG would deal with. In this regards, at the last Hiroshima meeting, the
IRTF chair mentioned that to create a new research group on IoT would be one
of possible solutions.  

So, it is very important to determine a right place for discussion on IoT.

First of all, we need to decide whether the HIP RG will develop a document
on conceptual requirements and architecture for IoT without limiting to HIP.
I believe that HIP can be one of candidate solutions in terms of object
naming.

With specific technical solutions like HIP for RF-ID, we should analyze
various cases with consideration of naming and addressing architecture which
other groups are developing.

Best Regards,

Gyu Myoung Lee

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pascal Urien
Sent: Wednesday, December 02, 2009 10:02 AM
To: Henderson, Thomas R
Cc: [email-masked]; [email-masked]
Subject: Re: [hiprg] HIPRG document process

Dear all,

The draft HIP and the IoT is a more general problem statement, dealing with
protocol issues for the Internet Of Things. My proposal sould be to extend
this draft as the first WG document for the IoT

Best Regards

Pascal

The purpose of advancing an independent submission to draft-irtf-hip status
is to reflect that the HIP research group desires to work towards publishing
the document as an IRTF-track RFC
(http://www.ietf.org/id/draft-irtf-rfcs-05.txt).  It may also be the case
that the document is later transferred to the HIP working group in the IETF
if the HIP working group wants to adopt it.

Once the document reaches IRSG state, a document shepherd will be appointed
(typically one of the RG chairs):
http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs#DocumentShepherds
The document shepherd will work with the authors to advance the document to
the state at which it is ready for IRSG review:
http://trac.tools.ietf.org/group/irtf/trac/wiki/IRTF-RFCs#IRSGReview.
While the RG will not officially have a "document shepherd" during the RG
preparation stage, the technical reviewers reviewing this draft for the RG
can look to the criteria in the above process in guiding their comments.

Of the above, we believe that the topics of HIP for Internet of Things, HI
revocation, HIP
DHT interface, and proxies each probably meet the criteria for level of
interest, although
in two cases (IoT and proxies) there are multiple contributions and we
should try to chart
out a process to end up with RG-level drafts.   It may be that others are
ready to move
forward at this time; please let us know your thoughts.

Please send your comments on the proposed process to the list, or let us
know if we are missing any drafts above.

- Tom and Andrei

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Wed, 2 Dec 2009 11:57:00 -0800

________________________________
From: Gyu Myoung Lee [mailto:[email-masked]]
Sent: Wednesday, December 02, 2009 3:22 AM
To: 'Pascal Urien'; Henderson, Thomas R
Cc: [email-masked]; [email-masked]
Subject: RE: [hiprg] HIPRG document process

Dear All

We have discussed several times for IoT related issues and many of you have expressed the opinion that this topic is very interesting through HIP RG meetings and mailing list discussion.
However, we still have various opinions on scope for this topic which the HIP RG would deal with. In this regards, at the last Hiroshima meeting, the IRTF chair mentioned that to create a new research group on IoT would be one of possible solutions.

I am not aware of any progress in creating a new research group on IoT.  As for HIP and IoT, we heard a concern that HIP was being selected as a solution for IoT prematurely, without considering other alternatives such as XMPP.

 So, it is very important to determine a right place for discussion on IoT.
First of all, we need to decide whether the HIP RG will develop a document on conceptual requirements and architecture for IoT without limiting to HIP. I believe that HIP can be one of candidate solutions in terms of object naming.

I think it is within scope for the HIP RG to study whether HIP can be a solution to IoT networking problems, and to consider whether HIP needs to be extended or modified to support such solutions.  However, I think it is probably out of scope to write drafts about whether a HIP-based architecture is the best way to solve IoT networking problems in general.

Is there another document (such as from Study Group 13) that you could point us to that discusses "conceptual requirements and architecture for IoT without limiting to HIP"?
With specific technical solutions like HIP for RF-ID, we should analyze various cases with consideration of naming and addressing architecture which other groups are developing.

We presently have two drafts that try to cover general naming and architectural issues:  draft-urien-hip-iot-00.txt and draft-lee-object-naming-01.txt, and both you and Pascal have separately suggested to move them forward as a RG draft, so we probably have to review that again and consider how we might end up with a single draft.

As for HIP for RF-ID draft, I'm not sure what you mean by "we should analyze various cases with consideration of naming and addressing architecture which other groups are developing," can you be more specific about the other groups to which you are referring?

Regards,
Tom