Subject: [hiprg] Adding Identity privacy to HIP DEX

From: Robert Moskowitz <[email-masked]>
Date: Wed, 06 Apr 2011 02:19:12 +0200

I faded early this evening and woke up in the middle of the night (hey, 
I am in Stockholm right now, it is 2am) with perhaps a wild idea that 
may make some sense.

I forfeited Identity privacy and PFS in DEX with moving the HI to ECDH 
and that ECDH exchange as the extent of the public key crypto in DEX.

Here is my thought.  The Initiator has TWO ECDH key pairs.  One is the 
HI, the other is an identity privacy key (IPK?).  I2 uses the IPK on the 
'outside' with the HI encrypted for an 'inner' ECDH protected exchange.  
The responders HI is still exposed.  It is ASSUMED that this is 
acceptable and that the Initiator has some mechanism to validate this HI 
to avoid a DH MITM.

I don't know if this is worth the effort to flesh out.  I have lots of 
other work to do on HIP-bis, HIP-DEX, core, and some Verizon projects.  
So I am asking here if others see Identity privacy as important enough 
to persue it?

---

From: Tobias Heer <[email-masked]>
Date: Wed, 06 Apr 2011 09:48:22 +0200

Hi Robert,

Am 06.04.2011 um 02:19 schrieb Robert Moskowitz:

> I faded early this evening and woke up in the middle of the night (hey, I am in Stockholm right now, it is 2am) with perhaps a wild idea that may make some sense.
> 
> I forfeited Identity privacy and PFS in DEX with moving the HI to ECDH and that ECDH exchange as the extent of the public key crypto in DEX.
> 
> Here is my thought.  The Initiator has TWO ECDH key pairs.  One is the HI, the other is an identity privacy key (IPK?).  I2 uses the IPK on the 'outside' with the HI encrypted for an 'inner' ECDH protected exchange.  The responders HI is still exposed.  It is ASSUMED that this is acceptable and that the Initiator has some mechanism to validate this HI to avoid a DH MITM.
> 
> I don't know if this is worth the effort to flesh out.  I have lots of other work to do on HIP-bis, HIP-DEX, core, and some Verizon projects.  So I am asking here if others see Identity privacy as important enough to persue it?
> 

Is your assumption that the outer DH exchange is not a static one? If it were static, you don't win much because the host can be identified by the outer DH key. If it is not a static DH, the host needs to generate a new DH key pair for each DEX. This can become quite costly.

Interesting idea, though!

Tobias

> 
> _______________________________________________
> hiprg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hiprg

-- 
Dipl.-Inform. Tobias Heer, Ph.D. Student
Chair of Communication and Distributed Systems - comsys
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://www.comsys.rwth-aachen.de/team/tobias-heer/
blog: http://dtobi.wordpress.com/
card: http://card.ly/dtobi
pgp id: AEECA5BF

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 06 Apr 2011 10:02:55 +0200

> Is your assumption that the outer DH exchange is not a static one? If it were static, you don't win much because the host can be identified by the outer DH key. If it is not a static DH, the host n…

Part of the issues that had my brain tied in knots and mis-firing for a 
while last night.