Subject: Re: [hiprg] HIPRG charter discussion

From: "Wendong WANG" <[email-masked]>
Date: Thu, 30 Jun 2011 11:30:51 +0800

Our team has interesting on the hierarchical HIT research work. we have already implemented a demo of ID-Locator mapping services based on HIP. 
We also hope to do more works on it for the future Internet mobility and security functions.
 
Wendong WANG
Beijing Universty of Posts and Telecommunications (BUPT) 
2011-06-30

> -----邮件原件-----
> 发件人: Andrei Gurtov [mailto:[email-masked]]
> 发送时间: 2011年6月14日 17:44
> 收件人: Xu Xiaohu
> 抄送: 'Henderson, Thomas R'; [email-masked]; [email-masked]
> 主题: Re: [hiprg] HIPRG charter discussion
> 
> 
> Hei Xiaohu,
> 
> That's an interesting topic, but there should be interest of several
> organizations to discuss and develop it jointly at HIPRG. Can you think
> of others who would be willing to commit to this topic for a couple
> years? Maybe China mobile, Tsinghua University?
> 
> Andrei
> 
> Xu Xiaohu wrote:
> > Hi Tom and all,
> >
> > I propose to consider taking the hierarchical HIT research as a new charter
> > item. IMHO, there are at least two major benefits of using hierarchical HITs
> > from the commercial deployment perspectives:
> >
> > First, the ID/HIT registration management service and the ID-to-Locator
> > mapping service corresponding to the hierarchical HITs could be run in a
> > hierarchical manner. In other words, such global mobility management
> service
> > systems could be operated by different countries and different operators
> > with clear administrative domain boundaries and reasonable business
> models,
> > just like the telephone number space in the telephone network and the home
> > address space in the mobile IP network. In addition, the existing DNS
> > infrastructure doesn't need to be changed largely. That's to say, HITs of
> > the HIP hosts could be stored directly as their corresponding AAAA RRs in
> > the existing DNS infrastructure.
> >
> > Second, the usage of hierarchical HITs will ease the transition for HIP. For
> > instance, legacy IPv6 hosts could access mobile HIP hosts via provider-owned
> > HIP proxy devices (just as home agents in the mobile IP network) since the
> > hierarchical HITs could be routable in the Internet. On the contrary,
> > ORCHIDs are not routable in the Internet since there is no reasonable
> > business motivation for operators to deploy HIP proxy devices for such flat
> > identifiers.
> >
> > There has been some proposals and presentations discussing about
> > hierarchical HITs in HIPRG before as follows:
> > http://tools.ietf.org/html/draft-xu-hip-hierarchical-02
> > http://tools.ietf.org/html/draft-kuptsov-hhit-02
> > http://tools.ietf.org/html/draft-xu-rangi-04
> >
> > By the way, we have implemented the RANGI
> > (http://tools.ietf.org/html/draft-xu-rangi-04) prototype which uses a
> > hierarchical and cryptographic host IDs with delegation-oriented structure.
> > Hope we could have a chance to show the implementation details and
> > verification results at the forthcoming IETF meeting in Quebec City.
> >
> > Best regards,
> > Xiaohu
> >
> >
> >> -----邮件原件-----
> >> 发件人: [email-masked] [mailto:[email-masked]] 代表
> >> Henderson, Thomas R
> >> 发送时间: 2011年6月6日 22:49
> >> 收件人: [email-masked]
> >> 抄送: [email-masked]'
> >> 主题: [hiprg] HIPRG charter discussion
> >>
> >> With the completion of the experiment report (our main RG charter item
> > since
> >> the RG's inception), I would like to ask about future directions of the
> > RG.
> >> Outside of completing our current RG drafts, we need to try to define some
> >> new collaborative work items and define what role the RG will play
> > relative to
> >> the WG.
> >>
> >> These work items should ideally satisfy the following criteria:
> >> - is the research area clear and relevant for the Internet community and
> > for
> >> HIP in particular?  What are the expected outcomes and impact?
> >> - will the RG foster work that would not be done otherwise?  For instance,
> >> participation drawn from more than a single institution or country.  Can
> > we
> >> try to identify individuals for this anticipated participation?
> >>
> >> We can have some discussion of this at the next meeting but I would like
> > to see
> >> whether we can start identifying some topics on the list before the
> > meeting.
> >> - Tom
> >> _______________________________________________
> >> hiprg mailing list
> >> [email-masked]
> >> https://www.irtf.org/mailman/listinfo/hiprg
> >
> > _______________________________________________
> > hiprg mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/hiprg

---

From: Andrei Gurtov <[email-masked]>
Date: Thu, 30 Jun 2011 09:32:24 +0300

Can you commit to attend the HIPRG meetings at IETF for one-two years to
 contribute to h-hip draft development or at least provide active
feedback on the mailing list (e.g. at least one email/week)?

Same question also applies to China mobile.

Andrei

Wendong WANG wrote:
> 
>  
> Our team has
> interesting on the hierarchical HIT research work. we have already implemented a demo of ID-Locator mapping services based on HIP. 
> ------------------------------------------------------------------------
>

---

From: "wdwang" <[email-masked]>
Date: Thu, 30 Jun 2011 07:23:36 -0000

Hei, Andrei

If H-HIP could be become a charter in HIPRG, I can commit to provide active feedback on the mailling list. Our team will very happy to do our contrbutions on H-HIP drafts and attend the HIPRG meeting at IETF.

Wendong WANG   

wdwang
2011-07-30

发件人： Andrei Gurtov
发送时间： 2011-06-30 15:04:06
收件人： Wendong WANG
抄送： hiprg
主题： Re: [hiprg] HIPRG charter discussion

---

From: Sean Shen 沈烁 <[email-masked]>
Date: Thu, 30 Jun 2011 15:34:34 +0800

I am interested in this topic and like to attend meetings and provide reviews.

Sean

From: [email-masked] [mailto:[email-masked]] On Behalf Of wdwang
Sent: Saturday, July 30, 2011 3:24 PM
To: Andrei Gurtov
Cc: hiprg
Subject: Re: [hiprg] HIPRG charter discussion

Hei, Andrei

Wendong WANG   

  _____  

wdwang

2011-07-30

  _____  

发件人： Andrei Gurtov

收件人： Wendong WANG

抄送： hiprg

Andrei

Wendong WANG wrote: