Subject: Re: [Hipsec] Status of HIP-DEX/BEX implementations

From: Miika Komu <[email-masked]>
Date: Tue, 4 Aug 2020 12:50:01 +0000

Hi Eric,

ti, 2020-07-14 kello 11:45 +0000, Eric Vyncke (evyncke) kirjoitti:
> [Bcc previous and current authors in HIP related documents]
>  
> In the framework of the IESG evaluation of HIP-DEX, it would be
> useful to know whether there are implementations of HIP-DEX.

sorry for not sending this earlier due to my vacations. I am aware of
three implementations (no idea about interoperability):

1. Contiki-based implementation 
https://www.researchgate.net/publication/259475424_Slimfit_-_A_HIP_DEX_compression_layer_for_the_IP-based_Internet_of_Things

2. Java: https://code.google.com/archive/p/hip-dex/

3. Java: https://github.com/juhovh/hip-dex/tree/master/SpotHIP
 
> In the same vein, getting a list of HIPv2 BEX (Base Exchange) would
> also be useful.

AFAIK, HIPv2 has been implemented and interoperated successfully by the
following implementations:

1. OpenHIP
2. HIP for Linux

(Maybe also by the HIP4Inter.net implementation but I am not sure about
this)

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 4 Aug 2020 14:17:52 +0000

Thank you Miika for these pieces of information.

Gonzalo, as you are the document shepherd for DEX, would you mind updating the write-up with this list of implementations?

For information, I have just request the IESG secretary to approve the HIP-NAT document as all DISCUSS & COMMENT points were addressed. Now, we need to get DEX through

-éric

-----Original Message-----
From: Miika Komu <[email-masked]>
Date: Tuesday, 4 August 2020 at 14:50
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Gonzalo Camarillo <[email-masked]>
Subject: Re: Status of HIP-DEX/BEX implementations

    Hi Eric,

    1. OpenHIP
    2. HIP for Linux